aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/ysm
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2002-05-28 15:52:19 +0800
committerfjoe <fjoe@FreeBSD.org>2002-05-28 15:52:19 +0800
commit28ea7144f25df19f44f2acca744cd043d9df0364 (patch)
treeba88d82bba76155a713877a31ce0978a06a167a2 /net-im/ysm
parent48d55748beca2c4d5fb1771766cf3ae71f42cb77 (diff)
downloadfreebsd-ports-gnome-28ea7144f25df19f44f2acca744cd043d9df0364.tar.gz
freebsd-ports-gnome-28ea7144f25df19f44f2acca744cd043d9df0364.tar.zst
freebsd-ports-gnome-28ea7144f25df19f44f2acca744cd043d9df0364.zip
New port: You Sick Me - command line ICQ client with ICQ2000 and
recoding support. YSM (You Sick Me) v7 is an ICQ console client. It was originally meant to run in Linux, but it has been successfully tested in FreeBSD, Win32, BeOS, and QNX. YSM is based on the last ICQ protocol version, v7/8. WWW: http://ysmv7.sourceforge.net/ PR: 38650 Submitted by: vampiro@rootshell.ru (MAINTAINER)
Diffstat (limited to 'net-im/ysm')
-rw-r--r--net-im/ysm/Makefile24
-rw-r--r--net-im/ysm/distinfo1
-rw-r--r--net-im/ysm/files/patch-Makefile13
-rw-r--r--net-im/ysm/files/patch-iconv24
-rw-r--r--net-im/ysm/files/patch-network13
-rw-r--r--net-im/ysm/files/patch-setup11
-rw-r--r--net-im/ysm/pkg-comment1
-rw-r--r--net-im/ysm/pkg-descr7
-rw-r--r--net-im/ysm/pkg-plist1
9 files changed, 95 insertions, 0 deletions
diff --git a/net-im/ysm/Makefile b/net-im/ysm/Makefile
new file mode 100644
index 000000000000..85c72be7cc8c
--- /dev/null
+++ b/net-im/ysm/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ysm
+# Date created: May 28, 2002
+# Whom: vampiro
+#
+# $FreeBSD$
+#
+
+PORTNAME= ysm
+PORTVERSION= 7.2.7.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ftp://vampiro.rootshell.ru/pub/warez/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ysmv7_2_7_1
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= vampiro@rootshell.ru
+
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+
+MAN1= ysm.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/net-im/ysm/distinfo b/net-im/ysm/distinfo
new file mode 100644
index 000000000000..830d83f69803
--- /dev/null
+++ b/net-im/ysm/distinfo
@@ -0,0 +1 @@
+MD5 (ysmv7_2_7_1.tgz) = 75cca9a9c9b48374fdfbbc8469ef54af
diff --git a/net-im/ysm/files/patch-Makefile b/net-im/ysm/files/patch-Makefile
new file mode 100644
index 000000000000..1472baa97709
--- /dev/null
+++ b/net-im/ysm/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Thu Jan 1 06:00:00 1970
++++ Makefile Tue May 28 12:06:00 2002
+@@ -0,0 +1,10 @@
++PROG= ysm
++CFLAGS+= -Wall -ansi -I/usr/local/include -DYSM_USE_ICONV
++LDADD+= -L/usr/local/lib -liconv
++PREFIX?= /usr/local
++BINDIR?= ${PREFIX}/bin
++SRCS= YSM_Main.c YSM_Network.c YSM_Prompt.c YSM_Setup.c \
++ YSM_ToolBox.c YSM_Slaves.c YSM_Help.c YSM_Win32.c
++MAN= docs/ysm.1
++MANDIR= ${PREFIX}/man/man
++.include <bsd.prog.mk>
diff --git a/net-im/ysm/files/patch-iconv b/net-im/ysm/files/patch-iconv
new file mode 100644
index 000000000000..68f9deb98200
--- /dev/null
+++ b/net-im/ysm/files/patch-iconv
@@ -0,0 +1,24 @@
+--- YSM_ToolBox.c.orig Fri Apr 12 11:07:38 2002
++++ YSM_ToolBox.c Tue May 28 11:19:33 2002
+@@ -45,6 +45,7 @@
+ #include "YSM.h"
+ /* International Languages Charset Convertion! */
+ #include "YSM_Iconv.h"
++#include <iconv.h>
+
+
+ static struct timeval tv;
+@@ -428,9 +429,12 @@
+ bytes_in = strlen(buf_from) + 1;
+ bytes_out = maxlen - 1;
+ conv_d = iconv_open(charset_to, charset_from);
+- bytes_res = iconv(conv_d, &inptr, &bytes_in, &outptr, &bytes_out);
++ if ( conv_d == (iconv_t)( -1)) { perror("iconv_open:"); return -1; }
++ else {
++ bytes_res = iconv(conv_d, (const char **)&inptr, &bytes_in, &outptr, &bytes_out);
+ iconv_close(conv_d);
+ return 0;
++ }
+ }
+
+ #endif
diff --git a/net-im/ysm/files/patch-network b/net-im/ysm/files/patch-network
new file mode 100644
index 000000000000..4d3590511652
--- /dev/null
+++ b/net-im/ysm/files/patch-network
@@ -0,0 +1,13 @@
+--- YSM_Network.c.orig Fri Apr 12 11:07:38 2002
++++ YSM_Network.c Tue May 28 11:18:47 2002
+@@ -1547,8 +1547,8 @@
+ int log_len = 0;
+
+ #ifdef YSM_USE_ICONV
+- if( YSM_Iconv( YSM_SETTING_CHARSET_TRANS,
+- YSM_SETTING_CHARSET_LOCAL,
++ if( YSM_Iconv( YSM_SETTING_CHARSET_LOCAL,
++ YSM_SETTING_CHARSET_TRANS,
+ data,
+ &data_conv,
+ YSM_ICONV_MAXLEN) < 0 )
diff --git a/net-im/ysm/files/patch-setup b/net-im/ysm/files/patch-setup
new file mode 100644
index 000000000000..20011b82dbbc
--- /dev/null
+++ b/net-im/ysm/files/patch-setup
@@ -0,0 +1,11 @@
+--- YSM_Setup.c.orig Fri Apr 12 11:07:38 2002
++++ YSM_Setup.c Tue May 28 11:21:08 2002
+@@ -441,7 +441,7 @@
+
+ fprintf(YSM_CFGFD,"\n# TRANS_CHARSET is charset for transfering/receiving of messages");
+ fprintf(YSM_CFGFD,"\n# LOCAL_CHARSET is charset for displaying/inputting of messages");
+- fprintf(YSM_CFGFD,"\n# Russian Generic are TRANS: CP1251 LOCAL: KOI8R\n");
++ fprintf(YSM_CFGFD,"\n# Russian Generic are TRANS: CP1251 LOCAL: KOI8-R\n");
+ fprintf(YSM_CFGFD,"\nCHARSET_TRANS>0");
+ fprintf(YSM_CFGFD,"\nCHARSET_LOCAL>0");
+ #endif
diff --git a/net-im/ysm/pkg-comment b/net-im/ysm/pkg-comment
new file mode 100644
index 000000000000..9bbcc6f43154
--- /dev/null
+++ b/net-im/ysm/pkg-comment
@@ -0,0 +1 @@
+Command line ICQ client with ICQ2000 and recoding support
diff --git a/net-im/ysm/pkg-descr b/net-im/ysm/pkg-descr
new file mode 100644
index 000000000000..9d8f03625e03
--- /dev/null
+++ b/net-im/ysm/pkg-descr
@@ -0,0 +1,7 @@
+You Sick Me - command line ICQ client with ICQ2000 and recoding support
+
+YSM (You Sick Me) v7 is an ICQ console client. It was originally meant to
+run in Linux, but it has been successfully tested in FreeBSD, Win32, BeOS,
+and QNX. YSM is based on the last ICQ protocol version, v7/8.
+
+WWW: http://ysmv7.sourceforge.net/
diff --git a/net-im/ysm/pkg-plist b/net-im/ysm/pkg-plist
new file mode 100644
index 000000000000..41b2ae474002
--- /dev/null
+++ b/net-im/ysm/pkg-plist
@@ -0,0 +1 @@
+bin/ysm