aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2016-06-01 04:06:41 +0800
committerThierry Thomas <thierry@FreeBSD.org>2016-06-01 04:06:41 +0800
commit03ecb47a7712a17797893dbfa588de999f954897 (patch)
tree9e73fad7cd666fcbbe313af814ca9f23757f1fc4 /net-im
parentae38172850352a5fc59a6af31fdcb50ca2967e28 (diff)
downloadfreebsd-ports-gnome-03ecb47a7712a17797893dbfa588de999f954897.tar.gz
freebsd-ports-gnome-03ecb47a7712a17797893dbfa588de999f954897.tar.zst
freebsd-ports-gnome-03ecb47a7712a17797893dbfa588de999f954897.zip
Update to 20160530 v0.9.5.
PR: 209906 Submitted by: Ivan Klymenko (maintainer)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/uTox/Makefile7
-rw-r--r--net-im/uTox/distinfo4
-rw-r--r--net-im/uTox/files/patch-Makefile12
3 files changed, 14 insertions, 9 deletions
diff --git a/net-im/uTox/Makefile b/net-im/uTox/Makefile
index 60bc11bef973..cf009e3e96ef 100644
--- a/net-im/uTox/Makefile
+++ b/net-im/uTox/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= uTox
-PORTVERSION= 0.8.2.20160511
+PORTVERSION= 0.9.5.20160530
CATEGORIES= net-im net-p2p
MAINTAINER= fidaj@ukr.net
@@ -17,12 +17,13 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libsodium.so:security/libsodium \
libv4lconvert.so:multimedia/libv4l \
libvpx.so:multimedia/libvpx \
- libfilteraudio.so:audio/libfilteraudio
+ libfilteraudio.so:audio/libfilteraudio\
+ libopus.so:audio/opus
RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= GrayHatter
-GH_TAGNAME= cc4388c
+GH_TAGNAME= c85c747
USES= compiler:c11 desktop-file-utils gmake openal:al pkgconfig
USE_XORG= x11 xext xrender
diff --git a/net-im/uTox/distinfo b/net-im/uTox/distinfo
index 63de3acfa206..9ca546e20350 100644
--- a/net-im/uTox/distinfo
+++ b/net-im/uTox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (GrayHatter-uTox-0.8.2.20160511-cc4388c_GH0.tar.gz) = 7c436cec5bd524ffcce3e1824dbebb7a93a121d0bc5d6860f8dadd1494e67067
-SIZE (GrayHatter-uTox-0.8.2.20160511-cc4388c_GH0.tar.gz) = 2015584
+SHA256 (GrayHatter-uTox-0.9.5.20160530-c85c747_GH0.tar.gz) = 43aaad041c7a830bc7e422908855f314f396c4c9e30577e86c225a3b5377c93e
+SIZE (GrayHatter-uTox-0.9.5.20160530-c85c747_GH0.tar.gz) = 2020325
diff --git a/net-im/uTox/files/patch-Makefile b/net-im/uTox/files/patch-Makefile
index b5fe71591864..ecd24762d964 100644
--- a/net-im/uTox/files/patch-Makefile
+++ b/net-im/uTox/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2016-05-10 07:09:15 UTC
+--- Makefile.orig 2016-05-30 04:33:35 UTC
+++ Makefile
@@ -2,9 +2,9 @@
# set to anything else to disable them
@@ -12,7 +12,7 @@
DEPS = libtoxav libtoxcore openal vpx libsodium
-@@ -54,6 +54,37 @@ ifeq ($(UNAME_S), Linux)
+@@ -54,6 +54,40 @@ ifeq ($(UNAME_S), Linux)
TRAY_OBJ = icons/utox-128x128.o
TRAY_GEN = $(LD) -r -b binary icons/utox-128x128.png -o
@@ -34,13 +34,16 @@
+
+ ifeq ($(DBUS), 1)
+ DEPS += dbus-1
++ CFLAGS += -DHAVE_DBUS
+ else
+ CFLAGS += -DNO_DBUS
+ endif
+
-+ CFLAGS += $(shell pkg-config --cflags $(DEPS))
++ PKG_CONFIG = pkg-config
+
-+ LDFLAGS += $(shell pkg-config --libs $(DEPS))
++ CFLAGS += $(shell $(PKG_CONFIG) --cflags $(DEPS))
++
++ LDFLAGS += $(shell $(PKG_CONFIG) --libs $(DEPS))
+
+ OS_SRC = $(wildcard src/xlib/*.c)
+ OS_OBJ = $(OS_SRC:.c=.o)
@@ -49,3 +52,4 @@
+ TRAY_GEN = $(LD) -r -b binary icons/utox-128x128.png -o
else ifeq ($(UNAME_O), Cygwin)
OUT_FILE = utox.exe
+