aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2011-07-19 16:01:35 +0800
committermarcus <marcus@FreeBSD.org>2011-07-19 16:01:35 +0800
commit04d9669c0818797becbf80d202214868d4286a51 (patch)
treea23c2a1e243cd4d9081961a26aea2c2a0d40ecf1 /net-im
parent83f6e98e02fb9e147c7cf7ab2aa81009047395fb (diff)
downloadfreebsd-ports-gnome-04d9669c0818797becbf80d202214868d4286a51.tar.gz
freebsd-ports-gnome-04d9669c0818797becbf80d202214868d4286a51.tar.zst
freebsd-ports-gnome-04d9669c0818797becbf80d202214868d4286a51.zip
Fix a bug where chat rooms/channels can appear multiple times. This is
taken from http://developer.pidgin.im/ticket/14351 . PR: 158814 Submitted by: Armin Pirkovitsch <armin@frozen-zone.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libpurple/Makefile2
-rw-r--r--net-im/libpurple/files/patch-libpurple-conversation.c10
-rw-r--r--net-im/pidgin/Makefile2
3 files changed, 12 insertions, 2 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 5f1f4bb034db..d320d9fcf5f2 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -8,7 +8,7 @@
PORTNAME?= libpurple
PORTVERSION= 2.9.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net-im
MASTER_SITES= SF/pidgin/Pidgin/${PORTVERSION}
DISTNAME= pidgin-${PORTVERSION}
diff --git a/net-im/libpurple/files/patch-libpurple-conversation.c b/net-im/libpurple/files/patch-libpurple-conversation.c
new file mode 100644
index 000000000000..992769c8bfcd
--- /dev/null
+++ b/net-im/libpurple/files/patch-libpurple-conversation.c
@@ -0,0 +1,10 @@
+--- libpurple/conversation.c.orig 2011-07-11 14:28:20.000000000 +0200
++++ libpurple/conversation.c 2011-07-11 14:28:47.000000000 +0200
+@@ -1978,7 +1978,6 @@
+ }
+
+ g_hash_table_remove_all(chat->users);
+- chat->users = NULL;
+
+ g_list_free(users);
+ chat->in_room = NULL;
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index 4a42ce98681f..ed5d7e46b499 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= pidgin
-PORTREVISION= 0
+PORTREVISION= 1
MAINTAINER= marcus@FreeBSD.org
COMMENT= Pidgin multi-protocol messaging client (GTK+ UI)