aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2019-01-16 19:13:44 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2019-01-16 19:13:44 +0800
commit1bf487d3e73d83700f5a4aeb3a9ffbfc6e87856b (patch)
tree127ae6686665fd0ff97a7bd5f27449299929734e /net-im
parentd20d8aa75e51f61da14ac206199a1ebc244f940a (diff)
downloadfreebsd-ports-gnome-1bf487d3e73d83700f5a4aeb3a9ffbfc6e87856b.tar.gz
freebsd-ports-gnome-1bf487d3e73d83700f5a4aeb3a9ffbfc6e87856b.tar.zst
freebsd-ports-gnome-1bf487d3e73d83700f5a4aeb3a9ffbfc6e87856b.zip
Fix Qt5 symbol version scripts to put the catch-all clause first. When
a symbol matches multiple clauses the last one takes precedence. If the catch-all is last it captures everything. In the case of Qt5 libraries this caused all symbols to have a Qt_5 label while some should have Qt_5_PRIVATE_API. This only affects lld because GNU ld always gives the catch-all lowest priority. Older versions of Qt5Webengine exported some memory allocation symbols from the bundled Chromium. Version 5.9 stopped exporting these [1] but the symbols were kept as weak wrappers for the standard allocation functions to maintain binary compatibility. [2][3] The problem is that the call to the standard function in these weak wrappers is only resolved to the standard function if there's a call to this standard function in other parts of Qt5Webengine, because only then is there a non-weak symbol that takes precedence over the weak one. If there's no such non-weak symbol the call in the weak wrapper resolves to the weak wrapper itself creating an infinite call loop that overflows the stack and causes a crash. Some of the allocation functions are variants of C++ new and delete and it probably depends on the compiler whether these variants are used in other parts of Qt5Webengine. Remove the weak wrappers (make them Linux specific). This isn't binary compatible but we are already breaking that with the changes to the symbol versions. [1] https://github.com/qt/qtwebengine/commit/5c2cbfccf9aafb547b0b30914c4056abd25942a4 [2] https://github.com/qt/qtwebengine/commit/2ed5054e3a800fa97c2c9e920ba1e6ea4b6ef2a5 [3] https://github.com/qt/qtwebengine/commit/009f5ebb4bd6e50188671e0815a5dae6afe39db5 Bump all ports that depend on Qt5. PR: 234070 Exp-run by: antoine Approved by: kde (adridg)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/cutegram/Makefile2
-rw-r--r--net-im/diligent/Makefile2
-rw-r--r--net-im/gitterdone/Makefile1
-rw-r--r--net-im/kaccounts-integration/Makefile1
-rw-r--r--net-im/kaccounts-providers/Makefile1
-rw-r--r--net-im/kde-telepathy/Makefile1
-rw-r--r--net-im/kopete/Makefile1
-rw-r--r--net-im/ktp-accounts-kcm/Makefile1
-rw-r--r--net-im/ktp-approver/Makefile1
-rw-r--r--net-im/ktp-auth-handler/Makefile1
-rw-r--r--net-im/ktp-call-ui/Makefile1
-rw-r--r--net-im/ktp-common-internals/Makefile1
-rw-r--r--net-im/ktp-contact-list/Makefile1
-rw-r--r--net-im/ktp-contact-runner/Makefile1
-rw-r--r--net-im/ktp-desktop-applets/Makefile1
-rw-r--r--net-im/ktp-filetransfer-handler/Makefile1
-rw-r--r--net-im/ktp-kded-module/Makefile1
-rw-r--r--net-im/ktp-send-file/Makefile1
-rw-r--r--net-im/ktp-text-ui/Makefile1
-rw-r--r--net-im/libaccounts-qt5/Makefile2
-rw-r--r--net-im/libjreen/Makefile2
-rw-r--r--net-im/libqtelegram-ae/Makefile2
-rw-r--r--net-im/libsignon-glib/Makefile2
-rw-r--r--net-im/licq-osd/Makefile2
-rw-r--r--net-im/licq-qt-gui/Makefile2
-rw-r--r--net-im/psi/Makefile1
-rw-r--r--net-im/qTox/Makefile2
-rw-r--r--net-im/qxmpp-qt5/Makefile1
-rw-r--r--net-im/qxmpp/Makefile2
-rw-r--r--net-im/ricochet/Makefile2
-rw-r--r--net-im/scudcloud/Makefile1
-rw-r--r--net-im/teamwords/Makefile2
-rw-r--r--net-im/telegram-desktop/Makefile1
-rw-r--r--net-im/telegramqml/Makefile2
-rw-r--r--net-im/telepathy-accounts-signon/Makefile1
-rw-r--r--net-im/telepathy-logger-qt5/Makefile2
-rw-r--r--net-im/telepathy-qt/Makefile2
-rw-r--r--net-im/turpial/Makefile2
38 files changed, 38 insertions, 16 deletions
diff --git a/net-im/cutegram/Makefile b/net-im/cutegram/Makefile
index e2a4f170bf3f..a1eded237e67 100644
--- a/net-im/cutegram/Makefile
+++ b/net-im/cutegram/Makefile
@@ -5,7 +5,7 @@ PORTNAME= cutegram
PORTVERSION= 2.7.1
DISTVERSIONPREFIX= v
DISTVERSIONSUFFIX= -stable
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MAINTAINER= henry.hu.sh@gmail.com
diff --git a/net-im/diligent/Makefile b/net-im/diligent/Makefile
index 63752e76f62b..38558244a861 100644
--- a/net-im/diligent/Makefile
+++ b/net-im/diligent/Makefile
@@ -3,7 +3,7 @@
PORTNAME= diligent
PORTVERSION= 0.2.7
-PORTREVISION= 6
+PORTREVISION= 7
DISTVERSIONPREFIX= v
CATEGORIES= net-im
diff --git a/net-im/gitterdone/Makefile b/net-im/gitterdone/Makefile
index db285a6dbe13..9d8ec4d5d060 100644
--- a/net-im/gitterdone/Makefile
+++ b/net-im/gitterdone/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gitterdone
PORTVERSION= 201710031257
+PORTREVISION= 1
CATEGORIES= net-im
MAINTAINER= jt@ixsystems.com
diff --git a/net-im/kaccounts-integration/Makefile b/net-im/kaccounts-integration/Makefile
index c33f9d0b67bf..8c03a2212477 100644
--- a/net-im/kaccounts-integration/Makefile
+++ b/net-im/kaccounts-integration/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kaccounts-integration
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/kaccounts-providers/Makefile b/net-im/kaccounts-providers/Makefile
index a328507ae07e..39b112abc24c 100644
--- a/net-im/kaccounts-providers/Makefile
+++ b/net-im/kaccounts-providers/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kaccounts-providers
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/kde-telepathy/Makefile b/net-im/kde-telepathy/Makefile
index 89393d99e5b6..d86fae39adfa 100644
--- a/net-im/kde-telepathy/Makefile
+++ b/net-im/kde-telepathy/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kde-telepathy
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/kopete/Makefile b/net-im/kopete/Makefile
index 15e0d8402f3c..1c3fc928cb17 100644
--- a/net-im/kopete/Makefile
+++ b/net-im/kopete/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kopete
PORTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-accounts-kcm/Makefile b/net-im/ktp-accounts-kcm/Makefile
index c93469e92a0b..7369bffacaca 100644
--- a/net-im/ktp-accounts-kcm/Makefile
+++ b/net-im/ktp-accounts-kcm/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-accounts-kcm
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-approver/Makefile b/net-im/ktp-approver/Makefile
index 7a8135e9cf77..4f8b2b7ecdde 100644
--- a/net-im/ktp-approver/Makefile
+++ b/net-im/ktp-approver/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-approver
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-auth-handler/Makefile b/net-im/ktp-auth-handler/Makefile
index e6c69441dd2c..af55eeeaffc7 100644
--- a/net-im/ktp-auth-handler/Makefile
+++ b/net-im/ktp-auth-handler/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-auth-handler
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-call-ui/Makefile b/net-im/ktp-call-ui/Makefile
index 63ad066e0f44..06fd4f2099a3 100644
--- a/net-im/ktp-call-ui/Makefile
+++ b/net-im/ktp-call-ui/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-call-ui
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-common-internals/Makefile b/net-im/ktp-common-internals/Makefile
index fb9e23a2847a..3f9f4a5ea95e 100644
--- a/net-im/ktp-common-internals/Makefile
+++ b/net-im/ktp-common-internals/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-common-internals
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-contact-list/Makefile b/net-im/ktp-contact-list/Makefile
index e446a46c4d21..17fd860d9c7d 100644
--- a/net-im/ktp-contact-list/Makefile
+++ b/net-im/ktp-contact-list/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-contact-list
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-contact-runner/Makefile b/net-im/ktp-contact-runner/Makefile
index a48b860b7cdd..726d13ccb89c 100644
--- a/net-im/ktp-contact-runner/Makefile
+++ b/net-im/ktp-contact-runner/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-contact-runner
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-desktop-applets/Makefile b/net-im/ktp-desktop-applets/Makefile
index 7ba4ee186a6c..ee0ab4e5fece 100644
--- a/net-im/ktp-desktop-applets/Makefile
+++ b/net-im/ktp-desktop-applets/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-desktop-applets
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-filetransfer-handler/Makefile b/net-im/ktp-filetransfer-handler/Makefile
index 883bc0a294a4..7491e02a4606 100644
--- a/net-im/ktp-filetransfer-handler/Makefile
+++ b/net-im/ktp-filetransfer-handler/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-filetransfer-handler
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-kded-module/Makefile b/net-im/ktp-kded-module/Makefile
index fdd0db4c3071..792da9ac0652 100644
--- a/net-im/ktp-kded-module/Makefile
+++ b/net-im/ktp-kded-module/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-kded-module
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-send-file/Makefile b/net-im/ktp-send-file/Makefile
index 7cccdca12b72..547a943a02cf 100644
--- a/net-im/ktp-send-file/Makefile
+++ b/net-im/ktp-send-file/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-send-file
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-text-ui/Makefile b/net-im/ktp-text-ui/Makefile
index 4c70aee9d6b7..665d902144d9 100644
--- a/net-im/ktp-text-ui/Makefile
+++ b/net-im/ktp-text-ui/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-text-ui
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/libaccounts-qt5/Makefile b/net-im/libaccounts-qt5/Makefile
index 74ed526061fa..0d24802e5161 100644
--- a/net-im/libaccounts-qt5/Makefile
+++ b/net-im/libaccounts-qt5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libaccounts-qt5
PORTVERSION= 1.13
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net-im
MASTER_SITES= https://drive.google.com/uc?export=download&id=0B8fX9XOwH_g4cTRCaktXNDRmMXM&dummy= \
LOCAL/rakuco
diff --git a/net-im/libjreen/Makefile b/net-im/libjreen/Makefile
index 121ebf6e2971..5698415bc4d2 100644
--- a/net-im/libjreen/Makefile
+++ b/net-im/libjreen/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libjreen
PORTVERSION= 1.1.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MAINTAINER= akuz84@gmail.com
diff --git a/net-im/libqtelegram-ae/Makefile b/net-im/libqtelegram-ae/Makefile
index 86fa01ae033f..35fc8db21607 100644
--- a/net-im/libqtelegram-ae/Makefile
+++ b/net-im/libqtelegram-ae/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libqtelegram-ae
PORTVERSION= 6.1
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONPREFIX= v
DISTVERSIONSUFFIX= -stable
CATEGORIES= net-im
diff --git a/net-im/libsignon-glib/Makefile b/net-im/libsignon-glib/Makefile
index da03dd148d69..40e7cd3c78d1 100644
--- a/net-im/libsignon-glib/Makefile
+++ b/net-im/libsignon-glib/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libsignon-glib
PORTVERSION= 1.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
DIST_SUBDIR= KDE/${GL_ACCOUNT}
diff --git a/net-im/licq-osd/Makefile b/net-im/licq-osd/Makefile
index ef14211bb6af..268f257c506a 100644
--- a/net-im/licq-osd/Makefile
+++ b/net-im/licq-osd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= osd
PORTVERSION= 1.9.0
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= net-im
PKGNAMEPREFIX= licq-
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index 271b6a8def89..ad0aa1072b4e 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qt-gui
PORTVERSION= 1.9.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net-im
PKGNAMEPREFIX= licq-
PKGNAMESUFFIX?= ${KDE_SUFFIX}${PKGNAMESUFFIX2}
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index 5d6191e14774..b3e02a3f6db3 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= psi
DISTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= SF/${PORTNAME}/Psi/${PORTVERSION}
diff --git a/net-im/qTox/Makefile b/net-im/qTox/Makefile
index f320a9dac9a0..a0d34b21c0e3 100644
--- a/net-im/qTox/Makefile
+++ b/net-im/qTox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= qTox
DISTVERSIONPREFIX= v
DISTVERSION= 1.16.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-im net-p2p
MAINTAINER= yuri@FreeBSD.org
diff --git a/net-im/qxmpp-qt5/Makefile b/net-im/qxmpp-qt5/Makefile
index fcb688709920..f42fe406fc1e 100644
--- a/net-im/qxmpp-qt5/Makefile
+++ b/net-im/qxmpp-qt5/Makefile
@@ -1,5 +1,6 @@
# $FreeBSD$
+PORTREVISION= 2
PKGNAMESUFFIX= -qt5
CONFLICTS= qxmpp-[0-9]*
diff --git a/net-im/qxmpp/Makefile b/net-im/qxmpp/Makefile
index a8194faafffc..0f1b73f28808 100644
--- a/net-im/qxmpp/Makefile
+++ b/net-im/qxmpp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qxmpp
PORTVERSION= 0.9.3
-PORTREVISION= 1
+PORTREVISION?= 1 # net-im/qxmpp-qt5
DISTVERSIONPREFIX= v
CATEGORIES= net-im
diff --git a/net-im/ricochet/Makefile b/net-im/ricochet/Makefile
index 2eb81808b244..8fd498196114 100644
--- a/net-im/ricochet/Makefile
+++ b/net-im/ricochet/Makefile
@@ -4,7 +4,7 @@
PORTNAME= ricochet
PORTVERSION= 1.1.4
DISTVERSIONPREFIX= v
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= net-im net-p2p
MAINTAINER= yuri@FreeBSD.org
diff --git a/net-im/scudcloud/Makefile b/net-im/scudcloud/Makefile
index 36229adb4084..2c11fa0ca929 100644
--- a/net-im/scudcloud/Makefile
+++ b/net-im/scudcloud/Makefile
@@ -4,6 +4,7 @@
PORTNAME= scudcloud
PORTVERSION= 1.65
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= net-im
MAINTAINER= nivit@FreeBSD.org
diff --git a/net-im/teamwords/Makefile b/net-im/teamwords/Makefile
index a7bb1cbe784c..3bc0e728907f 100644
--- a/net-im/teamwords/Makefile
+++ b/net-im/teamwords/Makefile
@@ -4,7 +4,7 @@
PORTNAME= teamwords
PORTVERSION= 0.2.1
DISTVERSIONPREFIX= v
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-im
MAINTAINER= kmoore@FreeBSD.org
diff --git a/net-im/telegram-desktop/Makefile b/net-im/telegram-desktop/Makefile
index 8d46e098c18c..c55266bac611 100644
--- a/net-im/telegram-desktop/Makefile
+++ b/net-im/telegram-desktop/Makefile
@@ -3,6 +3,7 @@
PORTNAME= telegram-desktop
DISTVERSIONPREFIX= v
DISTVERSION= 1.5.4
+PORTREVISION= 1
CATEGORIES= net-im
MAINTAINER= henry.hu.sh@gmail.com
diff --git a/net-im/telegramqml/Makefile b/net-im/telegramqml/Makefile
index 3ba0e403382f..64d2267b19b0 100644
--- a/net-im/telegramqml/Makefile
+++ b/net-im/telegramqml/Makefile
@@ -4,7 +4,7 @@
PORTNAME= telegramqml
PORTVERSION= 0.9.2
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-im
MAINTAINER= henry.hu.sh@gmail.com
diff --git a/net-im/telepathy-accounts-signon/Makefile b/net-im/telepathy-accounts-signon/Makefile
index 01a00da0bed9..bcf41a538885 100644
--- a/net-im/telepathy-accounts-signon/Makefile
+++ b/net-im/telepathy-accounts-signon/Makefile
@@ -2,6 +2,7 @@
PORTNAME= telepathy-accounts-signon
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= net-im
DIST_SUBDIR= KDE/${GL_ACCOUNT}
diff --git a/net-im/telepathy-logger-qt5/Makefile b/net-im/telepathy-logger-qt5/Makefile
index 6483fb5d2918..6c0e5faa6444 100644
--- a/net-im/telepathy-logger-qt5/Makefile
+++ b/net-im/telepathy-logger-qt5/Makefile
@@ -2,7 +2,7 @@
PORTNAME= telepathy-logger-qt
DISTVERSION= 17.08.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION:R}/src
diff --git a/net-im/telepathy-qt/Makefile b/net-im/telepathy-qt/Makefile
index ecfb5db41a11..479fc37da457 100644
--- a/net-im/telepathy-qt/Makefile
+++ b/net-im/telepathy-qt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= telepathy-qt
PORTVERSION= 0.9.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-im
MASTER_SITES= https://telepathy.freedesktop.org/releases/${PORTNAME}/
diff --git a/net-im/turpial/Makefile b/net-im/turpial/Makefile
index 87671699cf13..64eaae7b32ce 100644
--- a/net-im/turpial/Makefile
+++ b/net-im/turpial/Makefile
@@ -3,7 +3,7 @@
PORTNAME= turpial
PORTVERSION= 3.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-im python
MASTER_SITES= http://files.turpial.org.ve/sources/stable/