aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorjesper <jesper@FreeBSD.org>2005-04-30 17:20:14 +0800
committerjesper <jesper@FreeBSD.org>2005-04-30 17:20:14 +0800
commit23037eea70ce3b64a7daba6ca99025537a0a50c2 (patch)
tree3cc8fab1b6505477acca3fc414777554fb932f91 /net-im
parent0282aa30bcc1eca70b479b307ee7c48a7d4c5c11 (diff)
downloadfreebsd-ports-gnome-23037eea70ce3b64a7daba6ca99025537a0a50c2.tar.gz
freebsd-ports-gnome-23037eea70ce3b64a7daba6ca99025537a0a50c2.tar.zst
freebsd-ports-gnome-23037eea70ce3b64a7daba6ca99025537a0a50c2.zip
Fix crash when someone initiate IM with us, fixed in meanwhile CVS via
bugid 1192747 https://sourceforge.net/tracker/index.php?func=detail&aid=1192747&group_id=110565&atid=656718 Approved by: marcus
Diffstat (limited to 'net-im')
-rw-r--r--net-im/meanwhile/Makefile1
-rw-r--r--net-im/meanwhile/files/patch-srvc_im.c19
2 files changed, 20 insertions, 0 deletions
diff --git a/net-im/meanwhile/Makefile b/net-im/meanwhile/Makefile
index e780789557a7..b6e741dda6c9 100644
--- a/net-im/meanwhile/Makefile
+++ b/net-im/meanwhile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= meanwhile
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net-im/meanwhile/files/patch-srvc_im.c b/net-im/meanwhile/files/patch-srvc_im.c
new file mode 100644
index 000000000000..acca3e34e73e
--- /dev/null
+++ b/net-im/meanwhile/files/patch-srvc_im.c
@@ -0,0 +1,19 @@
+--- src/srvc_im.c.orig Fri Apr 29 23:38:46 2005
++++ src/srvc_im.c Fri Apr 29 23:39:28 2005
+@@ -272,7 +272,6 @@
+ static int send_accept(struct mwConversation *c) {
+ struct mwChannel *chan = c->channel;
+ struct mwSession *s = mwChannel_getSession(chan);
+- struct mwUserStatus *stat = mwSession_getUserStatus(s);
+ struct mwPutBuffer *b;
+ struct mwOpaque *o;
+
+@@ -284,8 +283,6 @@
+ o = mwChannel_getAddtlAccept(chan);
+ mwOpaque_clear(o);
+ mwPutBuffer_finalize(o, b);
+-
+- mwUserStatus_put(b, stat);
+
+ return mwChannel_accept(chan);
+ }