aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2019-03-25 18:40:41 +0800
committeradridg <adridg@FreeBSD.org>2019-03-25 18:40:41 +0800
commit2e6e521784c309257a6e4be6da880c29eede5d95 (patch)
treec3df1a71ca273e170ad40d062b9de344f984eab3 /net-im
parent5589bd59a261c45b89cd7358494957ab1e4f7ba1 (diff)
downloadfreebsd-ports-gnome-2e6e521784c309257a6e4be6da880c29eede5d95.tar.gz
freebsd-ports-gnome-2e6e521784c309257a6e4be6da880c29eede5d95.tar.zst
freebsd-ports-gnome-2e6e521784c309257a6e4be6da880c29eede5d95.zip
New ports security/olm and net-im/mtxclient
These are support libraries for Matrix clients; Nheko in particular. Until I wrap-up Nheko, they aren't used by anything.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/mtxclient/Makefile40
-rw-r--r--net-im/mtxclient/distinfo3
-rw-r--r--net-im/mtxclient/files/patch-include_mtx_responses_groups.hpp10
-rw-r--r--net-im/mtxclient/pkg-descr6
-rw-r--r--net-im/mtxclient/pkg-plist57
6 files changed, 117 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 6191857a2735..b6ffaab17014 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -76,6 +76,7 @@ PORTREVISION= 1
SUBDIR += mcabber
SUBDIR += meanwhile
SUBDIR += mikutter
+ SUBDIR += mtxclient
SUBDIR += mu-conference
SUBDIR += openfire
SUBDIR += oysttyer
diff --git a/net-im/mtxclient/Makefile b/net-im/mtxclient/Makefile
new file mode 100644
index 000000000000..a14aaa7fcd87
--- /dev/null
+++ b/net-im/mtxclient/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= mtxclient
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.0
+CATEGORIES= net-im
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= Client API library for the Matrix protocol
+
+LICENSE= MIT
+LICENSE_FILES= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json \
+ spdlog>=1.3:devel/spdlog \ \
+ gtest-config:devel/googletest
+LIB_DEPENDS= libsodium.so:security/libsodium \
+ libboost_date_time.so:devel/boost-libs \
+ libboost_chrono.so:devel/boost-libs \
+ libboost_iostreams.so:devel/boost-libs \
+ libboost_random.so:devel/boost-libs \
+ libboost_regex.so:devel/boost-libs \
+ libboost_system.so:devel/boost-libs \
+ libboost_thread.so:devel/boost-libs \
+ libolm.so:security/olm
+
+USES= cmake compiler:c++11-lang pkgconfig \
+ localbase:ldflags tar:xz
+
+USE_GITHUB= yes
+GH_ACCOUNT= Nheko-Reborn
+
+# 71 files use #include <json.hpp>, which needs to be
+# elsewhere; an alternative would be to bung in -I${LOCALBASE}/include/nlohmann
+post-patch:
+ ${FIND} ${WRKSRC} -type f -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} \
+ 's+include <json.hpp>+include <nlohmann/json.hpp>+'
+
+.include <bsd.port.mk>
diff --git a/net-im/mtxclient/distinfo b/net-im/mtxclient/distinfo
new file mode 100644
index 000000000000..fa34360a135f
--- /dev/null
+++ b/net-im/mtxclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1553378997
+SHA256 (Nheko-Reborn-mtxclient-v0.2.0_GH0.tar.gz) = e7638d4a8233c0c763d48111fd13e8ad1dcd5f34e3e641b46eaf1bb920b73482
+SIZE (Nheko-Reborn-mtxclient-v0.2.0_GH0.tar.gz) = 477869
diff --git a/net-im/mtxclient/files/patch-include_mtx_responses_groups.hpp b/net-im/mtxclient/files/patch-include_mtx_responses_groups.hpp
new file mode 100644
index 000000000000..f1f46751bf52
--- /dev/null
+++ b/net-im/mtxclient/files/patch-include_mtx_responses_groups.hpp
@@ -0,0 +1,10 @@
+--- include/mtx/responses/groups.hpp.orig 2019-03-24 20:45:03 UTC
++++ include/mtx/responses/groups.hpp
+@@ -1,6 +1,6 @@
+ #pragma once
+
+-#include "json.hpp"
++#include <nlohmann/json.hpp>
+
+ namespace mtx {
+ namespace responses {
diff --git a/net-im/mtxclient/pkg-descr b/net-im/mtxclient/pkg-descr
new file mode 100644
index 000000000000..3639050e0180
--- /dev/null
+++ b/net-im/mtxclient/pkg-descr
@@ -0,0 +1,6 @@
+Client API library for the Matrix protocol, built on top of Boost.Asio.
+
+This library is a C++-based API used by some C++-based Matrix clients,
+like Nheko.
+
+WWW: https://github.com/Nheko-Reborn/mtxclient
diff --git a/net-im/mtxclient/pkg-plist b/net-im/mtxclient/pkg-plist
new file mode 100644
index 000000000000..819ad7861bec
--- /dev/null
+++ b/net-im/mtxclient/pkg-plist
@@ -0,0 +1,57 @@
+include/mtx.hpp
+include/mtx/common.hpp
+include/mtx/errors.hpp
+include/mtx/events.hpp
+include/mtx/events/aliases.hpp
+include/mtx/events/avatar.hpp
+include/mtx/events/canonical_alias.hpp
+include/mtx/events/collections.hpp
+include/mtx/events/common.hpp
+include/mtx/events/create.hpp
+include/mtx/events/encrypted.hpp
+include/mtx/events/encryption.hpp
+include/mtx/events/guest_access.hpp
+include/mtx/events/history_visibility.hpp
+include/mtx/events/join_rules.hpp
+include/mtx/events/member.hpp
+include/mtx/events/messages/audio.hpp
+include/mtx/events/messages/emote.hpp
+include/mtx/events/messages/file.hpp
+include/mtx/events/messages/image.hpp
+include/mtx/events/messages/notice.hpp
+include/mtx/events/messages/text.hpp
+include/mtx/events/messages/video.hpp
+include/mtx/events/name.hpp
+include/mtx/events/pinned_events.hpp
+include/mtx/events/power_levels.hpp
+include/mtx/events/redaction.hpp
+include/mtx/events/tag.hpp
+include/mtx/events/topic.hpp
+include/mtx/identifiers.hpp
+include/mtx/requests.hpp
+include/mtx/responses.hpp
+include/mtx/responses/common.hpp
+include/mtx/responses/create_room.hpp
+include/mtx/responses/crypto.hpp
+include/mtx/responses/empty.hpp
+include/mtx/responses/groups.hpp
+include/mtx/responses/login.hpp
+include/mtx/responses/media.hpp
+include/mtx/responses/messages.hpp
+include/mtx/responses/notifications.hpp
+include/mtx/responses/profile.hpp
+include/mtx/responses/register.hpp
+include/mtx/responses/sync.hpp
+include/mtx/responses/version.hpp
+include/mtxclient/crypto/client.hpp
+include/mtxclient/crypto/objects.hpp
+include/mtxclient/crypto/types.hpp
+include/mtxclient/http/client.hpp
+include/mtxclient/http/errors.hpp
+include/mtxclient/http/session.hpp
+include/mtxclient/utils.hpp
+lib/cmake/MatrixClient/MatrixClientConfig.cmake
+lib/cmake/MatrixClient/MatrixClientConfigVersion.cmake
+lib/cmake/MatrixClient/MatrixClientTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/MatrixClient/MatrixClientTargets.cmake
+lib/libmatrix_client.a