aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-09 00:49:43 +0800
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-09 00:49:43 +0800
commit31469ae5656e71f14de03b31cf71b809859573d2 (patch)
tree344b6abf61ea06069f5de2c1cdcb8209791ac07e /net-im
parent2625e8a3e3cca5d0659fb2fd36594a503ce698ca (diff)
downloadfreebsd-ports-gnome-31469ae5656e71f14de03b31cf71b809859573d2.tar.gz
freebsd-ports-gnome-31469ae5656e71f14de03b31cf71b809859573d2.tar.zst
freebsd-ports-gnome-31469ae5656e71f14de03b31cf71b809859573d2.zip
PyQt: Replace bsd.pyqt.mk with Uses/pyqt.mk.
In preparation for landing PyQt5 ports, generalize devel/py-qt4's bsd.pyqt.mk and make it a proper file in Uses/. Ports wishing to depend on PyQt4 ports can now do the following: USES= pyqt:4 USE_PYQT= foo bar_build baz_run Other changes include the renaming of the PYQT4_DIST variable to PYQT_DIST and the introduction of the PYQT_SIPDIR plist substitution variable. The rest of the contents of Uses/pyqt.mk are pretty much identical to what we had in bsd.pyqt.mk with additional processing of USE_PYQT. Even though this patch touches files in many different ports, the goal is for it to be a no-op from an end-user perspective (so that the basic infrastructure is landed before the other, riskier changes): no dependencies have been changed, PyQt/SIP/QScintilla have not been upgraded and the plists should remain exactly the same, since PYQT_SIPDIR currently contains the same value that used to be hardcoded in the plists. Huge thanks to Guido Falsi (madpilot@) for spearheading most of the work: he took the initiative to work on PyQt5 and sent D2910 to Phabricator with the original version of this patch. Tobias Berner (tcberner@gmail.com) later applied it to kde@'s experimental area51 repositories and did some more work on it.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/turpial/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/net-im/turpial/Makefile b/net-im/turpial/Makefile
index a5d916d42dc2..ebff96f460c1 100644
--- a/net-im/turpial/Makefile
+++ b/net-im/turpial/Makefile
@@ -18,18 +18,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notify>=0.1.1:${PORTSDIR}/devel/py-notify \
${PYTHON_PKGNAMEPREFIX}Jinja2>=2.7.1:${PORTSDIR}/devel/py-Jinja2 \
${PYTHON_PKGNAMEPREFIX}libturpial>=1.7.0:${PORTSDIR}/net-im/py-libturpial
-USES= python:2
+USES= pyqt:4 python:2
+USE_PYQT= core_run gui_run network_run phonon_run webkit_run
USE_PYTHON= distutils autoplist
INSTALLS_ICONS= yes
-PYQT4_PORTS= core gui network phonon webkit
-
-.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
-
-.for component in ${PYQT4_PORTS}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}qt4-${component}>=0:${PORTSDIR}/${${component}_PORT}
-.endfor
-
LOCALES_DIR= ca de eo es fr it ja pt_BR pt_PT ru_RU tr
post-extract: