aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-23 17:54:02 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-23 17:54:02 +0800
commit3ab1b8443ec60e4983c4666f0e84cedab20e81d2 (patch)
treed13723a66084b6936010f3cea6404da7bbcf103b /net-im
parent63d0ab27e8fc88df6e11d9fb8b37620420285dd1 (diff)
downloadfreebsd-ports-gnome-3ab1b8443ec60e4983c4666f0e84cedab20e81d2.tar.gz
freebsd-ports-gnome-3ab1b8443ec60e4983c4666f0e84cedab20e81d2.tar.zst
freebsd-ports-gnome-3ab1b8443ec60e4983c4666f0e84cedab20e81d2.zip
- Replace security/gnutls with security/gnutls3 and update to 3.2.15
- Bump PORTREVISION on all ports that depend on security/gnutls and adjust all ports that depend on security/gnutls3 - Update mail/anubis to version 4.2 which supports gnutls 3.x - Update mail/libvmime to a development snapshot (recommended by upstream developers) PR: 191274 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/finch/Makefile2
-rw-r--r--net-im/gloox/Makefile2
-rw-r--r--net-im/jabber.el/Makefile1
-rw-r--r--net-im/jabber/Makefile2
-rw-r--r--net-im/jabber/files/patch-configure13
-rw-r--r--net-im/jabber/files/patch-jabberd-jabberd.h14
-rw-r--r--net-im/jabber/files/patch-jabberd-mio_tls.cc28
-rw-r--r--net-im/libpurple/Makefile2
-rw-r--r--net-im/loudmouth/Makefile2
9 files changed, 53 insertions, 13 deletions
diff --git a/net-im/finch/Makefile b/net-im/finch/Makefile
index 94e0ce014ca7..525c4ef53cfd 100644
--- a/net-im/finch/Makefile
+++ b/net-im/finch/Makefile
@@ -3,7 +3,7 @@
# $MCom: ports-stable/net-im/gaim-consoleui-devel/Makefile,v 1.2 2006/10/29 18:55:28 marcus Exp $
PORTNAME= finch
-PORTREVISION= 5
+PORTREVISION= 6
MAINTAINER= marcus@FreeBSD.org
COMMENT= Finch multi-protocol messaging client (Console UI)
diff --git a/net-im/gloox/Makefile b/net-im/gloox/Makefile
index 8f39ef88a189..3a5abe21c059 100644
--- a/net-im/gloox/Makefile
+++ b/net-im/gloox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gloox
PORTVERSION= 1.0.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= http://camaya.net/download/
diff --git a/net-im/jabber.el/Makefile b/net-im/jabber.el/Makefile
index dae02328dc98..ef2b3f9c751d 100644
--- a/net-im/jabber.el/Makefile
+++ b/net-im/jabber.el/Makefile
@@ -3,6 +3,7 @@
PORTNAME= jabber.el
PORTVERSION= 0.8.92
+PORTREVISION= 1
CATEGORIES= net-im elisp
MASTER_SITES= SF/emacs-jabber/emacs-jabber%20beta%20versions/${PORTVERSION}
DISTNAME= emacs-jabber-${PORTVERSION}
diff --git a/net-im/jabber/Makefile b/net-im/jabber/Makefile
index 6c523c0a2326..6e6d3532277a 100644
--- a/net-im/jabber/Makefile
+++ b/net-im/jabber/Makefile
@@ -3,7 +3,7 @@
PORTNAME= jabber
PORTVERSION= 1.6.1.1
-PORTREVISION= 15
+PORTREVISION= 16
PORTEPOCH= 1
CATEGORIES= net-im ipv6
MASTER_SITES= http://download.jabberd.org/jabberd14/%SUBDIR%/
diff --git a/net-im/jabber/files/patch-configure b/net-im/jabber/files/patch-configure
index 89cd51559276..57a16dcd4023 100644
--- a/net-im/jabber/files/patch-configure
+++ b/net-im/jabber/files/patch-configure
@@ -8,6 +8,15 @@
#include <sys/types.h>
#include <sys/socket.h>
#include <netdb.h>
+@@ -21878,7 +21879,7 @@
+ echo "${ECHO_T}yes" >&6; }
+ hasgnutlsextra=yes
+ fi
+-if test $hasgnutls = "yes" ; then
++if test $hasgnutlsextra = "yes" ; then
+ CPPFLAGS="$CPPFLAGS $GNUTLSEXTRA_CFLAGS"
+ LDFLAGS="$LDFLAGS $GNUTLSEXTRA_LIBS"
+
@@ -22554,7 +22555,7 @@
if test "${with_mysql+set}" = set; then
withval=$with_mysql; mysql=$withval
@@ -15,7 +24,7 @@
- mysql=yes
+ mysql=no
fi
-
+
if test "$mysql" != "no"; then
@@ -22778,7 +22779,7 @@
if test "${with_postgresql+set}" = set; then
@@ -24,7 +33,7 @@
- postgresql=yes
+ postgresql=no
fi
-
+
if test "$postgresql" != "no"; then
@@ -22787,8 +22788,8 @@
CPPFLAGS="${CPPFLAGS} -I$postgresql/include"
diff --git a/net-im/jabber/files/patch-jabberd-jabberd.h b/net-im/jabber/files/patch-jabberd-jabberd.h
new file mode 100644
index 000000000000..349e9f50117a
--- /dev/null
+++ b/net-im/jabber/files/patch-jabberd-jabberd.h
@@ -0,0 +1,14 @@
+--- jabberd/jabberd.h.orig
++++ jabberd/jabberd.h
+@@ -103,10 +103,10 @@
+ #include <jabberdlib.h>
+ #include <gnutls/gnutls.h>
+ #include <gnutls/x509.h>
++#include <gnutls/openpgp.h>
+
+ #ifdef HAVE_GNUTLS_EXTRA
+ # include <gnutls/extra.h>
+-# include <gnutls/openpgp.h>
+ #endif
+
+ /** Packet types */
diff --git a/net-im/jabber/files/patch-jabberd-mio_tls.cc b/net-im/jabber/files/patch-jabberd-mio_tls.cc
index 1a945861ceb2..433dd4eba8d7 100644
--- a/net-im/jabber/files/patch-jabberd-mio_tls.cc
+++ b/net-im/jabber/files/patch-jabberd-mio_tls.cc
@@ -59,7 +59,23 @@
return false;
/* XXX we have to delete the structure on shutdown using asn1_delete_structure(&mio_tls_asn1_tree) */
}
-@@ -1684,14 +1666,14 @@
+@@ -1498,7 +1480,6 @@
+ const gnutls_datum_t *cert_list = NULL;
+ unsigned int cert_list_size = 0;
+
+-#ifdef HAVE_GNUTLS_EXTRA
+ // get the certificate (it's only a single one for OpenPGP)
+ cert_list = gnutls_certificate_get_peers(static_cast<gnutls_session_t>(m->ssl), &cert_list_size);
+ if (cert_list == NULL || cert_list_size <= 0) {
+@@ -1566,7 +1547,6 @@
+ // free memory
+ gnutls_openpgp_key_deinit(pgpkey);
+ pool_free(jidpool);
+-#endif
+ return 0;
+ }
+
+@@ -1684,14 +1664,14 @@
/* init subjectAltName_element */
ret = asn1_create_element(mio_tls_asn1_tree, "PKIX1.SubjectAltName", &subjectAltName_element);
if (ret != ASN1_SUCCESS) {
@@ -76,7 +92,7 @@
asn1_delete_structure(&subjectAltName_element);
break;
}
-@@ -1712,7 +1694,7 @@
+@@ -1712,7 +1692,7 @@
break;
}
if (ret != ASN1_SUCCESS) {
@@ -85,7 +101,7 @@
break;
}
-@@ -1732,7 +1714,7 @@
+@@ -1732,7 +1712,7 @@
ret = asn1_read_value(subjectAltName_element, access_string, dNSName, &dNSName_len);
if (ret != ASN1_SUCCESS) {
@@ -94,7 +110,7 @@
break;
}
-@@ -1772,7 +1754,7 @@
+@@ -1772,7 +1752,7 @@
/* get the OID of the otherName */
ret = asn1_read_value(subjectAltName_element, access_string_type, otherNameType, &otherNameType_len);
if (ret != ASN1_SUCCESS) {
@@ -103,7 +119,7 @@
break;
}
-@@ -1785,7 +1767,7 @@
+@@ -1785,7 +1765,7 @@
/* get the value of the otherName */
ret = asn1_read_value(subjectAltName_element, access_string_value, otherNameValue, &otherNameValue_len);
if (ret != ASN1_SUCCESS) {
@@ -112,7 +128,7 @@
break;
}
-@@ -1799,21 +1781,21 @@
+@@ -1799,21 +1779,21 @@
ret = asn1_create_element(mio_tls_asn1_tree, "PKIX1.DirectoryString", &directoryString_element);
if (ret != ASN1_SUCCESS) {
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 5ae36fb0e2b7..157a8b497ea7 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -4,7 +4,7 @@
PORTNAME?= libpurple
PORTVERSION= 2.10.9
-PORTREVISION?= 5
+PORTREVISION?= 6
CATEGORIES?= net-im
MASTER_SITES= SF/pidgin/Pidgin/${PORTVERSION}
DISTNAME= pidgin-${PORTVERSION}
diff --git a/net-im/loudmouth/Makefile b/net-im/loudmouth/Makefile
index 6f639767c422..da272bc97ee0 100644
--- a/net-im/loudmouth/Makefile
+++ b/net-im/loudmouth/Makefile
@@ -3,7 +3,7 @@
PORTNAME= loudmouth
PORTVERSION= 1.4.3
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net-im gnome
MASTER_SITES= GNOME