aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-02-03 07:34:54 +0800
committermadpilot <madpilot@FreeBSD.org>2016-02-03 07:34:54 +0800
commit486edebf8af7b932e11eef5eb491494d6d119f97 (patch)
treea25947e2daf4159eca47a09b7ceeeff43e24ad5d /net-im
parent8efcd5a9bee364571ab06e54c7290b9c7404d3a1 (diff)
downloadfreebsd-ports-gnome-486edebf8af7b932e11eef5eb491494d6d119f97.tar.gz
freebsd-ports-gnome-486edebf8af7b932e11eef5eb491494d6d119f97.tar.zst
freebsd-ports-gnome-486edebf8af7b932e11eef5eb491494d6d119f97.zip
Telegram API tools for QtQML and Qml, based on Cutegram-Core and libqtelegram.
It's free and released under the GPLv3 license. WWW: https://github.com/Aseman-Land/TelegramQML PR: 204349 Submitted by: Henry Hu <henry.hu.sh@gmail.com>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/telegramqml/Makefile26
-rw-r--r--net-im/telegramqml/distinfo2
-rw-r--r--net-im/telegramqml/pkg-descr4
-rw-r--r--net-im/telegramqml/pkg-plist39
5 files changed, 72 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 471ddeed88d3..4fb233b406a5 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -161,6 +161,7 @@
SUBDIR += teamwords
SUBDIR += telegram
SUBDIR += telegram-purple
+ SUBDIR += telegramqml
SUBDIR += telepathy-butterfly
SUBDIR += telepathy-farsight
SUBDIR += telepathy-farstream
diff --git a/net-im/telegramqml/Makefile b/net-im/telegramqml/Makefile
new file mode 100644
index 000000000000..37c213b710b0
--- /dev/null
+++ b/net-im/telegramqml/Makefile
@@ -0,0 +1,26 @@
+# Created by: Henry Hu <henry.hu.sh@gmail.com>
+# $FreeBSD$
+
+PORTNAME= telegramqml
+PORTVERSION= 0.9.2
+DISTVERSIONPREFIX= v
+CATEGORIES= net-im
+
+MAINTAINER= henry.hu.sh@gmail.com
+COMMENT= Telegram API tools for QtQML and Qml
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libqtelegram-ae.so:${PORTSDIR}/net-im/libqtelegram-ae
+
+USE_GITHUB= yes
+GH_ACCOUNT= Aseman-Land
+GH_PROJECT= TelegramQML
+
+USES= qmake:outsource
+USE_QT5= qmake_build buildtools_build core qml quick sql xml multimedia
+USE_LDCONFIG= yes
+QMAKE_ARGS= BUILD_MODE+=lib
+
+.include <bsd.port.mk>
diff --git a/net-im/telegramqml/distinfo b/net-im/telegramqml/distinfo
new file mode 100644
index 000000000000..df4bf8205e1e
--- /dev/null
+++ b/net-im/telegramqml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Aseman-Land-TelegramQML-v0.9.2_GH0.tar.gz) = 16d6429fe180531af167dc44bcc799e82b08c9cfa88f1f635155dfcef2558397
+SIZE (Aseman-Land-TelegramQML-v0.9.2_GH0.tar.gz) = 129567
diff --git a/net-im/telegramqml/pkg-descr b/net-im/telegramqml/pkg-descr
new file mode 100644
index 000000000000..824c4d63efbc
--- /dev/null
+++ b/net-im/telegramqml/pkg-descr
@@ -0,0 +1,4 @@
+Telegram API tools for QtQML and Qml, based on Cutegram-Core and libqtelegram.
+It's free and released under the GPLv3 license.
+
+WWW: https://github.com/Aseman-Land/TelegramQML
diff --git a/net-im/telegramqml/pkg-plist b/net-im/telegramqml/pkg-plist
new file mode 100644
index 000000000000..837581ec356d
--- /dev/null
+++ b/net-im/telegramqml/pkg-plist
@@ -0,0 +1,39 @@
+include/telegramqml/backgroundmanager.h
+include/telegramqml/chatparticipantlist.h
+include/telegramqml/database.h
+include/telegramqml/databaseabstractencryptor.h
+include/telegramqml/databasecore.h
+include/telegramqml/dialogfilesmodel.h
+include/telegramqml/documentattributelist.h
+include/telegramqml/mp3converterengine.h
+include/telegramqml/newsletterdialog.h
+include/telegramqml/objects/types.h
+include/telegramqml/photosizelist.h
+include/telegramqml/profilesmodel.h
+include/telegramqml/stickersmodel.h
+include/telegramqml/tagfiltermodel.h
+include/telegramqml/telegramchatparticipantsmodel.h
+include/telegramqml/telegramcontactsfiltermodel.h
+include/telegramqml/telegramcontactsmodel.h
+include/telegramqml/telegramdetailedcontactsmodel.h
+include/telegramqml/telegramdialogsmodel.h
+include/telegramqml/telegramfilehandler.h
+include/telegramqml/telegrammessagesmodel.h
+include/telegramqml/telegramqml.h
+include/telegramqml/telegramqml_global.h
+include/telegramqml/telegramqml_macros.h
+include/telegramqml/telegramqml_plugin.h
+include/telegramqml/telegramqmlinitializer.h
+include/telegramqml/telegramsearchmodel.h
+include/telegramqml/telegramthumbnailer.h
+include/telegramqml/telegramthumbnailercore.h
+include/telegramqml/telegramuploadsmodel.h
+include/telegramqml/telegramwallpapersmodel.h
+include/telegramqml/tgabstractlistmodel.h
+include/telegramqml/tqobject.h
+include/telegramqml/userdata.h
+include/telegramqml/usernamefiltermodel.h
+lib/libtelegramqml.so
+lib/libtelegramqml.so.1
+lib/libtelegramqml.so.1.0
+lib/libtelegramqml.so.1.0.0