aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-08-31 08:18:11 +0800
committerbapt <bapt@FreeBSD.org>2013-08-31 08:18:11 +0800
commit4a7e1514f30f19906c08052b844d2481d84e45c1 (patch)
tree69b9c40644b7552cf69a821770b47f1b2c8d5251 /net-im
parente339b548ab5c25fc7fba6529a80b8e3f573a1651 (diff)
downloadfreebsd-ports-gnome-4a7e1514f30f19906c08052b844d2481d84e45c1.tar.gz
freebsd-ports-gnome-4a7e1514f30f19906c08052b844d2481d84e45c1.tar.zst
freebsd-ports-gnome-4a7e1514f30f19906c08052b844d2481d84e45c1.zip
Convert USE_GNOME=pkgconfig to USES=pkgconfig
Convert USE_GMAKE to USES=gmake
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jggtrans/Makefile45
-rw-r--r--net-im/pidgin-birthday-reminder/Makefile11
-rw-r--r--net-im/pidgin-hotkeys/Makefile3
-rw-r--r--net-im/pidgin-osd/Makefile9
-rw-r--r--net-im/pidgin-twitter/Makefile9
5 files changed, 33 insertions, 44 deletions
diff --git a/net-im/jggtrans/Makefile b/net-im/jggtrans/Makefile
index d32d3c2dbb5f..2a37a2d0fa0e 100644
--- a/net-im/jggtrans/Makefile
+++ b/net-im/jggtrans/Makefile
@@ -1,29 +1,28 @@
# Created by: Bartek Rutkowski <r@robakdesign.com>
# $FreeBSD$
-PORTNAME= jggtrans
-PORTVERSION= 2.2.4
-PORTREVISION= 2
-CATEGORIES= net-im polish
-MASTER_SITES= http://jggtrans.jajcus.net/downloads/ \
- http://freebsd.e.pl/distfiles/
-
-MAINTAINER= mg@fork.pl
-COMMENT= Jabberd XMPP to GG instant messaging service gateway
-
-LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn \
- expat.6:${PORTSDIR}/textproc/expat2 \
- gadu.3:${PORTSDIR}/polish/libgadu
-
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USES= gettext
-USE_GNOME= glib20 pkgconfig
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CFLAGS+= -I${LOCALBASE}/include
-
-USE_RC_SUBR= jggtrans
+PORTNAME= jggtrans
+PORTVERSION= 2.2.4
+PORTREVISION= 2
+CATEGORIES= net-im polish
+MASTER_SITES= http://jggtrans.jajcus.net/downloads/ \
+ http://freebsd.e.pl/distfiles/
+
+MAINTAINER= mg@fork.pl
+COMMENT= Jabberd XMPP to GG instant messaging service gateway
+
+LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn \
+ expat.6:${PORTSDIR}/textproc/expat2 \
+ gadu.3:${PORTSDIR}/polish/libgadu
+
+GNU_CONFIGURE= yes
+USES= gettext gmake pkgconfig
+USE_GNOME= glib20
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+
+USE_RC_SUBR= jggtrans
OPTIONS_DEFINE= DEBUG EJABBERD
EJABBERD_DESC= transport with ejabberd
diff --git a/net-im/pidgin-birthday-reminder/Makefile b/net-im/pidgin-birthday-reminder/Makefile
index 24f2a58f330e..cd233b8a6265 100644
--- a/net-im/pidgin-birthday-reminder/Makefile
+++ b/net-im/pidgin-birthday-reminder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pidgin-birthday_reminder
-# Date created: 11 April 2009
-# Whom: Alexander Logvinov <ports@logvinov.com>
-#
+# Created by: Alexander Logvinov <ports@logvinov.com>
# $FreeBSD$
-#
PORTNAME= pidgin-birthday-reminder
PORTVERSION= 1.7
@@ -20,9 +16,8 @@ RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= gettext
-USE_GNOME= pkgconfig intltool
+USES= gettext gmake pkgconfig
+USE_GNOME= intltool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net-im/pidgin-hotkeys/Makefile b/net-im/pidgin-hotkeys/Makefile
index dcc595500be8..a88c1586d708 100644
--- a/net-im/pidgin-hotkeys/Makefile
+++ b/net-im/pidgin-hotkeys/Makefile
@@ -13,7 +13,8 @@ LIB_DEPENDS= purple:${PORTSDIR}/net-im/libpurple
BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
-USE_GNOME= pkgconfig gtk20
+USES= pkgconfig
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
PLIST_FILES= lib/pidgin/hotkeys.so \
diff --git a/net-im/pidgin-osd/Makefile b/net-im/pidgin-osd/Makefile
index a9313e8260c8..b0e47206d9e4 100644
--- a/net-im/pidgin-osd/Makefile
+++ b/net-im/pidgin-osd/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: pidgin-osd
-# Date created: 17 Dec 2009
-# Whom: Vyacheslav Anikin <anikinsl@gmail.com>
-#
+# Created by: Vyacheslav Anikin <anikinsl@gmail.com>
# $FreeBSD$
PORTNAME= pidgin-osd
@@ -18,9 +15,9 @@ BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin \
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin \
xosd>=2.2.12:${PORTSDIR}/misc/xosd
-USE_GNOME= pkgconfig glib20
+USES= gmake pkgconfig
+USE_GNOME= glib20
USE_BZIP2= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
PLIST_FILES= lib/pidgin/pidgin-osd.so \
diff --git a/net-im/pidgin-twitter/Makefile b/net-im/pidgin-twitter/Makefile
index e1897922292d..cf8cd0d7980a 100644
--- a/net-im/pidgin-twitter/Makefile
+++ b/net-im/pidgin-twitter/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: pidgin-twitter
-# Date created: 17 May 2008
-# Whom: Junji NAKANISHI <jun-g@daemonfreaks.com>
-#
+# Created by: Junji NAKANISHI <jun-g@daemonfreaks.com>
# $FreeBSD$
PORTNAME= pidgin-twitter
@@ -17,8 +14,8 @@ BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
-USE_GNOME= pkgconfig glib20
-USE_GMAKE= yes
+USES= gmake pkgconfig
+USE_GNOME= glib20
GNU_CONFIGURE= yes
PLIST_FILES= lib/pidgin/pidgin-twitter.so \