aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-08-01 21:57:18 +0800
committerhq <hq@FreeBSD.org>2005-08-01 21:57:18 +0800
commit63593b01ef8a4e6e5c870cd34b3e85d06e17d810 (patch)
tree354c9057187875e38eea7fed248403daf880c620 /net-im
parent41e96633e7a58e3f65ee81fea1ff2ad45c9df9e1 (diff)
downloadfreebsd-ports-gnome-63593b01ef8a4e6e5c870cd34b3e85d06e17d810.tar.gz
freebsd-ports-gnome-63593b01ef8a4e6e5c870cd34b3e85d06e17d810.tar.zst
freebsd-ports-gnome-63593b01ef8a4e6e5c870cd34b3e85d06e17d810.zip
Convey allows people across the globe to collaboratively draw images while
chatting online. Using pictures in addition to words makes communicating online fun and easy. Convey is an Instant Message (IM) program. You can send an message to a friend, but unlike email, the message instantly appears on your friend's screen if they are online. Otherwise, the message is delivered to your friend when they log onto the Internet. Convey uses the Jabber protocol to send its messages. A protocol consists of the rules by which a computer communicates with another computer. Using Jabber, Convey provides users connections to other popular IM programs, such as AOL Instant Messenger, ICQ, MSN Instant Messenger, and Yahoo! Messenger. WWW: http://convey.sourceforge.net/ PR: 83749 Submitted by: Nicola Vitale <nivit@email.it>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/convey/Makefile39
-rw-r--r--net-im/convey/distinfo2
-rw-r--r--net-im/convey/files/convey.sh.in6
-rw-r--r--net-im/convey/pkg-descr17
-rw-r--r--net-im/convey/pkg-plist10
5 files changed, 74 insertions, 0 deletions
diff --git a/net-im/convey/Makefile b/net-im/convey/Makefile
new file mode 100644
index 000000000000..b06ffdd4af9d
--- /dev/null
+++ b/net-im/convey/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: convey
+# Date created: 2005-07-18
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= convey
+PORTVERSION= 0.3
+CATEGORIES= net java
+MASTER_SITES= http://convey.sourceforge.net/downloads/ \
+ http://nivi.interfree.it/tmp/convey.sourceforge.net/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= nivit@email.it
+COMMENT= An Instant Message (IM) program using the Jabber protocol
+
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+
+USE_ANT= yes
+USE_JAVA= yes
+
+JAVA_VERSION= 1.3+
+
+MAKE_ARGS= -quiet
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+FIND_DIRS= lib
+
+SUB_FILES= convey.sh
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/convey.sh ${PREFIX}/bin/convey
+ cd ${WRKSRC} && ${FIND} ${FIND_DIRS} -type d -exec ${MKDIR} ${DATADIR}/{} \;
+ cd ${WRKSRC} && ${FIND} ${FIND_DIRS} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+
+.include <bsd.port.post.mk>
diff --git a/net-im/convey/distinfo b/net-im/convey/distinfo
new file mode 100644
index 000000000000..7ac220c29f68
--- /dev/null
+++ b/net-im/convey/distinfo
@@ -0,0 +1,2 @@
+MD5 (convey-src-0.3.tar.gz) = 12b34536d6b9652a1e3fe33b710a59e2
+SIZE (convey-src-0.3.tar.gz) = 810560
diff --git a/net-im/convey/files/convey.sh.in b/net-im/convey/files/convey.sh.in
new file mode 100644
index 000000000000..7080202e7469
--- /dev/null
+++ b/net-im/convey/files/convey.sh.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+cd "%%DATADIR%%"
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -cp "classes:lib/muse-0.72.jar:lib/crimson-1.1.3.jar:lib/jaxp-1.1.jar:lib/jakarta-oro-2.0.4.jar:lib/jdom-b7.jar:lib/convey-0.3.jar" org.convey.ConveyFrame
diff --git a/net-im/convey/pkg-descr b/net-im/convey/pkg-descr
new file mode 100644
index 000000000000..bd80ae210fb8
--- /dev/null
+++ b/net-im/convey/pkg-descr
@@ -0,0 +1,17 @@
+Convey allows people across the globe to collaboratively draw images while
+chatting online. Using pictures in addition to words makes communicating online
+fun and easy.
+
+Convey is an Instant Message (IM) program. You can send an message to a friend,
+but unlike email, the message instantly appears on your friend's screen if they
+are online. Otherwise, the message is delivered to your friend when they log
+onto the Internet.
+
+Convey uses the Jabber protocol to send its messages. A protocol consists of
+the rules by which a computer communicates with another computer.
+
+Using Jabber, Convey provides users connections to other popular IM programs,
+such as AOL Instant Messenger, ICQ, MSN Instant Messenger, and Yahoo!
+Messenger.
+
+WWW: http://convey.sourceforge.net/
diff --git a/net-im/convey/pkg-plist b/net-im/convey/pkg-plist
new file mode 100644
index 000000000000..3d04072eb373
--- /dev/null
+++ b/net-im/convey/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+bin/convey
+%%DATADIR%%/lib/convey-0.3.jar
+%%DATADIR%%/lib/crimson-1.1.3.jar
+%%DATADIR%%/lib/jakarta-oro-2.0.4.jar
+%%DATADIR%%/lib/jaxp-1.1.jar
+%%DATADIR%%/lib/jdom-b7.jar
+%%DATADIR%%/lib/muse-0.72.jar
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%