aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2021-02-11 20:32:32 +0800
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-02-11 20:32:32 +0800
commit75d6bc8de824cec008d1b7dbc3caf09d8a35cdcf (patch)
tree84438381452a30167da3c1feae6ea107ab6a09b4 /net-im
parent00ddf5cfb3b826d453723c26bb32cdd5e2b1228a (diff)
downloadfreebsd-ports-gnome-75d6bc8de824cec008d1b7dbc3caf09d8a35cdcf.tar.gz
freebsd-ports-gnome-75d6bc8de824cec008d1b7dbc3caf09d8a35cdcf.tar.zst
freebsd-ports-gnome-75d6bc8de824cec008d1b7dbc3caf09d8a35cdcf.zip
net-im/telegram-desktop: update to 2.5.8
PR: 253336 Submitted by: Henry Hu <henry.hu.sh@gmail.com> (maintainer)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telegram-desktop/Makefile26
-rw-r--r--net-im/telegram-desktop/distinfo8
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__file__utilities__linux.cpp11
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__info__linux.cpp69
-rw-r--r--net-im/telegram-desktop/files/patch-cmake_external_webrtc_CMakeLists.txt32
-rw-r--r--net-im/telegram-desktop/files/patch-tg__owt_CMakeLists.txt26
-rw-r--r--net-im/telegram-desktop/files/patch-tg__owt_cmake_libevent.cmake26
-rw-r--r--net-im/telegram-desktop/files/patch-tg__owt_src_media_sctp_sctp__transport.cc20
-rw-r--r--net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_byte__order.h11
-rw-r--r--net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_ip__address.cc10
-rw-r--r--net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_physical__socket__server.cc29
-rw-r--r--net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_physical__socket__server.h11
-rw-r--r--net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_platform__thread__types.cc43
13 files changed, 51 insertions, 271 deletions
diff --git a/net-im/telegram-desktop/Makefile b/net-im/telegram-desktop/Makefile
index 55ec9ab78550..695f3f64083b 100644
--- a/net-im/telegram-desktop/Makefile
+++ b/net-im/telegram-desktop/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= telegram-desktop
-DISTVERSION= 2.4.4
-PORTREVISION= 2
+DISTVERSION= 2.5.8
CATEGORIES= net-im
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${DISTVERSION}/
DISTNAME= tdesktop-${DISTVERSION}-full
@@ -25,7 +24,8 @@ BUILD_DEPENDS= alsa-lib>0:audio/alsa-lib \
range-v3>0:devel/range-v3 \
tl-expected>0:devel/tl-expected \
v4l_compat>0:multimedia/v4l_compat \
- yasm:devel/yasm
+ yasm:devel/yasm \
+ ${LOCALBASE}/lib/libtg_owt.a:net-im/tg_owt
LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
libdbus-1.so:devel/dbus \
libdbusmenu-qt5.so:devel/libdbusmenu-qt \
@@ -50,7 +50,6 @@ NO_CCACHE= yes
USE_GITHUB= nodefault
GH_ACCOUNT= telegramdesktop
GH_PROJECT= tdesktop
-GH_TUPLE= desktop-app:tg_owt:c73a471:tg_owt/tg_owt
USE_GNOME= glib20
USE_QT= core dbus gui imageformats network widgets buildtools_build \
qmake_build wayland
@@ -58,14 +57,14 @@ USE_XORG= x11 xcb
USE_GL= gl
CMAKE_ON= DESKTOP_APP_USE_PACKAGED DESKTOP_APP_DISABLE_CRASH_REPORTS \
- TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME TDESKTOP_DISABLE_DESKTOP_FILE_GENERATION
+ TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME TDESKTOP_DISABLE_DESKTOP_FILE_GENERATION \
+ DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION
CMAKE_OFF= DESKTOP_APP_USE_PACKAGED_RLOTTIE DESKTOP_APP_USE_PACKAGED_VARIANT \
DESKTOP_APP_USE_GLIBC_WRAPS TDESKTOP_USE_PACKAGED_TGVOIP \
DESKTOP_APP_USE_PACKAGED_FONTS
CMAKE_ARGS= -DDESKTOP_APP_SPECIAL_TARGET="" -DTDESKTOP_LAUNCHER_BASENAME="telegramdesktop" \
-DTDESKTOP_API_ID=${TELEGRAM_API_ID} -DTDESKTOP_API_HASH=${TELEGRAM_API_HASH} \
- -Ddisable_autoupdate=1 \
- -DDESKTOP_APP_WEBRTC_LOCATION=${WRKSRC}/tg_owt/src
+ -Ddisable_autoupdate=1
# Disable DCHECKs, otherwise video calls will crash.
CXXFLAGS+= -DNDEBUG
@@ -98,15 +97,4 @@ INSTALLS_ICONS= yes
USE_GNOME+= gtk30
.endif
-.include <bsd.port.pre.mk>
-
-pre-configure:
- @cd ${WRKSRC}/tg_owt && \
- ${MKDIR} out/${CMAKE_BUILD_TYPE} && \
- cd out/${CMAKE_BUILD_TYPE} && \
- ${CMAKE_BIN} ${CMAKE_ARGS} ${WRKSRC}/tg_owt
-
-pre-build:
- @cd ${WRKSRC}/tg_owt/out/${CMAKE_BUILD_TYPE} && ${DO_MAKE_BUILD}
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/telegram-desktop/distinfo b/net-im/telegram-desktop/distinfo
index 70e52f41ef6a..f384a7ca55fd 100644
--- a/net-im/telegram-desktop/distinfo
+++ b/net-im/telegram-desktop/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1603766669
-SHA256 (tdesktop-2.4.4-full.tar.gz) = 88799708daedaf5c132752259945b4e1b5dcbb62385661e2cca7b8e5d58c9026
-SIZE (tdesktop-2.4.4-full.tar.gz) = 36220573
-SHA256 (desktop-app-tg_owt-c73a471_GH0.tar.gz) = d1886a3ba6966fef257f63a3dd39f53d01ff8db0177fcd6de1b64916cd4076e1
-SIZE (desktop-app-tg_owt-c73a471_GH0.tar.gz) = 18383113
+TIMESTAMP = 1612728578
+SHA256 (tdesktop-2.5.8-full.tar.gz) = 9c89cb31f8ba8a26821fe3c2769b04162e8d7629d327f9cd25a892e88878417e
+SIZE (tdesktop-2.5.8-full.tar.gz) = 36685925
diff --git a/net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__file__utilities__linux.cpp b/net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__file__utilities__linux.cpp
new file mode 100644
index 000000000000..dac991968a86
--- /dev/null
+++ b/net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__file__utilities__linux.cpp
@@ -0,0 +1,11 @@
+--- Telegram/lib_base/base/platform/linux/base_file_utilities_linux.cpp.orig 2021-01-28 15:30:24 UTC
++++ Telegram/lib_base/base/platform/linux/base_file_utilities_linux.cpp
+@@ -114,7 +114,7 @@ bool ShowInFolder(const QString &filepath) {
+ }
+
+ if (g_app_info_launch_default_for_uri(
+- g_filename_to_uri(absoluteDirPath.toUtf8(), nullptr, nullptr),
++ g_filename_to_uri(absoluteDirPath.toUtf8().constData(), nullptr, nullptr),
+ nullptr,
+ nullptr)) {
+ return true;
diff --git a/net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__info__linux.cpp b/net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__info__linux.cpp
index e066c7e49f55..e5bf3f9b34ee 100644
--- a/net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__info__linux.cpp
+++ b/net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__info__linux.cpp
@@ -1,50 +1,41 @@
---- Telegram/lib_base/base/platform/linux/base_info_linux.cpp.orig 2020-10-20 16:29:09 UTC
+--- Telegram/lib_base/base/platform/linux/base_info_linux.cpp.orig 2021-01-28 15:30:24 UTC
+++ Telegram/lib_base/base/platform/linux/base_info_linux.cpp
-@@ -11,7 +11,6 @@
- #include <QtCore/QVersionNumber>
+@@ -14,11 +14,6 @@
#include <QtCore/QDate>
#include <QtGui/QGuiApplication>
--#include <gnu/libc-version.h>
+-// this file is used on both Linux & BSD
+-#ifdef Q_OS_LINUX
+-#include <gnu/libc-version.h>
+-#endif // Q_OS_LINUX
+-
namespace Platform {
+ namespace {
-@@ -32,11 +31,9 @@ QString SystemVersionPretty() {
- const auto value = result ? QString::fromLatin1(result) : QString();
- const auto list = value.split(':', QString::SkipEmptyParts);
+@@ -103,7 +98,7 @@ QString SystemVersionPretty() {
+ static const auto result = [&] {
+ QStringList resultList{};
-- return "Linux "
-+ return "FreeBSD "
- + (list.isEmpty() ? QString() : list[0] + ' ')
-- + (IsWayland() ? "Wayland " : "X11 ")
-- + "glibc "
-- + GetGlibCVersion();
-+ + (IsWayland() ? "Wayland " : "X11 ");
+-#ifdef Q_OS_LINUX
++#if 0
+ resultList << "Linux";
+ #else // Q_OS_LINUX
+ resultList << QSysInfo::kernelType();
+@@ -186,7 +181,7 @@ QString AutoUpdateKey() {
}
- QString SystemCountry() {
-@@ -54,10 +51,6 @@ QString SystemLanguage() {
- QDate WhenSystemBecomesOutdated() {
- if (IsLinux32Bit()) {
- return QDate(2020, 9, 1);
-- } else if (const auto version = GetGlibCVersion(); !version.isEmpty()) {
-- if (QVersionNumber::fromString(version) < QVersionNumber(2, 23)) {
-- return QDate(2020, 9, 1); // Older than Ubuntu 16.04.
-- }
- }
- return QDate();
- }
-@@ -78,14 +71,6 @@ QString AutoUpdateKey() {
- } else {
- Unexpected("Platform in AutoUpdateKey.");
- }
--}
--
--QString GetGlibCVersion() {
-- static const auto result = [&] {
-- const auto version = QString::fromLatin1(gnu_get_libc_version());
-- return QVersionNumber::fromString(version).isNull() ? QString() : version;
-- }();
-- return result;
+ QString GetLibcName() {
+-#ifdef Q_OS_LINUX
++#if 0
+ return "glibc";
+ #endif // Q_OS_LINUX
+
+@@ -194,7 +189,7 @@ QString GetLibcName() {
}
- bool IsWayland() {
+ QString GetLibcVersion() {
+-#ifdef Q_OS_LINUX
++#if 0
+ static const auto result = [&] {
+ const auto version = QString::fromLatin1(gnu_get_libc_version());
+ return QVersionNumber::fromString(version).isNull() ? QString() : version;
diff --git a/net-im/telegram-desktop/files/patch-cmake_external_webrtc_CMakeLists.txt b/net-im/telegram-desktop/files/patch-cmake_external_webrtc_CMakeLists.txt
deleted file mode 100644
index 534c221055cf..000000000000
--- a/net-im/telegram-desktop/files/patch-cmake_external_webrtc_CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
---- cmake/external/webrtc/CMakeLists.txt.orig 2020-10-23 14:48:52 UTC
-+++ cmake/external/webrtc/CMakeLists.txt
-@@ -7,11 +7,11 @@
- add_library(external_webrtc INTERFACE IMPORTED GLOBAL)
- add_library(desktop-app::external_webrtc ALIAS external_webrtc)
-
--if (DESKTOP_APP_USE_PACKAGED)
-+if (0) # DESKTOP_APP_USE_PACKAGED
- find_package(tg_owt REQUIRED)
- target_link_libraries(external_webrtc INTERFACE tg_owt::tg_owt)
- else()
-- set(webrtc_loc ${libs_loc}/tg_owt/src)
-+ set(webrtc_loc ${DESKTOP_APP_WEBRTC_LOCATION})
- set(webrtc_build_loc ${libs_loc}/tg_owt/out/$<CONFIG>)
-
- target_compile_definitions(external_webrtc
-@@ -75,7 +75,7 @@ else()
- )
- endif()
- foreach (lib ${webrtc_libs})
-- list(APPEND webrtc_libs_list "${webrtc_build_loc}/${lib}${webrtc_lib_suffix}")
-+ list(APPEND webrtc_libs_list "${DESKTOP_APP_WEBRTC_LOCATION}/../out/$<CONFIG>/${lib}${webrtc_lib_suffix}")
- endforeach()
-
- if (WIN32)
-@@ -98,5 +98,6 @@ else()
- INTERFACE
- ${webrtc_libs_list}
- desktop-app::external_openssl
-+ jpeg
- )
- endif()
diff --git a/net-im/telegram-desktop/files/patch-tg__owt_CMakeLists.txt b/net-im/telegram-desktop/files/patch-tg__owt_CMakeLists.txt
deleted file mode 100644
index 5f1ab789675e..000000000000
--- a/net-im/telegram-desktop/files/patch-tg__owt_CMakeLists.txt
+++ /dev/null
@@ -1,26 +0,0 @@
---- tg_owt/CMakeLists.txt.orig 2020-10-07 14:11:02 UTC
-+++ tg_owt/CMakeLists.txt
-@@ -38,7 +38,6 @@ include(cmake/libopenh264.cmake)
- include(cmake/libpffft.cmake)
- include(cmake/librnnoise.cmake)
- include(cmake/libsrtp.cmake)
--include(cmake/libusrsctp.cmake)
- include(cmake/libvpx.cmake)
- include(cmake/libwebrtcbuild.cmake)
- include(cmake/libyuv.cmake)
-@@ -62,7 +61,6 @@ if (is_x86 OR is_x64)
- tg_owt::libpffft
- tg_owt::librnnoise
- tg_owt::libsrtp
-- tg_owt::libusrsctp
- tg_owt::libvpx
- tg_owt::libvpx_mmx
- tg_owt::libvpx_sse2
-@@ -1839,7 +1837,6 @@ TARGETS
- libpffft
- librnnoise
- libsrtp
-- libusrsctp
- libvpx
- ${vpx_export}
- libwebrtcbuild
diff --git a/net-im/telegram-desktop/files/patch-tg__owt_cmake_libevent.cmake b/net-im/telegram-desktop/files/patch-tg__owt_cmake_libevent.cmake
deleted file mode 100644
index 77216670c30f..000000000000
--- a/net-im/telegram-desktop/files/patch-tg__owt_cmake_libevent.cmake
+++ /dev/null
@@ -1,26 +0,0 @@
---- tg_owt/cmake/libevent.cmake.orig 2020-08-30 09:41:57 UTC
-+++ tg_owt/cmake/libevent.cmake
-@@ -17,14 +17,13 @@ if (APPLE)
- else()
- target_include_directories(libevent
- PRIVATE
-- ${libevent_loc}/linux
-+ ${libevent_loc}/freebsd
- )
- endif()
-
- nice_target_sources(libevent ${libevent_loc}
- PRIVATE
- buffer.c
-- epoll.c
- evbuffer.c
- evdns.c
- event.c
-@@ -32,6 +31,7 @@ PRIVATE
- evrpc.c
- evutil.c
- http.c
-+ kqueue.c
- log.c
- poll.c
- select.c
diff --git a/net-im/telegram-desktop/files/patch-tg__owt_src_media_sctp_sctp__transport.cc b/net-im/telegram-desktop/files/patch-tg__owt_src_media_sctp_sctp__transport.cc
deleted file mode 100644
index ebca69089d98..000000000000
--- a/net-im/telegram-desktop/files/patch-tg__owt_src_media_sctp_sctp__transport.cc
+++ /dev/null
@@ -1,20 +0,0 @@
---- tg_owt/src/media/sctp/sctp_transport.cc.orig 2020-10-07 14:11:02 UTC
-+++ tg_owt/src/media/sctp/sctp_transport.cc
-@@ -43,7 +43,7 @@
- #include "rtc_base/thread_annotations.h"
- #include "rtc_base/thread_checker.h"
- #include "rtc_base/trace_event.h"
--#include "usrsctplib/usrsctp.h"
-+#include "usrsctp.h"
-
- namespace {
-
-@@ -470,7 +470,7 @@
- return transport;
- }
-
-- static int SendThresholdCallback(struct socket* sock, uint32_t sb_free) {
-+ static int SendThresholdCallback(struct socket* sock, uint32_t sb_free, void *ulp_info) {
- // Fired on our I/O thread. SctpTransport::OnPacketReceived() gets
- // a packet containing acknowledgments, which goes into usrsctp_conninput,
- // and then back here.
diff --git a/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_byte__order.h b/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_byte__order.h
deleted file mode 100644
index 75e6ca781e96..000000000000
--- a/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_byte__order.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- tg_owt/src/rtc_base/byte_order.h.orig 2020-08-30 09:41:57 UTC
-+++ tg_owt/src/rtc_base/byte_order.h
-@@ -89,7 +89,7 @@
- #endif // defined(WEBRTC_ARCH_LITTLE_ENDIAN)
-
- #elif defined(WEBRTC_POSIX)
--#include <endian.h>
-+#include <sys/endian.h>
- #else
- #error "Missing byte order functions for this arch."
- #endif // defined(WEBRTC_MAC)
diff --git a/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_ip__address.cc b/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_ip__address.cc
deleted file mode 100644
index d539d30d6282..000000000000
--- a/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_ip__address.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- tg_owt/src/rtc_base/ip_address.cc.orig 2020-08-30 09:41:57 UTC
-+++ tg_owt/src/rtc_base/ip_address.cc
-@@ -15,6 +15,7 @@
- #include <netinet/in_systm.h>
- #endif
- #ifndef __native_client__
-+#include <sys/types.h>
- #include <netinet/ip.h>
- #endif
- #include <netdb.h>
diff --git a/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_physical__socket__server.cc b/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_physical__socket__server.cc
deleted file mode 100644
index d40dea6d99fd..000000000000
--- a/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_physical__socket__server.cc
+++ /dev/null
@@ -1,29 +0,0 @@
---- tg_owt/src/rtc_base/physical_socket_server.cc.orig 2020-08-30 09:41:57 UTC
-+++ tg_owt/src/rtc_base/physical_socket_server.cc
-@@ -51,6 +51,8 @@
- #include "rtc_base/null_socket_server.h"
- #include "rtc_base/time_utils.h"
-
-+#undef WEBRTC_LINUX
-+
- #if defined(WEBRTC_LINUX)
- #include <linux/sockios.h>
- #endif
-@@ -70,7 +72,7 @@ typedef void* SockOptArg;
-
- #endif // WEBRTC_POSIX
-
--#if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(__native_client__)
-+#if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(__native_client__) && !defined(__FreeBSD__)
-
- int64_t GetSocketRecvTimestamp(int socket) {
- struct timeval tv_ioctl;
-@@ -551,7 +553,7 @@ int PhysicalSocket::TranslateOption(Option opt, int* s
- *slevel = IPPROTO_IP;
- *sopt = IP_DONTFRAGMENT;
- break;
--#elif defined(WEBRTC_MAC) || defined(BSD) || defined(__native_client__)
-+#elif defined(WEBRTC_MAC) || defined(BSD) || defined(__native_client__) || defined(__FreeBSD__)
- RTC_LOG(LS_WARNING) << "Socket::OPT_DONTFRAGMENT not supported.";
- return -1;
- #elif defined(WEBRTC_POSIX)
diff --git a/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_physical__socket__server.h b/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_physical__socket__server.h
deleted file mode 100644
index 4deb1446cba7..000000000000
--- a/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_physical__socket__server.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- tg_owt/src/rtc_base/physical_socket_server.h.orig 2020-08-30 09:41:57 UTC
-+++ tg_owt/src/rtc_base/physical_socket_server.h
-@@ -12,8 +12,6 @@
- #define RTC_BASE_PHYSICAL_SOCKET_SERVER_H_
-
- #if defined(WEBRTC_POSIX) && defined(WEBRTC_LINUX)
--#include <sys/epoll.h>
--#define WEBRTC_USE_EPOLL 1
- #endif
-
- #include <memory>
diff --git a/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_platform__thread__types.cc b/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_platform__thread__types.cc
deleted file mode 100644
index ce84319f9895..000000000000
--- a/net-im/telegram-desktop/files/patch-tg__owt_src_rtc__base_platform__thread__types.cc
+++ /dev/null
@@ -1,43 +0,0 @@
---- tg_owt/src/rtc_base/platform_thread_types.cc.orig 2020-08-30 09:41:57 UTC
-+++ tg_owt/src/rtc_base/platform_thread_types.cc
-@@ -11,10 +11,14 @@
- #include "rtc_base/platform_thread_types.h"
-
- #if defined(WEBRTC_LINUX)
--#include <sys/prctl.h>
- #include <sys/syscall.h>
- #endif
-
-+#ifdef __FreeBSD__
-+#include <sys/thr.h>
-+#include <pthread_np.h>
-+#endif
-+
- namespace rtc {
-
- PlatformThreadId CurrentThreadId() {
-@@ -28,7 +32,13 @@ PlatformThreadId CurrentThreadId() {
- #elif defined(WEBRTC_FUCHSIA)
- return zx_thread_self();
- #elif defined(WEBRTC_LINUX)
-+#if defined(__FreeBSD__)
-+ long id;
-+ thr_self(&id);
-+ return id;
-+#else
- return syscall(__NR_gettid);
-+#endif
- #elif defined(__EMSCRIPTEN__)
- return static_cast<PlatformThreadId>(pthread_self());
- #else
-@@ -78,9 +88,7 @@ void SetCurrentThreadName(const char* name) {
- }
- #pragma warning(pop)
- #elif defined(WEBRTC_LINUX) || defined(WEBRTC_ANDROID)
-- prctl(PR_SET_NAME, reinterpret_cast<unsigned long>(name)); // NOLINT
--#elif defined(WEBRTC_MAC) || defined(WEBRTC_IOS)
-- pthread_setname_np(name);
-+ pthread_set_name_np(pthread_self(), name);
- #endif
- }
-