aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 14:51:04 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 14:51:04 +0800
commit9f48528e6e53a3f6a788a0bfcf5f3d434d79921a (patch)
treef134d7bf940f5f50482b60e36c255e9f239360d6 /net-im
parentf25de658a01310d78cbb67209274b82dcbf0878e (diff)
downloadfreebsd-ports-gnome-9f48528e6e53a3f6a788a0bfcf5f3d434d79921a.tar.gz
freebsd-ports-gnome-9f48528e6e53a3f6a788a0bfcf5f3d434d79921a.tar.zst
freebsd-ports-gnome-9f48528e6e53a3f6a788a0bfcf5f3d434d79921a.zip
Convert to new perl framework
Convert from USE_GMAKE to USES=gmake
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabberd/Makefile4
-rw-r--r--net-im/libpurple/Makefile2
-rw-r--r--net-im/ttytter/Makefile3
3 files changed, 5 insertions, 4 deletions
diff --git a/net-im/jabberd/Makefile b/net-im/jabberd/Makefile
index 6189ca686594..9bdc2aeffedc 100644
--- a/net-im/jabberd/Makefile
+++ b/net-im/jabberd/Makefile
@@ -28,9 +28,9 @@ CYRUS_DESC= Use Cyrus SASL backend (not supported)
USE_XZ= yes
GNU_CONFIGURE= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_OPENSSL= yes
-USES= iconv
+USES= iconv perl5
USE_RC_SUBR= jabberd
USE_LDCONFIG= ${PREFIX}/lib/jabberd
CONFIGURE_ARGS+= --localstatedir=/var \
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index d52f08913b69..09fa4b95daec 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -194,7 +194,7 @@ PLIST_SUB+= DBUS="@comment not installed: "
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES+= perl5
CONFIGURE_ARGS+= --with-perl-lib=site
PLIST_SUB+= PERL:=""
.if !defined(PIDGIN_SLAVE)
diff --git a/net-im/ttytter/Makefile b/net-im/ttytter/Makefile
index d1178f3888c6..3e25522b5789 100644
--- a/net-im/ttytter/Makefile
+++ b/net-im/ttytter/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
OPTIONS_DEFINE= READLINE RLTTYTTER
OPTIONS_DEFAULT=READLINE