aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
committertijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
commitb3a361d8eb7b71f0b468fd98e66a366d09af5fcf (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /net-im
parent237bc033e6203c347316781328565cb5a7f8b2cf (diff)
downloadfreebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.gz
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.zst
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.zip
Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. The
first contains runtime libraries such as libintl and the latter contains developer tools such as msgfmt. Ports that use gettext will usually need a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools. USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on devel/gettext-runtime and USES=gettext-tools can be used to set a BUILD/RUN_DEPENDS on devel/gettext-tools. USES=gettext is now the same as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools. Update gettext to 0.19.3. Remove :oldver from converters/libiconv and devel/gettext-runtime. Leave symlinks with the old library versions to avoid the need to bump PORTREVISION on a large number of dependent ports. When most of the dependent ports have had normal version updates, PORTREVISION can be bumped on the remaining ones (low number) and the links can be removed. Fix some ports that installed files in lib/locale instead of share/locale. PR: 194038 Reviewed by: bapt Exp-run: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libpurple/Makefile8
-rw-r--r--net-im/libpurple/pkg-plist44
-rw-r--r--net-im/licq-osd/Makefile2
-rw-r--r--net-im/pidgin/Makefile2
-rw-r--r--net-im/telepathy-logger/Makefile3
5 files changed, 8 insertions, 51 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 5f9209c09376..25e3b857a22a 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= libpurple
PORTVERSION= 2.10.10
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= net-im
MASTER_SITES= SF/pidgin/Pidgin/${PORTVERSION}
DISTNAME= pidgin-${PORTVERSION}
@@ -11,8 +11,8 @@ DISTNAME= pidgin-${PORTVERSION}
MAINTAINER?= marcus@FreeBSD.org
COMMENT?= Backend library for the Pidgin multi-protocol messaging client
-USES= cpe gmake libtool pathfix pkgconfig tar:bzip2
-USE_GNOME?= gnomeprefix intlhack glib20 libxml2
+USES= cpe gettext gmake libtool pathfix pkgconfig tar:bzip2
+USE_GNOME?= gnomeprefix intltool glib20 libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS?=--disable-gtkui \
--disable-consoleui \
@@ -26,7 +26,7 @@ INSTALL_TARGET= install-strip
.if !defined(PIDGIN_SLAVE)
# Pidgin slave ports that require the following functionality, must explicitly
# set these macros themselves.
-USES+= gettext iconv python
+USES+= iconv python
USE_LDCONFIG= yes
WANT_GNOME= yes
diff --git a/net-im/libpurple/pkg-plist b/net-im/libpurple/pkg-plist
index eadae40a48ec..c1691108fbb2 100644
--- a/net-im/libpurple/pkg-plist
+++ b/net-im/libpurple/pkg-plist
@@ -278,47 +278,3 @@ share/sounds/purple/login.wav
share/sounds/purple/logout.wav
share/sounds/purple/receive.wav
share/sounds/purple/send.wav
-@dir share/sounds/purple
-@dir share/purple/ca-certs
-@dir share/purple
-@dir share/locale/zh_HK/LC_MESSAGES
-@dir share/locale/zh_HK
-@dir share/locale/xh/LC_MESSAGES
-@dir share/locale/xh
-@dir share/locale/ur/LC_MESSAGES
-@dir share/locale/ur
-@dir share/locale/te/LC_MESSAGES
-@dir share/locale/te
-@dir share/locale/sw/LC_MESSAGES
-@dir share/locale/sw
-@dir share/locale/sr@latin/LC_MESSAGES
-@dir share/locale/sr@latin
-@dir share/locale/si/LC_MESSAGES
-@dir share/locale/si
-@dir share/locale/ps/LC_MESSAGES
-@dir share/locale/ps
-@dir share/locale/oc/LC_MESSAGES
-@dir share/locale/oc
-@dir share/locale/my_MM/LC_MESSAGES
-@dir share/locale/my_MM
-@dir share/locale/mr/LC_MESSAGES
-@dir share/locale/mr
-@dir share/locale/mhr/LC_MESSAGES
-@dir share/locale/mhr
-@dir share/locale/mai/LC_MESSAGES
-@dir share/locale/mai
-@dir share/locale/ku/LC_MESSAGES
-@dir share/locale/ku
-@dir share/locale/km/LC_MESSAGES
-@dir share/locale/km
-@dir share/locale/dz/LC_MESSAGES
-@dir share/locale/dz
-@dir share/locale/ca@valencia/LC_MESSAGES
-@dir share/locale/ca@valencia
-@dir share/locale/bn_IN/LC_MESSAGES
-@dir share/locale/bn_IN
-@dir share/locale/be@latin/LC_MESSAGES
-@dir share/locale/be@latin
-@dir lib/purple-2
-@dir include/libpurple/media
-@dir include/libpurple
diff --git a/net-im/licq-osd/Makefile b/net-im/licq-osd/Makefile
index 6b4dd2a9850c..239dea4c3d42 100644
--- a/net-im/licq-osd/Makefile
+++ b/net-im/licq-osd/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/licq/licq_qt4-gui.so:${PORTSDIR}/${LICQ_PORT}-qt-g
# plugin (gtk+) and wish run osd with it. i've not tested with
# plugins other than qt-gui
-USES= cmake
+USES= cmake gettext-tools
LOCALES= be de cs es fr pt pt_BR ro ru sv sk
PLIST_FILES= lib/licq/licq_osd.so \
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index 1fd92abefad3..677ee7376a73 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -21,7 +21,7 @@ PIDGIN_SLAVE= yes
WITH_GTKUI= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomeprefix intlhack gtk20
+USE_GNOME= gnomeprefix gtk20
USE_XORG= xscrnsaver sm
WANT_GNOME= yes
CONFIGURE_ARGS= --disable-consoleui \
diff --git a/net-im/telepathy-logger/Makefile b/net-im/telepathy-logger/Makefile
index 4c4ae3bf2108..22f3da7698a6 100644
--- a/net-im/telepathy-logger/Makefile
+++ b/net-im/telepathy-logger/Makefile
@@ -15,7 +15,8 @@ LICENSE= LGPL21
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib
-USES= gmake libtool pathfix pkgconfig python:build tar:bzip2
+USES= gettext-tools gmake libtool pathfix pkgconfig python:build \
+ tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= glib20 gnomedocutils intltool libxml2 \