aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2005-09-11 03:40:48 +0800
committervsevolod <vsevolod@FreeBSD.org>2005-09-11 03:40:48 +0800
commitcad53039002a346ee0502a7a3e185b875a30743a (patch)
tree66b42e5983fb4502cec70e6c8a97e487be2b413b /net-im
parentc2e46c73da726f82ef1bd779649d054d9b14bbc7 (diff)
downloadfreebsd-ports-gnome-cad53039002a346ee0502a7a3e185b875a30743a.tar.gz
freebsd-ports-gnome-cad53039002a346ee0502a7a3e185b875a30743a.tar.zst
freebsd-ports-gnome-cad53039002a346ee0502a7a3e185b875a30743a.zip
Add support of sqlite storage.
PR: 85925 Submitted by: Vivek Khera <vivek@khera.org> Approved by: Kirk Strauser (maintainer)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabberd/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/net-im/jabberd/Makefile b/net-im/jabberd/Makefile
index d531494e8d8b..cf394601be26 100644
--- a/net-im/jabberd/Makefile
+++ b/net-im/jabberd/Makefile
@@ -21,6 +21,7 @@ OPTIONS= POSTGRESQL "Use PostgreSQL for storage and authentication" off \
MYSQL "Use MySQL for storage and authentication" off \
LDAP "Use LDAP for authentication" off \
BDB "Use BDB for storage and authentication" off \
+ SQLITE "Use SQLITE3 for storage" off \
PAM "Use PAM for authentication" off \
PIPE "Enable pipe auth/reg support" off \
DEBUG "Compile with debug information" on
@@ -48,6 +49,13 @@ CONFIGURE_ARGS+=--enable-pgsql
CONFIGURE_ARGS+=--disable-pgsql
.endif
+.if defined(WITH_SQLITE)
+CONFIGURE_ARGS+=--enable-sqlite
+LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
+.else
+CONFIGURE_ARGS+=--disable-sqlite
+.endif
+
.if defined(WITH_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+=--enable-mysql