aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2005-10-19 09:59:28 +0800
committerclsung <clsung@FreeBSD.org>2005-10-19 09:59:28 +0800
commite5f3c5f14d3ac6961f7ac21915d6c4827cb6d4a5 (patch)
tree59642205cfaac8be86fccd586b3605c7ceb2f484 /net-im
parent8731e8b247df9ccb25ebd674bc2a76dff3f2085a (diff)
downloadfreebsd-ports-gnome-e5f3c5f14d3ac6961f7ac21915d6c4827cb6d4a5.tar.gz
freebsd-ports-gnome-e5f3c5f14d3ac6961f7ac21915d6c4827cb6d4a5.tar.zst
freebsd-ports-gnome-e5f3c5f14d3ac6961f7ac21915d6c4827cb6d4a5.zip
- fix libgadu security issues...
libgadu -- multiple vulnerabilities. Reference: <http://www.FreeBSD.org/ports/portaudit/3b4a6982-0b24-11da-bc08-0001020eed82.html>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centericq/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index b2813d818b36..0e25f4136dde 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -8,7 +8,7 @@
PORTNAME= centericq
PORTVERSION= 4.21.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://centericq.de/archive/source/releases/ \
http://thekonst.net/download/
@@ -21,6 +21,7 @@ USE_ICONV= yes
USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
CXXFLAGS="-I${LOCALBASE}/include"
LDFLAGS+= -L${LOCALBASE}/lib -lstdc++
@@ -101,6 +102,9 @@ CONFIGURE_ARGS+= --disable-lj
.if !defined(WITH_GG)
CONFIGURE_ARGS+= --disable-gg
+.else
+LIB_DEPENDS+= gadu.3:${PORTSDIR}/polish/ekg
+LIBGADU= -lgadu
.endif
post-patch:
@@ -109,6 +113,14 @@ post-patch:
${MV} -f ${file} ${file}.orig ; \
${GREP} -v "_G_config.h" ${file}.orig > ${file})
.endfor
+ @${FIND} ${WRKSRC} -name "Makefile*" -type f -print0 | \
+ ${XARGS} -0 \
+ ${REINPLACE_CMD} -E \
+ -e "s|-I\$$\(top_srcdir\)/libgadu-0.1|-I${LOCALBASE}/include|" \
+ -e "s|-L\$$\(top_srcdir\)/libgadu-0.1|-L${LOCALBASE}/lib|" \
+ -e 's|libgadu-0.1/*||' \
+ -e 's|libgadu-0.1||' \
+ -e 's|-llibgadu|${LIBGADU}|'
.if !defined(NOPORTDOCS)
post-install: