aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/airport
diff options
context:
space:
mode:
authornsayer <nsayer@FreeBSD.org>2001-03-07 22:29:56 +0800
committernsayer <nsayer@FreeBSD.org>2001-03-07 22:29:56 +0800
commit9f97686ca66a3c6ce00c850a77a272ff6ab360ba (patch)
tree770ea4a9c52ff079750dcfe879201b8f3cde6e20 /net-mgmt/airport
parentfbac99660f580275f76587992359af6dc922e510 (diff)
downloadfreebsd-ports-gnome-9f97686ca66a3c6ce00c850a77a272ff6ab360ba.tar.gz
freebsd-ports-gnome-9f97686ca66a3c6ce00c850a77a272ff6ab360ba.tar.zst
freebsd-ports-gnome-9f97686ca66a3c6ce00c850a77a272ff6ab360ba.zip
Use the javavmwrapper rather than explicitely naming the jdk.
No PORTREVISION since PORTVERSION was updated, like, 10 seconds ago.
Diffstat (limited to 'net-mgmt/airport')
-rw-r--r--net-mgmt/airport/Makefile4
-rw-r--r--net-mgmt/airport/files/airport2
2 files changed, 3 insertions, 3 deletions
diff --git a/net-mgmt/airport/Makefile b/net-mgmt/airport/Makefile
index 4d93c63305ff..c5abef19c06c 100644
--- a/net-mgmt/airport/Makefile
+++ b/net-mgmt/airport/Makefile
@@ -14,7 +14,8 @@ DISTFILES= configurator_13${EXTRACT_SUFX}
MAINTAINER= nsayer@freebsd.org
RUN_DEPENDS= ${LOCALBASE}/jdk${JDK_VERSION}/bin/java:${PORTSDIR}/java/jdk \
- ${LOCALBASE}/share/java/classes/jfc-${JFC_VERSION}/swingall.jar:${PORTSDIR}/java/jfc
+ ${LOCALBASE}/share/java/classes/jfc-${JFC_VERSION}/swingall.jar:${PORTSDIR}/java/jfc \
+ ${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
USE_ZIP= YES
@@ -32,7 +33,6 @@ do-install:
${MKDIR} ${PREFIX}/share/airport; \
${CP} -r ${WRKSRC}/* ${PREFIX}/share/airport; \
${SED} -e s,%%PREFIX%%,${PREFIX},g \
- -e s/%%JDK_VERSION%%/${JDK_VERSION}/ \
-e s/%%JFC_VERSION%%/${JFC_VERSION}/ \
< ${FILESDIR}/airport > ${PREFIX}/bin/airport; \
${CHMOD} a+x ${PREFIX}/bin/airport
diff --git a/net-mgmt/airport/files/airport b/net-mgmt/airport/files/airport
index 54381a2c1299..4e1254dd28bf 100644
--- a/net-mgmt/airport/files/airport
+++ b/net-mgmt/airport/files/airport
@@ -1,5 +1,5 @@
#! /bin/sh
-exec %%PREFIX%%/jdk%%JDK_VERSION%%/bin/jre -cp "%%PREFIX%%/share/java/classes/jfc-%%JFC_VERSION%%/swingall.jar:%%PREFIX%%/share/airport/AirportBaseStationConfig.jar" AirportBaseStationConfigurator
+exec %%PREFIX%%/bin/javavm -cp "%%PREFIX%%/share/java/classes/jfc-%%JFC_VERSION%%/swingall.jar:%%PREFIX%%/share/airport/AirportBaseStationConfig.jar" AirportBaseStationConfigurator
exit 1