aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/collectd
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-02-25 08:47:51 +0800
committermiwi <miwi@FreeBSD.org>2011-02-25 08:47:51 +0800
commitfcad7d6603fff8cde093f411f3c1b860d1721a6a (patch)
tree480360672129bf0c49f6b94e20c9f729f2a8a6e7 /net-mgmt/collectd
parentafca7c67d76daed658334425b473995491edcbb5 (diff)
downloadfreebsd-ports-gnome-fcad7d6603fff8cde093f411f3c1b860d1721a6a.tar.gz
freebsd-ports-gnome-fcad7d6603fff8cde093f411f3c1b860d1721a6a.tar.zst
freebsd-ports-gnome-fcad7d6603fff8cde093f411f3c1b860d1721a6a.zip
- Move to py25 or above
- While here kick md5 support
Diffstat (limited to 'net-mgmt/collectd')
-rw-r--r--net-mgmt/collectd/Makefile28
-rw-r--r--net-mgmt/collectd/pkg-plist3
2 files changed, 26 insertions, 5 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 0179458e680c..8cae9b909cf2 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= collectd
PORTVERSION= 4.9.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
@@ -16,9 +16,13 @@ COMMENT= Systems & network statistics collection daemon
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libltdl
+USE_AUTOTOOLS= autoheader aclocal libtool libtoolize automake autoconf libltdl
WANT_GNOME= yes
+AUTOMAKE_ARGS= --add-missing --copy
+LIBTOOLIZE_ARGS= --ltdl --copy --force
+ACLOCAL_ARGS=
+
OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
BIND "Enable BIND 9.5+ statistics" On \
DEBUG "Enable debugging" Off \
@@ -37,8 +41,7 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
PGSQL "Input: PostgreSQL" Off \
PING "Input: Network latency (liboping)" On \
SNMP "Input: SNMP" On \
- XMMS "Input: XMMS" Off \
- RRDTOOL "Output: RRDTool" On
+ XMMS "Input: XMMS" Off
MAN1= collectd.1 collectd-nagios.1 collectdmon.1
MAN5= collectd.conf.5 collectd-email.5 collectd-exec.5 \
@@ -53,6 +56,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
+.if ( ${OSVERSION} >= 800000 )
+OPTIONS+= ZFS_ARC "Input: ZFS ARC" Off
+.else
+.undef WITH_ZFS_ARC
+.endif
+
+OPTIONS+= RRDTOOL "Output: RRDTool" On
+
.if ( ${OSVERSION} < 601103 )
BROKEN= Need bind9 import post 6.1
.endif
@@ -123,7 +134,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-vserver \
--disable-wireless \
--disable-write_http \
- --disable-zfs_arc \
--without-perl-bindings
.if defined(WITH_DEBUG)
@@ -315,6 +325,14 @@ CONFIGURE_ARGS+=--disable-xmms
PLIST_SUB+= XMMS="@comment "
.endif
+.if defined(WITH_ZFS_ARC) && ( ${OSVERSION} >= 800000 )
+CONFIGURE_ARGS+=--enable-zfs_arc
+PLIST_SUB+= ZFS_ARC=""
+.else
+CONFIGURE_ARGS+=--disable-zfs_arc
+PLIST_SUB+= ZFS_ARC="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} \
-e 's;@prefix@/var/;/var/;' \
diff --git a/net-mgmt/collectd/pkg-plist b/net-mgmt/collectd/pkg-plist
index b899a8f03e4c..8d5652aeb47f 100644
--- a/net-mgmt/collectd/pkg-plist
+++ b/net-mgmt/collectd/pkg-plist
@@ -134,6 +134,9 @@ libdata/pkgconfig/libcollectdclient.pc
%%XMMS%%lib/collectd/xmms.a
%%XMMS%%lib/collectd/xmms.la
%%XMMS%%lib/collectd/xmms.so
+%%ZFS_ARC%%lib/collectd/zfs_arc.a
+%%ZFS_ARC%%lib/collectd/zfs_arc.la
+%%ZFS_ARC%%lib/collectd/zfs_arc.so
%%DATADIR%%/postgresql_default.conf
%%DATADIR%%/types.db
@dirrm lib/collectd