aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/icinga2/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-08-05 00:41:53 +0800
committermarino <marino@FreeBSD.org>2016-08-05 00:41:53 +0800
commitbd018e5dd9446e8fb8e9548b897bb09fac2182c6 (patch)
tree225869ff9f2c9ca578ff86371bfce543a0c74670 /net-mgmt/icinga2/Makefile
parentf9fc215c58d3b1d235732d48eac57663e8698695 (diff)
downloadfreebsd-ports-gnome-bd018e5dd9446e8fb8e9548b897bb09fac2182c6.tar.gz
freebsd-ports-gnome-bd018e5dd9446e8fb8e9548b897bb09fac2182c6.tar.zst
freebsd-ports-gnome-bd018e5dd9446e8fb8e9548b897bb09fac2182c6.zip
net-mgmt/icinga2: Fix LIB_DEPENDS with USES=execinfo
The unconditional specification of libexecinfo.so is redundant on most plaforms that have libexecinfo.so in base. The helper USES=execinfo was created just to avoid this issue, so convert port to that. Approved by: just-fix-it
Diffstat (limited to 'net-mgmt/icinga2/Makefile')
-rw-r--r--net-mgmt/icinga2/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index 5178720f4e65..9067ab38f722 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -13,14 +13,13 @@ LICENSE= GPLv2
BROKEN_powerpc64= Does not build
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
- libyajl.so:devel/yajl \
- libexecinfo.so:devel/libexecinfo # for better debugging
+ libyajl.so:devel/yajl
RUN_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash
USE_GITHUB= yes
GH_ACCOUNT= icinga
-USES= alias bison cmake libedit
+USES= alias bison cmake execinfo libedit
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}