aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nagcon
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2008-03-04 03:49:48 +0800
committerehaupt <ehaupt@FreeBSD.org>2008-03-04 03:49:48 +0800
commit724696bd8cad2c8f5adf9e11ed6a4a5e6852fe7e (patch)
tree8ad947f958b9d24e987aac0a93e7d07bf41fd3a5 /net-mgmt/nagcon
parent71313bff6ec55e0179c33702fd7bc357bca57192 (diff)
downloadfreebsd-ports-gnome-724696bd8cad2c8f5adf9e11ed6a4a5e6852fe7e.tar.gz
freebsd-ports-gnome-724696bd8cad2c8f5adf9e11ed6a4a5e6852fe7e.tar.zst
freebsd-ports-gnome-724696bd8cad2c8f5adf9e11ed6a4a5e6852fe7e.zip
- Update to 0.0.26
- Add an additional mirror PR: 121190 Submitted by: "Douglas K. Rand" <rand@meridian-enviro.com> (maintainer)
Diffstat (limited to 'net-mgmt/nagcon')
-rw-r--r--net-mgmt/nagcon/Makefile29
-rw-r--r--net-mgmt/nagcon/distinfo6
-rw-r--r--net-mgmt/nagcon/files/patch-br.cpp10
-rw-r--r--net-mgmt/nagcon/files/patch-utils.cpp12
-rw-r--r--net-mgmt/nagcon/pkg-descr4
5 files changed, 51 insertions, 10 deletions
diff --git a/net-mgmt/nagcon/Makefile b/net-mgmt/nagcon/Makefile
index bcadd366f68a..b08950fda476 100644
--- a/net-mgmt/nagcon/Makefile
+++ b/net-mgmt/nagcon/Makefile
@@ -6,16 +6,35 @@
#
PORTNAME= nagcon
-PORTVERSION= 0.0.15
-PORTREVISION= 1
+PORTVERSION= 0.0.26
CATEGORIES= net-mgmt
-MASTER_SITES= http://www.vanheusden.com/nagcon/
+MASTER_SITES= http://www.vanheusden.com/nagcon/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= ehaupt
EXTRACT_SUFX= .tgz
MAINTAINER= rand@meridian-enviro.com
-COMMENT= Nagios 2.0 console monitor
+COMMENT= Nagios console monitor
+
+LIB_DEPENDS= strfunc.9:${PORTSDIR}/devel/libstrfunc
-USE_GMAKE= YES
PLIST_FILES= bin/nagcon
+CFILES= error.c
+CPPFILES= utils.cpp br.cpp nc.cpp pl.cpp
+
+CFLAGS+= -DVERSION=\"${PORTVERSION}\" -I${LOCALBASE}/include
+LDFLAGS+= -lncurses -lstdc++ -L${LOCALBASE}/lib -lstrfunc
+
+do-build:
+ ${CC} ${CFLAGS} -c -o ${WRKSRC}/${CFILES:C/\.c//}.o ${WRKSRC}/${CFILES}
+.for f in ${CPPFILES}
+ ${CXX} ${CFLAGS} -c -o ${WRKSRC}/${f:C/\.cpp//}.o ${WRKSRC}/${f}
+.endfor
+ ${CC} ${LDFLAGS} ${WRKSRC}/error.o ${CPPFILES:C/(.*)\.cpp/${WRKSRC}\/\1.o/} \
+ -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
.include <bsd.port.mk>
diff --git a/net-mgmt/nagcon/distinfo b/net-mgmt/nagcon/distinfo
index 0b567e2a85cf..143bc928b50e 100644
--- a/net-mgmt/nagcon/distinfo
+++ b/net-mgmt/nagcon/distinfo
@@ -1,3 +1,3 @@
-MD5 (nagcon-0.0.15.tgz) = 05e40346aa7c7aa3b831595df057db87
-SHA256 (nagcon-0.0.15.tgz) = 467b2ba1ef265d3990d5aff14874c0c8249161be1d89cde8dda4376197fe3dc2
-SIZE (nagcon-0.0.15.tgz) = 13487
+MD5 (nagcon-0.0.26.tgz) = 695387e635e42943fc4a8e1ec82d5cda
+SHA256 (nagcon-0.0.26.tgz) = cb075a804a699dede1eab7497d2819b90ce5bd6440286468294c4159a531d7ef
+SIZE (nagcon-0.0.26.tgz) = 15343
diff --git a/net-mgmt/nagcon/files/patch-br.cpp b/net-mgmt/nagcon/files/patch-br.cpp
new file mode 100644
index 000000000000..7d2b4b35e175
--- /dev/null
+++ b/net-mgmt/nagcon/files/patch-br.cpp
@@ -0,0 +1,10 @@
+--- br.cpp.orig Thu Feb 28 15:12:00 2008
++++ br.cpp Thu Feb 28 15:12:12 2008
+@@ -28,6 +28,7 @@
+ #include <sys/mman.h>
+ #include <fcntl.h>
+ #include <syslog.h>
++#include <strfunc.h>
+ #include "br.h"
+
+ buffered_reader::buffered_reader(int cur_fd, int cur_block_size)
diff --git a/net-mgmt/nagcon/files/patch-utils.cpp b/net-mgmt/nagcon/files/patch-utils.cpp
new file mode 100644
index 000000000000..f79864dd06c9
--- /dev/null
+++ b/net-mgmt/nagcon/files/patch-utils.cpp
@@ -0,0 +1,12 @@
+--- utils.cpp.orig Thu Feb 28 14:48:39 2008
++++ utils.cpp Thu Feb 28 15:11:48 2008
+@@ -29,6 +29,9 @@
+ #include <netdb.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <arpa/inet.h>
++#include <netinet/in.h>
++#include <strfunc.h>
+ extern "C" {
+ #include "error.h"
+ }
diff --git a/net-mgmt/nagcon/pkg-descr b/net-mgmt/nagcon/pkg-descr
index 6b5ebf5e55e7..260fec892a90 100644
--- a/net-mgmt/nagcon/pkg-descr
+++ b/net-mgmt/nagcon/pkg-descr
@@ -1,4 +1,4 @@
-Nagcon is a console application interfacing to Nagios 2.0 which gives
-you an overview of all services with troubled services.
+Nagcon is a console application interfacing to Nagios 2.0 and 3.0
+which gives you an overview of all services with troubled services.
WWW: http://www.vanheusden.com/nagcon