aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nagios-openldap-plugins
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-08-10 16:29:14 +0800
committerantoine <antoine@FreeBSD.org>2014-08-10 16:29:14 +0800
commit7713e209a4165b2a79a35de5e8d41ea8345eb21e (patch)
tree9f5a13b7a5449482b1d47a71543b13eddb5dd89f /net-mgmt/nagios-openldap-plugins
parentb9c9cecd7e280fe3d50812dded5e623947ab34a3 (diff)
downloadfreebsd-ports-gnome-7713e209a4165b2a79a35de5e8d41ea8345eb21e.tar.gz
freebsd-ports-gnome-7713e209a4165b2a79a35de5e8d41ea8345eb21e.tar.zst
freebsd-ports-gnome-7713e209a4165b2a79a35de5e8d41ea8345eb21e.zip
Fix a stage violation and shebangfix
Diffstat (limited to 'net-mgmt/nagios-openldap-plugins')
-rw-r--r--net-mgmt/nagios-openldap-plugins/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-mgmt/nagios-openldap-plugins/Makefile b/net-mgmt/nagios-openldap-plugins/Makefile
index a91422faf015..68f60c789621 100644
--- a/net-mgmt/nagios-openldap-plugins/Makefile
+++ b/net-mgmt/nagios-openldap-plugins/Makefile
@@ -21,8 +21,9 @@ RUN_DEPENDS= p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap \
PORTSCOUT= ignore:1
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
+SHEBANG_FILES= check_*.pl
PLIST_FILES= libexec/nagios/check_berkeleydb_locks.pl \
libexec/nagios/check_ldap_dn.pl \
@@ -44,7 +45,7 @@ post-patch:
${WRKSRC}/*.pl
do-install:
- @${MKDIR} ${PREFIX}/libexec/nagios
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
@(cd ${WRKSRC} && ${COPYTREE_BIN} . ${STAGEDIR}${PREFIX}/libexec/nagios/)
.include <bsd.port.mk>