aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-10-08 12:14:54 +0800
committerRong-En Fan <rafan@FreeBSD.org>2007-10-08 12:14:54 +0800
commitd255213cfbcd7142e6f224cbd795d805e218f0ce (patch)
tree4f3bbec458285591807373e7eb36beb25d84fe9c /net-mgmt/nagios-plugins
parentba934c092d72e108449dc200faa04a1f6d7a2589 (diff)
downloadfreebsd-ports-gnome-d255213cfbcd7142e6f224cbd795d805e218f0ce.tar.gz
freebsd-ports-gnome-d255213cfbcd7142e6f224cbd795d805e218f0ce.tar.zst
freebsd-ports-gnome-d255213cfbcd7142e6f224cbd795d805e218f0ce.zip
- When libexecdir does not exist, the installed perl based plugins gets wrong
use lib directive. This is due to the installation procedure assumes the existence of libexecdir. Fix this problem and bump PORTREVISION. PR: ports/115443 Reported by: Stefan Kaltenbrunner <stefan at kaltenbrunner.cc> Patched by: Jarrod Sayers <jarrod at netleader.com.au> (maintainer)
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile2
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index ab8b847f1bc9..4be6e3ca375d 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nagios-plugins
PORTVERSION= 1.4.9
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in
new file mode 100644
index 000000000000..35b676b95201
--- /dev/null
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in
@@ -0,0 +1,11 @@
+--- plugins-scripts/subst.in.orig Wed Aug 31 07:41:42 2005
++++ plugins-scripts/subst.in Sun Sep 30 18:16:42 2007
+@@ -1,7 +1,7 @@
+ #!/usr/bin/awk
+
+ function which(c,path) {
+- cmd = "test -x " c;
++ cmd = "[ " c " = @libexecdir@ ] || test -x " c;
+
+ if (system(cmd)==0) {
+ return c;