aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/ndpmon
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2011-09-26 00:47:03 +0800
committerzi <zi@FreeBSD.org>2011-09-26 00:47:03 +0800
commit882364a9125cefe04fd4d01361b67d15c8454f39 (patch)
treef9e02c52473c25e4749adf1bf17426119265fbde /net-mgmt/ndpmon
parentda9c7d34b1818274f734673fd015f4a479d32014 (diff)
downloadfreebsd-ports-gnome-882364a9125cefe04fd4d01361b67d15c8454f39.tar.gz
freebsd-ports-gnome-882364a9125cefe04fd4d01361b67d15c8454f39.tar.zst
freebsd-ports-gnome-882364a9125cefe04fd4d01361b67d15c8454f39.zip
- Silence startup noise [1]
- Fix build with custom PREFIX/LOCALBASE - Fix build when using CLANG - Add OPTIONS for MAC resolution - Add LICENSE PR: ports/159915 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu> (maintainer) [1]
Diffstat (limited to 'net-mgmt/ndpmon')
-rw-r--r--net-mgmt/ndpmon/Makefile14
-rw-r--r--net-mgmt/ndpmon/files/ndpmonitor.in2
2 files changed, 13 insertions, 3 deletions
diff --git a/net-mgmt/ndpmon/Makefile b/net-mgmt/ndpmon/Makefile
index 6471c3256250..08c1de70d1f6 100644
--- a/net-mgmt/ndpmon/Makefile
+++ b/net-mgmt/ndpmon/Makefile
@@ -14,7 +14,11 @@ EXTRACT_SUFX= .tgz
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= On-link icmpv6 message monitoring and reporting daemon
-OPTIONS= PY4SUITE "Depend on py-4suite-xml (for generating HTML)" off
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+OPTIONS= PY4SUITE "Depend on py-4suite-xml (for generating HTML)" off \
+ MACRESOLV "Enable MAC Manufacturer Resolution" off
.include <bsd.port.options.mk>
@@ -30,13 +34,19 @@ USE_GNOME= libxml2
USE_PERL5_RUN= yes
USE_RC_SUBR= ndpmonitor
+MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= OSTYPE=FreeBSD
-CONFIGURE_ARGS= --with-var-datadir=${PREFIX}/var --with-confdir=${ETCDIR}
+CONFIGURE_ARGS= --with-var-datadir=${PREFIX}/var --with-confdir=${ETCDIR} \
+ --with-libxml2=${LOCALBASE} --cache-file=/dev/null
MAN8= ndpmon.8
PORTDOCS= INSTALL README
+.if defined(WITH_MACRESOLV)
+CONFIGURE_ARGS+=--enable-mac-resolv
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/net-mgmt/ndpmon/files/ndpmonitor.in b/net-mgmt/ndpmon/files/ndpmonitor.in
index 8742713fcadf..c7a1d2449d2b 100644
--- a/net-mgmt/ndpmon/files/ndpmonitor.in
+++ b/net-mgmt/ndpmon/files/ndpmonitor.in
@@ -18,6 +18,6 @@ load_rc_config $name
: ${ndpmonitor_enable="NO"}
-command_args=">/dev/null &"
+command_args=">/dev/null 2>&1 &"
run_rc_command "$1"