aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/net-snmp
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2019-07-07 23:17:18 +0800
committerDima Panov <fluffy@FreeBSD.org>2019-07-07 23:17:18 +0800
commit72a0cbc85c7af349d9ca778dcdb4e406da8cef12 (patch)
tree212b33624a1ad1f85e7d4ea2c7684f37e72281f4 /net-mgmt/net-snmp
parentb2494d5a01cad13a835fb0be3ed64660425fc6fd (diff)
downloadfreebsd-ports-gnome-72a0cbc85c7af349d9ca778dcdb4e406da8cef12.tar.gz
freebsd-ports-gnome-72a0cbc85c7af349d9ca778dcdb4e406da8cef12.tar.zst
freebsd-ports-gnome-72a0cbc85c7af349d9ca778dcdb4e406da8cef12.zip
- Real unbreak with openssl111 from ports
- Use ${OPENSSLBASE} instead of hardcode path - Add more conditions to check for extra patch - TLS option is fine now PR: 228898 Submitted by: myself (this patch) Approved by: maintainer timeout (>2 months after submission) MFH: 2019Q3
Diffstat (limited to 'net-mgmt/net-snmp')
-rw-r--r--net-mgmt/net-snmp/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 100335a7f9bd..868f991fc57b 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= snmp
PORTVERSION= 5.7.3
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION} \
ZI
@@ -16,8 +16,6 @@ COMMENT= Extendable SNMP implementation
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_SSL= openssl111
-
LIB_DEPENDS= libpkg.so:ports-mgmt/pkg
NOT_FOR_ARCHS= mips mips64
@@ -77,7 +75,7 @@ TLS_CONFIGURE_ON= --with-security-modules=tsm --with-transports=TLSTCP,DTLSUDP
.include <bsd.port.options.mk>
-.if ${OSVERSION} >= 1200085
+.if (${OSVERSION} >= 1200085 || ${SSL_DEFAULT:Mopenssl111*})
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-openssl11
.endif
@@ -96,7 +94,7 @@ PLIST_SUB+= PYDISTUTILS_PKGVERSION=${PYDISTUTILS_PKGVERSION}
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
-CONFIGURE_ARGS+=--with-openssl="/usr"
+CONFIGURE_ARGS+=--with-openssl="${OPENSSLBASE}"
.if ${PORT_OPTIONS:MDUMMY}
CONFIGURE_ARGS+=--with-dummy-values
@@ -252,6 +250,10 @@ post-patch:
${WRKSRC}/agent/mibgroup/host/hr_system.c
@${REINPLACE_CMD} -E -e 's|return pci_lookup_name|disabled broken|g' \
${WRKSRC}/configure
+.if (${OSVERSION} >= 1200085 || ${SSL_DEFAULT:Mopenssl111*})
+ @${REINPLACE_CMD} -E -e 's|SSL_library_init|OPENSSL_init_ssl|g' \
+ ${WRKSRC}/configure
+.endif
@${CP} ${WRKSRC}/include/net-snmp/system/freebsd12.h \
${WRKSRC}/include/net-snmp/system/freebsd13.h