aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/net-snmp
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-09-04 07:18:09 +0800
committermat <mat@FreeBSD.org>2015-09-04 07:18:09 +0800
commit9eeb1be8abe1959d31662dac4e93a7b1156ebf3f (patch)
tree585220d60d73f71028aa4d93865c3447d8b02a6c /net-mgmt/net-snmp
parentdd740fd76a5062724ccace6e49d84dadabf16b87 (diff)
downloadfreebsd-ports-gnome-9eeb1be8abe1959d31662dac4e93a7b1156ebf3f.tar.gz
freebsd-ports-gnome-9eeb1be8abe1959d31662dac4e93a7b1156ebf3f.tar.zst
freebsd-ports-gnome-9eeb1be8abe1959d31662dac4e93a7b1156ebf3f.zip
Fix build with the two latest lang/perl5-devel.
Approved by: zi Sponsored by: Absolight
Diffstat (limited to 'net-mgmt/net-snmp')
-rw-r--r--net-mgmt/net-snmp/files/patch-perl5.2370
1 files changed, 70 insertions, 0 deletions
diff --git a/net-mgmt/net-snmp/files/patch-perl5.23 b/net-mgmt/net-snmp/files/patch-perl5.23
index 96219763f636..bb382f20ba2e 100644
--- a/net-mgmt/net-snmp/files/patch-perl5.23
+++ b/net-mgmt/net-snmp/files/patch-perl5.23
@@ -63,3 +63,73 @@
#include <net-snmp/net-snmp-config.h>
#include <net-snmp/net-snmp-includes.h>
#include <net-snmp/agent/net-snmp-agent-includes.h>
+--- perl/ASN/Makefile.PL.orig 2014-12-08 20:23:22 UTC
++++ perl/ASN/Makefile.PL
+@@ -1,3 +1,4 @@
++package ASN;
+ use ExtUtils::MakeMaker;
+ require 5;
+ use Config;
+--- perl/AnyData_SNMP/Makefile.PL.orig 2015-09-03 22:27:45 UTC
++++ perl/AnyData_SNMP/Makefile.PL
+@@ -1,3 +1,4 @@
++package AnyData_SNMP;
+ use ExtUtils::MakeMaker;
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
+--- perl/OID/Makefile.PL.orig 2014-12-08 20:23:22 UTC
++++ perl/OID/Makefile.PL
+@@ -1,3 +1,4 @@
++package OID;
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
+
+--- perl/SNMP/Makefile.PL.orig 2014-12-08 20:23:22 UTC
++++ perl/SNMP/Makefile.PL
+@@ -1,3 +1,4 @@
++package SNMP;
+ use ExtUtils::MakeMaker;
+ require 5;
+ use Config;
+--- perl/TrapReceiver/Makefile.PL.orig 2014-12-08 20:23:22 UTC
++++ perl/TrapReceiver/Makefile.PL
+@@ -1,3 +1,4 @@
++package TrapReceiver;
+ use ExtUtils::MakeMaker;
+ require 5;
+ use Config;
+--- perl/agent/Makefile.PL.orig 2014-12-08 20:23:22 UTC
++++ perl/agent/Makefile.PL
+@@ -1,3 +1,4 @@
++package agent;
+ use ExtUtils::MakeMaker;
+ require 5;
+ use Config;
+--- perl/agent/Support/Makefile.PL.orig 2014-12-08 20:23:22 UTC
++++ perl/agent/Support/Makefile.PL
+@@ -1,3 +1,4 @@
++package agent_Support;
+ use ExtUtils::MakeMaker;
+ require 5;
+ use Config;
+--- perl/agent/default_store/Makefile.PL.orig 2014-12-08 20:23:22 UTC
++++ perl/agent/default_store/Makefile.PL
+@@ -1,3 +1,4 @@
++package agent_default_store;
+ use ExtUtils::MakeMaker;
+ require 5;
+ use Config;
+--- perl/default_store/Makefile.PL.orig 2014-12-08 20:23:22 UTC
++++ perl/default_store/Makefile.PL
+@@ -1,3 +1,4 @@
++package default_store;
+ use ExtUtils::MakeMaker;
+ require 5;
+ use Config;
+--- perl/manager/Makefile.PL.orig 2014-12-08 20:23:22 UTC
++++ perl/manager/Makefile.PL
+@@ -1,3 +1,4 @@
++package manager;
+ use ExtUtils::MakeMaker;
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.