aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/netams-front
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-11 06:36:07 +0800
committermiwi <miwi@FreeBSD.org>2009-05-11 06:36:07 +0800
commitce5a89db607dbc8fa87b7e81fe55bb32267b9788 (patch)
tree9172aae3310bb67b0bfc63939c92d1de02717c2f /net-mgmt/netams-front
parent9f3524c0ca08421d4c3d536918c2a3903251e5e0 (diff)
downloadfreebsd-ports-gnome-ce5a89db607dbc8fa87b7e81fe55bb32267b9788.tar.gz
freebsd-ports-gnome-ce5a89db607dbc8fa87b7e81fe55bb32267b9788.tar.zst
freebsd-ports-gnome-ce5a89db607dbc8fa87b7e81fe55bb32267b9788.zip
NetAms Front - is an alternative to builtin web interface for NeTAMS software.
One of the main advantages of this interface is use of PHP for generation of dynamic page allowing highly configurable web statistic available for system administrator with NeTAMS. Features: - View traffic for all the configured networks and peers - Manage accounting policies with web interface - Manage NeTAMS peers: clusters, networks, groups, hosts and users with web interface - NeTAMS database service WWW: http://netams.it2k.ru PR: ports/134426 Submitted by: Alexey V. Degtyarev
Diffstat (limited to 'net-mgmt/netams-front')
-rw-r--r--net-mgmt/netams-front/Makefile52
-rw-r--r--net-mgmt/netams-front/distinfo3
-rw-r--r--net-mgmt/netams-front/files/patch-config.php.simple15
-rw-r--r--net-mgmt/netams-front/files/pkg-message.in28
-rw-r--r--net-mgmt/netams-front/pkg-descr17
-rw-r--r--net-mgmt/netams-front/pkg-plist81
6 files changed, 196 insertions, 0 deletions
diff --git a/net-mgmt/netams-front/Makefile b/net-mgmt/netams-front/Makefile
new file mode 100644
index 000000000000..a57c371fc1aa
--- /dev/null
+++ b/net-mgmt/netams-front/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: netams-front
+# Date created: Sun 10 May 2009
+# Whom: Alexey V. Degtyarev
+#
+# $FreeBSD$
+#
+
+PORTNAME= netams-front
+PORTVERSION= 0.4
+CATEGORIES= net-mgmt www
+MASTER_SITES= ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= PHP-based web interface for NeTAMS software
+
+NO_BUILD= yes
+
+USE_MYSQL= yes
+WANT_PHP_WEB= yes
+USE_PHP= mysql pcre
+
+SUB_FILES= pkg-message
+
+# This target is only meant to be used by the port maintainer.
+x-generate-plist: build
+ cd ${WRKSRC}/www; \
+ ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
+ ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
+ ${FIND} . -type d | ${SORT} -r | ${SED} \
+ -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
+ -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
+do-install:
+ @cd ${WRKSRC}/www; \
+ for src in $$( ${FIND} . ! -name '*.orig' -a \
+ ! -name 'config.php.simple' ) ; do \
+ dst=${WWWDIR}$${src#.} ; \
+ if ${TEST} -d $$src ; then \
+ ${MKDIR} $$dst ; \
+ else \
+ ${INSTALL_DATA} $$src $$dst ; \
+ fi \
+ done
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/www/config.php.simple \
+ ${EXAMPLESDIR}/config.php
+ @if ! ${TEST} -f ${WWWDIR}/config.php; then \
+ ${INSTALL_DATA} ${WRKSRC}/www/config.php.simple \
+ ${WWWDIR}/config.php; \
+ fi
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/netams-front/distinfo b/net-mgmt/netams-front/distinfo
new file mode 100644
index 000000000000..bb01a4657124
--- /dev/null
+++ b/net-mgmt/netams-front/distinfo
@@ -0,0 +1,3 @@
+MD5 (netams-front-0.4.tar.gz) = 325d4e8aea9947de81e981d74e63b482
+SHA256 (netams-front-0.4.tar.gz) = c3e8cb97bea93c0f80532fa733e62b2b27d1e394b0062cb5a8cbfd27e7d409f3
+SIZE (netams-front-0.4.tar.gz) = 63362
diff --git a/net-mgmt/netams-front/files/patch-config.php.simple b/net-mgmt/netams-front/files/patch-config.php.simple
new file mode 100644
index 000000000000..f30823814cb8
--- /dev/null
+++ b/net-mgmt/netams-front/files/patch-config.php.simple
@@ -0,0 +1,15 @@
+--- www/config.php.simple.orig 2009-04-06 16:24:21.000000000 +0400
++++ www/config.php.simple 2009-05-10 19:30:54.000000000 +0400
+@@ -12,0 +13,2 @@
++header("Content-Type: text/html; charset=utf-8");
++
+@@ -67 +69 @@
+-$data_base[$i]['netamsclient'] = "ctl";
++$data_base[$i]['netamsclient'] = "telnet";
+@@ -95 +97 @@
+-$data_base[$i]['adv_users'] = "127.0.0.1 192.168.0.1 192.168.0.2";
++$data_base[$i]['adv_users'] = $cfg['admins_ip'] . "127.0.0.1 192.168.0.1 192.168.0.2";
+@@ -101 +103 @@
+-?>
+\ No newline at end of file
++?>
diff --git a/net-mgmt/netams-front/files/pkg-message.in b/net-mgmt/netams-front/files/pkg-message.in
new file mode 100644
index 000000000000..8c74e7e777e2
--- /dev/null
+++ b/net-mgmt/netams-front/files/pkg-message.in
@@ -0,0 +1,28 @@
+*******************************************************************************
+
+NetAms Front has been installed into:
+
+ %%WWWDIR%%
+
+You can edit config.php to adjust some parameters to your network
+configuration.
+
+To access NetAms Front from web you may want to add the following configuration
+to httpd.conf:
+
+ Alias /netams-front/ "%%WWWDIR%%/"
+
+ <Directory "%%WWWDIR%%/">
+ Options none
+ AllowOverride Limit
+
+ Order Deny,Allow
+ Deny from all
+ Allow from 127.0.0.1 .example.com
+ </Directory>
+
+Try yet another NeTAMS web interface by pointing your browser to
+
+ http://localhost/netams-front/
+
+*******************************************************************************
diff --git a/net-mgmt/netams-front/pkg-descr b/net-mgmt/netams-front/pkg-descr
new file mode 100644
index 000000000000..4560cec851ed
--- /dev/null
+++ b/net-mgmt/netams-front/pkg-descr
@@ -0,0 +1,17 @@
+NetAms Front - is an alternative to builtin web interface for NeTAMS software.
+One of the main advantages of this interface is use of PHP for generation of
+dynamic page allowing highly configurable web statistic available for system
+administrator with NeTAMS.
+
+Features:
+
+- View traffic for all the configured networks and peers
+
+- Manage accounting policies with web interface
+
+- Manage NeTAMS peers: clusters, networks, groups, hosts and users with web
+ interface
+
+- NeTAMS database service
+
+WWW: http://netams.it2k.ru
diff --git a/net-mgmt/netams-front/pkg-plist b/net-mgmt/netams-front/pkg-plist
new file mode 100644
index 000000000000..bc29da28dab0
--- /dev/null
+++ b/net-mgmt/netams-front/pkg-plist
@@ -0,0 +1,81 @@
+%%WWWDIR%%/admin.php
+%%WWWDIR%%/changelog.txt
+%%WWWDIR%%/images/add.gif
+%%WWWDIR%%/images/adv_url.gif
+%%WWWDIR%%/images/arr_left.gif
+%%WWWDIR%%/images/arr_rigth.gif
+%%WWWDIR%%/images/big_cluster.gif
+%%WWWDIR%%/images/big_group.gif
+%%WWWDIR%%/images/big_host.gif
+%%WWWDIR%%/images/big_net.gif
+%%WWWDIR%%/images/big_user.gif
+%%WWWDIR%%/images/calendar.gif
+%%WWWDIR%%/images/delete.gif
+%%WWWDIR%%/images/down.gif
+%%WWWDIR%%/images/folder.gif
+%%WWWDIR%%/images/mini_admin.gif
+%%WWWDIR%%/images/mini_backup.gif
+%%WWWDIR%%/images/mini_cluster.gif
+%%WWWDIR%%/images/mini_configuration.gif
+%%WWWDIR%%/images/mini_database.gif
+%%WWWDIR%%/images/mini_endyear.gif
+%%WWWDIR%%/images/mini_group.gif
+%%WWWDIR%%/images/mini_host.gif
+%%WWWDIR%%/images/mini_net.gif
+%%WWWDIR%%/images/mini_policy.gif
+%%WWWDIR%%/images/mini_server.gif
+%%WWWDIR%%/images/mini_stat.gif
+%%WWWDIR%%/images/mini_user.gif
+%%WWWDIR%%/images/proto/dns.gif
+%%WWWDIR%%/images/proto/ftp.gif
+%%WWWDIR%%/images/proto/icq.gif
+%%WWWDIR%%/images/proto/ip.gif
+%%WWWDIR%%/images/proto/local.gif
+%%WWWDIR%%/images/proto/mail.gif
+%%WWWDIR%%/images/proto/other.gif
+%%WWWDIR%%/images/proto/other_tcp.gif
+%%WWWDIR%%/images/proto/other_udp.gif
+%%WWWDIR%%/images/proto/ping.gif
+%%WWWDIR%%/images/proto/rdesktop.gif
+%%WWWDIR%%/images/proto/samba.gif
+%%WWWDIR%%/images/proto/ssh.gif
+%%WWWDIR%%/images/proto/urls.gif
+%%WWWDIR%%/images/proto/vnc.gif
+%%WWWDIR%%/images/proto/www.gif
+%%WWWDIR%%/images/quota/disabled.gif
+%%WWWDIR%%/images/quota/enabled.gif
+%%WWWDIR%%/images/quota/notset.gif
+%%WWWDIR%%/images/space.gif
+%%WWWDIR%%/images/table/sort_down.gif
+%%WWWDIR%%/images/table/sort_no.gif
+%%WWWDIR%%/images/table/sort_up.gif
+%%WWWDIR%%/images/up.gif
+%%WWWDIR%%/include/class-calendar.php
+%%WWWDIR%%/include/class-ctree.php
+%%WWWDIR%%/include/class-netams-client.php
+%%WWWDIR%%/include/class-table.php
+%%WWWDIR%%/include/db.php
+%%WWWDIR%%/include/functions.js
+%%WWWDIR%%/include/style.css
+%%WWWDIR%%/index.php
+%%WWWDIR%%/kernel.php
+%%WWWDIR%%/modules/mod.base.php
+%%WWWDIR%%/modules/mod.configuration.php
+%%WWWDIR%%/modules/mod.database.php
+%%WWWDIR%%/modules/mod.policy.php
+%%WWWDIR%%/modules/mod.units.php
+%%WWWDIR%%/netams-client.php
+%%WWWDIR%%/quota.php
+%%WWWDIR%%/stat.php
+%%WWWDIR%%/urls.php
+@unexec if cmp -s %D/%%EXAMPLESDIR%%/config.php %D/%%WWWDIR%%/config.php; then rm %D/%%WWWDIR%%/config.php; fi
+%%EXAMPLESDIR%%/config.php
+@exec if ! test -f %D/%%WWWDIR%%/%f; then cp -p %D/%F %D/%%WWWDIR%%/%f; fi
+@dirrm %%WWWDIR%%/modules
+@dirrm %%WWWDIR%%/include
+@dirrm %%WWWDIR%%/images/table
+@dirrm %%WWWDIR%%/images/quota
+@dirrm %%WWWDIR%%/images/proto
+@dirrm %%WWWDIR%%/images
+@dirrmtry %%WWWDIR%%
+@dirrmtry %%EXAMPLESDIR%%