aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/netsaint
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
commit971087c2b4d6b0b917e3fac3ac1334b04f7c9907 (patch)
tree7181a8316bbb1b7be4386d9173b3c6ace07025da /net-mgmt/netsaint
parent0cc85c09b55a7d94ca1d7c16c8eedae091f2840c (diff)
downloadfreebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.gz
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.zst
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Diffstat (limited to 'net-mgmt/netsaint')
-rw-r--r--net-mgmt/netsaint/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-mgmt/netsaint/Makefile b/net-mgmt/netsaint/Makefile
index 026e6f2b8433..9a042d807eae 100644
--- a/net-mgmt/netsaint/Makefile
+++ b/net-mgmt/netsaint/Makefile
@@ -7,7 +7,7 @@
PORTNAME= netsaint
PORTVERSION= 0.0.7
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://netsaint.sourceforge.net/download/ \
@@ -18,15 +18,16 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} netsaint-graphics.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Extremely powerful network monitoring system
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
RUN_DEPENDS= ${LOCALBASE}/libexec/netsaint/check_netsaint:${PORTSDIR}/net/netsaint-plugins
+USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
USE_PERL5= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CPPFLAGS= -I${LOCALBASE}/include
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgd -lgnugetopt"
+ LIBS="-L${LOCALBASE}/lib -lgd"
CONFIGURE_ARGS= --with-command-user=netsaint \
--with-command-grp=www \
--with-netsaint-user=netsaint \