aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nettop
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2006-04-21 22:12:50 +0800
committerleeym <leeym@FreeBSD.org>2006-04-21 22:12:50 +0800
commit9e3f5c648fb83c0db5a71d843c4b1fb26a8f1474 (patch)
tree06fbfd1aa1a159d64103c7e56092bc01b489b510 /net-mgmt/nettop
parent096e08e0e61e1a9d87224a3076463201bfbcdae2 (diff)
downloadfreebsd-ports-gnome-9e3f5c648fb83c0db5a71d843c4b1fb26a8f1474.tar.gz
freebsd-ports-gnome-9e3f5c648fb83c0db5a71d843c4b1fb26a8f1474.tar.zst
freebsd-ports-gnome-9e3f5c648fb83c0db5a71d843c4b1fb26a8f1474.zip
- add nettop-0.2.3
Nettop is a program which looks like top, but is for network packets. It requires libpcap and slang to be installed on your computer. WWW: http://srparish.net/scripts/
Diffstat (limited to 'net-mgmt/nettop')
-rw-r--r--net-mgmt/nettop/Makefile38
-rw-r--r--net-mgmt/nettop/distinfo3
-rw-r--r--net-mgmt/nettop/files/patch-nettop.c19
-rw-r--r--net-mgmt/nettop/pkg-descr4
4 files changed, 64 insertions, 0 deletions
diff --git a/net-mgmt/nettop/Makefile b/net-mgmt/nettop/Makefile
new file mode 100644
index 000000000000..11b4e40ef09f
--- /dev/null
+++ b/net-mgmt/nettop/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: nettop
+# Date created: 21 April 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nettop
+PORTVERSION= 0.2.3
+CATEGORIES= net-mgmt
+MASTER_SITES= http://srparish.net/scripts/
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A program which looks like top, but is for network packets
+
+LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-slang-libraries=${LOCALBASE}/lib \
+ --with-slang-includes=${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-lcurses"
+
+PLIST_FILES= bin/nettop
+PORTDOCS= README THANKS ChangeLog
+
+post-patch:
+.if !exists(/usr/lib/libpthread.so)
+ ${REINPLACE_CMD} -e 's/lpthread/lc_r/g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nettop/distinfo b/net-mgmt/nettop/distinfo
new file mode 100644
index 000000000000..b4456f64e287
--- /dev/null
+++ b/net-mgmt/nettop/distinfo
@@ -0,0 +1,3 @@
+MD5 (nettop-0.2.3.tar.gz) = e76602717e79a26b0ab15ab6799fb1ef
+SHA256 (nettop-0.2.3.tar.gz) = 4dbb2bdb506c4a5a49d67fbd7bcc860008a881abe55271cf3651316620143556
+SIZE (nettop-0.2.3.tar.gz) = 22797
diff --git a/net-mgmt/nettop/files/patch-nettop.c b/net-mgmt/nettop/files/patch-nettop.c
new file mode 100644
index 000000000000..7941e4cd7278
--- /dev/null
+++ b/net-mgmt/nettop/files/patch-nettop.c
@@ -0,0 +1,19 @@
+--- nettop.c.orig Fri Nov 9 11:50:03 2001
++++ nettop.c Fri Apr 21 18:19:58 2006
+@@ -57,7 +57,7 @@
+ #include <signal.h>
+ #include <unistd.h>
+ #include <limits.h>
+-#ifdef sun
++#ifdef __FreeBSD__
+ #include <netinet/in_systm.h>
+ #endif
+ #include <netinet/in.h>
+@@ -361,6 +361,7 @@
+ }
+ break;
+ default:
++ break;
+ }
+ }
+ }
diff --git a/net-mgmt/nettop/pkg-descr b/net-mgmt/nettop/pkg-descr
new file mode 100644
index 000000000000..538de7ea8cdb
--- /dev/null
+++ b/net-mgmt/nettop/pkg-descr
@@ -0,0 +1,4 @@
+Nettop is a program which looks like top, but is for network packets.
+It requires libpcap and slang to be installed on your computer.
+
+WWW: http://srparish.net/scripts/