aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/pixilate
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
committerpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
commitccd12ccd577604add511aad4ea4e71c32b3e2f06 (patch)
tree25b833c135dd7f2323045f819dc7121e621103fc /net-mgmt/pixilate
parente2f15954f8960a944e8d5b2c28982257d8c6e91f (diff)
downloadfreebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.gz
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.zst
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Diffstat (limited to 'net-mgmt/pixilate')
-rw-r--r--net-mgmt/pixilate/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/net-mgmt/pixilate/Makefile b/net-mgmt/pixilate/Makefile
index 38a3cdd50378..fd21bcf9c904 100644
--- a/net-mgmt/pixilate/Makefile
+++ b/net-mgmt/pixilate/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pixilate
PORTVERSION= 0.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= winfingerprint
@@ -14,25 +14,28 @@ MASTER_SITE_SUBDIR= winfingerprint
MAINTAINER= ports@FreeBSD.org
COMMENT= Generates packets to match a list of Cisco PIX access lists
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
WRKSRC= ${WRKDIR}/pixilate
-LIBNET_CONFIG= ${LOCALBASE}/bin/libnet-config
-CFLAGS+= `${LIBNET_CONFIG} --cflags` `${LIBNET_CONFIG} --defines`
-CFLAGS+= -I${LOCALBASE}/include
-LIBS= `${LIBNET_CONFIG} --libs`
-GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake:15 autoconf:253
+USE_AUTOTOOLS= automake:15 autoconf:259
AUTOMAKE_ARGS= --add-missing
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${LIBS}" CPPFLAGS="-I${LOCALBASE}/include"
+#CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${LIBS}" CPPFLAGS="-I${LOCALBASE}/include"
MAN1= pixilate.1
PORTDOCS= README
PLIST_FILES= bin/pixilate
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|libnet-config|${LIBNET_CONFIG}|; \
+ s|--defines`|& `${LIBNET_CONFIG} --cflags`|' \
+ ${WRKSRC}/configure.ac
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}