aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/py-pdagent/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2017-09-15 15:12:44 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-09-15 15:12:44 +0800
commitab1f40794d9dbcc1388a9257d285362f52f74596 (patch)
tree2a6a7e2dc039c429914eaca76a443556bf403df2 /net-mgmt/py-pdagent/Makefile
parentfd6770ac21bfbaf4055314e3e44262e074d8043b (diff)
parent26f34f6d62441f81a8d0d43f1908a496c283ee05 (diff)
downloadfreebsd-ports-gnome-gnome-3.24.tar.gz
freebsd-ports-gnome-gnome-3.24.tar.zst
freebsd-ports-gnome-gnome-3.24.zip
Merge branch 'master' into gnome-3.24gnome-3.24
Diffstat (limited to 'net-mgmt/py-pdagent/Makefile')
-rw-r--r--net-mgmt/py-pdagent/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-mgmt/py-pdagent/Makefile b/net-mgmt/py-pdagent/Makefile
new file mode 100644
index 000000000000..51fde1b2342c
--- /dev/null
+++ b/net-mgmt/py-pdagent/Makefile
@@ -0,0 +1,39 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pdagent
+DISTVERSION= v1.4
+CATEGORIES= net-mgmt python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= PagerDuty Agent software
+
+LICENSE= BSD3CLAUSE
+
+USES= python:2.7 shebangfix
+SHEBANG_FILES= bin/*
+NO_ARCH= yes
+NO_BUILD= yes
+
+USE_RC_SUBR= pdagentd
+
+USE_GITHUB= YES
+GH_ACCOUNT= PagerDuty
+
+SUB_LIST+= PYTHON_CMD="${PYTHON_CMD}"
+
+BINFILES= pd-queue pd-send pdagentd.py
+
+do-patch:
+ ${REINPLACE_CMD} -e 's|/var/lib/pdagent|/var/db/pdagent|' -e 's|/etc|${ETCDIR}|' ${WRKSRC}/pdagent/confdirs.py
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR} ${STAGEDIR}/${ETCDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} pdagent ${STAGEDIR}${PYTHON_SITELIBDIR})
+.for i in ${BINFILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${i} ${STAGEDIR}/${PREFIX}/bin/${i}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/conf/pdagent.conf ${STAGEDIR}/${ETCDIR}/pdagent.conf.sample
+
+.include <bsd.port.mk>