aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/rancid3
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-08-17 04:02:15 +0800
committerfeld <feld@FreeBSD.org>2016-08-17 04:02:15 +0800
commit5b65ecef53e9734e52d7fb23f3b738cfccc89d6a (patch)
tree6a95fda693fdbbe45f64a5960cae7b6b97e9ad26 /net-mgmt/rancid3
parentbaea5bf65a1976bb3896c25492ef006776cef183 (diff)
downloadfreebsd-ports-gnome-5b65ecef53e9734e52d7fb23f3b738cfccc89d6a.tar.gz
freebsd-ports-gnome-5b65ecef53e9734e52d7fb23f3b738cfccc89d6a.tar.zst
freebsd-ports-gnome-5b65ecef53e9734e52d7fb23f3b738cfccc89d6a.zip
net-mgmt/rancid3: Fix SSH on FreeBSD 11.0
RANCID by default attempts to ssh to devices with 3des as the cipher. This no longer works with OpenSSH in FreeBSD 11 as you need to be more specific. Changing this to 3des-cbc works for now, but future versions of OpenSSH will break this as well. Unfortunately this will break RANCID as many network devices do not support modern ciphers, but we will have to deal with that when the time comes. MFH: 2016Q3
Diffstat (limited to 'net-mgmt/rancid3')
-rw-r--r--net-mgmt/rancid3/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net-mgmt/rancid3/Makefile b/net-mgmt/rancid3/Makefile
index b94c57808170..000b0bb2040f 100644
--- a/net-mgmt/rancid3/Makefile
+++ b/net-mgmt/rancid3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rancid
PORTVERSION= 3.4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.shrubbery.net/pub/rancid/
PKGNAMESUFFIX= 3
@@ -59,6 +59,8 @@ pre-everything::
post-patch:
${REINPLACE_CMD} "s|par.1|rancid-par.1|" ${WRKSRC}/man/Makefile.in
${MV} ${WRKSRC}/man/par.1 ${WRKSRC}/man/rancid-par.1
+ ${REINPLACE_CMD} "s|3des|3des-cbc|g" ${WRKSRC}/bin/*.in ${WRKSRC}/cloginrc.sample \
+ ${WRKSRC}/man/cloginrc.5 ${WRKSRC}/man/clogin.1
post-install:
${LN} -s ${PREFIX}/libexec/${PORTNAME}/rancid-cvs ${STAGEDIR}${PREFIX}/bin