aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/scotty3
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2008-09-02 21:44:41 +0800
committermat <mat@FreeBSD.org>2008-09-02 21:44:41 +0800
commit828637f9e837b5a26e9c9569cfd9a79e2a7bceed (patch)
treed6b7138f4455cad8daa105404bdac4bdae986346 /net-mgmt/scotty3
parentb7c65e009597b3340d071f0ef114bfa808d8c676 (diff)
downloadfreebsd-ports-gnome-828637f9e837b5a26e9c9569cfd9a79e2a7bceed.tar.gz
freebsd-ports-gnome-828637f9e837b5a26e9c9569cfd9a79e2a7bceed.tar.zst
freebsd-ports-gnome-828637f9e837b5a26e9c9569cfd9a79e2a7bceed.zip
Make it compile with GCC 4.2
Diffstat (limited to 'net-mgmt/scotty3')
-rw-r--r--net-mgmt/scotty3/Makefile6
-rw-r--r--net-mgmt/scotty3/files/scotty.c2
2 files changed, 2 insertions, 6 deletions
diff --git a/net-mgmt/scotty3/Makefile b/net-mgmt/scotty3/Makefile
index 6d949160fd69..ac38ad3734e6 100644
--- a/net-mgmt/scotty3/Makefile
+++ b/net-mgmt/scotty3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scotty
PORTVERSION= 20000221
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-mgmt tcl tk
MASTER_SITES= ftp://ftp.ibr.cs.tu-bs.de/pub/local/tkined/devel/
DISTNAME= ${PORTNAME}-00-02-21
@@ -58,10 +58,6 @@ LATEST_LINK= scotty3
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
post-patch:
${MV} ${WRKSRC}/scotty.c ${WRKSRC}/scotty.c.orig
${CP} -p ${FILESDIR}/scotty.c ${WRKSRC}/scotty.c
diff --git a/net-mgmt/scotty3/files/scotty.c b/net-mgmt/scotty3/files/scotty.c
index 375cd2a7529e..015c8f743e42 100644
--- a/net-mgmt/scotty3/files/scotty.c
+++ b/net-mgmt/scotty3/files/scotty.c
@@ -2,7 +2,7 @@
#include "tnmInt.h"
-static int
+int
Tcl_AppInit(interp)
Tcl_Interp *interp;
{