aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/yaf
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-09 19:09:00 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-09 19:09:00 +0800
commite0ab20bcaca03cd6fad94f2651833ed8cc510404 (patch)
tree9a8ef2d055f0bee8786434e608371f9b6bd9bfc2 /net-mgmt/yaf
parentaccf1903c492856117086274655361c234507c21 (diff)
downloadfreebsd-ports-gnome-e0ab20bcaca03cd6fad94f2651833ed8cc510404.tar.gz
freebsd-ports-gnome-e0ab20bcaca03cd6fad94f2651833ed8cc510404.tar.zst
freebsd-ports-gnome-e0ab20bcaca03cd6fad94f2651833ed8cc510404.zip
- Update to 2.5.0
- New LIB_DEPENDS syntax - USES=libtool pathfix - Add INSTALL_TARGET=install-strip - Depend on libltdl - Enable extra plugins - Use @sample
Diffstat (limited to 'net-mgmt/yaf')
-rw-r--r--net-mgmt/yaf/Makefile21
-rw-r--r--net-mgmt/yaf/distinfo4
-rw-r--r--net-mgmt/yaf/pkg-plist133
3 files changed, 133 insertions, 25 deletions
diff --git a/net-mgmt/yaf/Makefile b/net-mgmt/yaf/Makefile
index b90c854b337a..fbd569393eea 100644
--- a/net-mgmt/yaf/Makefile
+++ b/net-mgmt/yaf/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= yaf
-PORTVERSION= 2.1.1
-PORTREVISION= 2
+PORTVERSION= 2.5.0
CATEGORIES= net-mgmt
MASTER_SITES= http://tools.netsa.cert.org/releases/
@@ -13,14 +12,16 @@ COMMENT= YAF is Yet Another Flowmeter
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= fixbuf:${PORTSDIR}/net/libfixbuf \
- pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libfixbuf.so:${PORTSDIR}/net/libfixbuf \
+ libpcre.so:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
-USES= pkgconfig perl5
-USE_GNOME= glib20 gnomehack
+INSTALL_TARGET= install-strip
+USES= libtool pathfix perl5 pkgconfig
+USE_AUTOTOOLS= libltdl
+USE_GNOME= glib20
USE_LDCONFIG= yes
-CONFIOGURE_ARGS+= --disable-doxygen
+CONFIGURE_ARGS= --disable-doxygen-doc --enable-applabel --enable-plugins
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
@@ -28,7 +29,9 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
CONFIGURE_ARGS+= --with-dag=${LOCALBASE}
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+post-install:
+.for f in dhcp_fingerprints.conf yafApplabelRules.conf yafDPIRules.conf
+ ${MV} ${STAGEDIR}${PREFIX}/etc/$f ${STAGEDIR}${PREFIX}/etc/$f.sample
+.endfor
.include <bsd.port.mk>
diff --git a/net-mgmt/yaf/distinfo b/net-mgmt/yaf/distinfo
index ed7c889c119e..246263d4362c 100644
--- a/net-mgmt/yaf/distinfo
+++ b/net-mgmt/yaf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (yaf-2.1.1.tar.gz) = 078c7518f6bdc6f9c1a93ec0bc8613be4f9f8090b3ec9cff76f87ddcd54df212
-SIZE (yaf-2.1.1.tar.gz) = 1298770
+SHA256 (yaf-2.5.0.tar.gz) = 79c3498a77e9be11487b22fb6c4fe886965042de3c875c6242b54c3f9e9a4c9d
+SIZE (yaf-2.5.0.tar.gz) = 1530757
diff --git a/net-mgmt/yaf/pkg-plist b/net-mgmt/yaf/pkg-plist
index 083d5a9a8d54..e5638bd26db0 100644
--- a/net-mgmt/yaf/pkg-plist
+++ b/net-mgmt/yaf/pkg-plist
@@ -1,9 +1,13 @@
bin/airdaemon
bin/filedaemon
+bin/getFlowKeyHash
bin/yaf
+bin/yafMeta2Pcap
bin/yafcollect
bin/yafscii
-etc/yafApplabelRules.conf
+@sample etc/dhcp_fingerprints.conf.sample
+@sample etc/yafApplabelRules.conf.sample
+@sample etc/yafDPIRules.conf.sample
include/airframe/airlock.h
include/airframe/airopt.h
include/airframe/airutil.h
@@ -22,10 +26,6 @@ include/airframe/mio_source_tcp.h
include/airframe/mio_source_udp.h
include/airframe/mio_stdio.h
include/airframe/privconfig.h
-include/libltdl/lt_dlloader.h
-include/libltdl/lt_error.h
-include/libltdl/lt_system.h
-include/ltdl.h
include/yaf/CERT_IE.h
include/yaf/autoinc.h
include/yaf/decode.h
@@ -35,28 +35,133 @@ include/yaf/yafcore.h
include/yaf/yafhooks.h
include/yaf/yafrag.h
include/yaf/yaftab.h
-lib/libairframe-%%PORTVERSION%%.so
lib/libairframe-%%PORTVERSION%%.so.4
+lib/libairframe-%%PORTVERSION%%.so.4.0.0
lib/libairframe.a
-lib/libairframe.la
lib/libairframe.so
-lib/libltdl.a
-lib/libltdl.la
-lib/libltdl.so
-lib/libltdl.so.9
-lib/libyaf-%%PORTVERSION%%.so
lib/libyaf-%%PORTVERSION%%.so.4
+lib/libyaf-%%PORTVERSION%%.so.4.0.0
lib/libyaf.a
-lib/libyaf.la
lib/libyaf.so
+lib/yaf/aolplugin.a
+lib/yaf/aolplugin.so
+lib/yaf/aolplugin.so.1
+lib/yaf/aolplugin.so.1.0.1
+lib/yaf/bgpplugin.a
+lib/yaf/bgpplugin.so
+lib/yaf/bgpplugin.so.1
+lib/yaf/bgpplugin.so.1.0.1
+lib/yaf/dhcp_fp_plugin.a
+lib/yaf/dhcp_fp_plugin.so
+lib/yaf/dhcp_fp_plugin.so.1
+lib/yaf/dhcp_fp_plugin.so.1.0.1
+lib/yaf/dhcpplugin.a
+lib/yaf/dhcpplugin.so
+lib/yaf/dhcpplugin.so.1
+lib/yaf/dhcpplugin.so.1.0.1
+lib/yaf/dnp3plugin.a
+lib/yaf/dnp3plugin.so
+lib/yaf/dnp3plugin.so.1
+lib/yaf/dnp3plugin.so.1.0.1
+lib/yaf/dnsplugin.a
+lib/yaf/dnsplugin.so
+lib/yaf/dnsplugin.so.1
+lib/yaf/dnsplugin.so.1.0.1
+lib/yaf/dpacketplugin.a
+lib/yaf/dpacketplugin.so
+lib/yaf/dpacketplugin.so.1
+lib/yaf/dpacketplugin.so.1.0.1
+lib/yaf/dumpplugin.a
+lib/yaf/dumpplugin.so
+lib/yaf/dumpplugin.so.1
+lib/yaf/dumpplugin.so.1.0.1
+lib/yaf/ethipplugin.a
+lib/yaf/ethipplugin.so
+lib/yaf/ethipplugin.so.1
+lib/yaf/ethipplugin.so.1.0.1
+lib/yaf/ircplugin.a
+lib/yaf/ircplugin.so
+lib/yaf/ircplugin.so.1
+lib/yaf/ircplugin.so.1.0.1
+lib/yaf/ldpplugin.a
+lib/yaf/ldpplugin.so
+lib/yaf/ldpplugin.so.1
+lib/yaf/ldpplugin.so.1.0.1
+lib/yaf/modbusplugin.a
+lib/yaf/modbusplugin.so
+lib/yaf/modbusplugin.so.1
+lib/yaf/modbusplugin.so.1.0.1
+lib/yaf/mysqlplugin.a
+lib/yaf/mysqlplugin.so
+lib/yaf/mysqlplugin.so.1
+lib/yaf/mysqlplugin.so.1.0.1
+lib/yaf/nntpplugin.a
+lib/yaf/nntpplugin.so
+lib/yaf/nntpplugin.so.1
+lib/yaf/nntpplugin.so.1.0.1
+lib/yaf/nullplugin.a
+lib/yaf/nullplugin.so
+lib/yaf/nullplugin.so.1
+lib/yaf/nullplugin.so.1.0.1
+lib/yaf/palplugin.a
+lib/yaf/palplugin.so
+lib/yaf/palplugin.so.1
+lib/yaf/palplugin.so.1.0.1
+lib/yaf/piplugin.a
+lib/yaf/piplugin.so
+lib/yaf/piplugin.so.1
+lib/yaf/piplugin.so.1.0.1
+lib/yaf/pop3plugin.a
+lib/yaf/pop3plugin.so
+lib/yaf/pop3plugin.so.1
+lib/yaf/pop3plugin.so.1.0.1
+lib/yaf/pptpplugin.a
+lib/yaf/pptpplugin.so
+lib/yaf/pptpplugin.so.1
+lib/yaf/pptpplugin.so.1.0.1
+lib/yaf/proxyplugin.a
+lib/yaf/proxyplugin.so
+lib/yaf/proxyplugin.so.1
+lib/yaf/proxyplugin.so.1.0.1
+lib/yaf/rtpplugin.a
+lib/yaf/rtpplugin.so
+lib/yaf/rtpplugin.so.1
+lib/yaf/rtpplugin.so.1.0.1
+lib/yaf/slpplugin.a
+lib/yaf/slpplugin.so
+lib/yaf/slpplugin.so.1
+lib/yaf/slpplugin.so.1.0.1
+lib/yaf/snmpplugin.a
+lib/yaf/snmpplugin.so
+lib/yaf/snmpplugin.so.1
+lib/yaf/snmpplugin.so.1.0.1
+lib/yaf/socksplugin.a
+lib/yaf/socksplugin.so
+lib/yaf/socksplugin.so.1
+lib/yaf/socksplugin.so.1.0.1
+lib/yaf/teredoplugin.a
+lib/yaf/teredoplugin.so
+lib/yaf/teredoplugin.so.1
+lib/yaf/teredoplugin.so.1.0.1
+lib/yaf/tftpplugin.a
+lib/yaf/tftpplugin.so
+lib/yaf/tftpplugin.so.1
+lib/yaf/tftpplugin.so.1.0.1
+lib/yaf/tlsplugin.a
+lib/yaf/tlsplugin.so
+lib/yaf/tlsplugin.so.1
+lib/yaf/tlsplugin.so.1.0.1
libdata/pkgconfig/libairframe.pc
libdata/pkgconfig/libyaf.pc
man/man1/airdaemon.1.gz
man/man1/applabel.1.gz
man/man1/filedaemon.1.gz
+man/man1/getFlowKeyHash.1.gz
man/man1/yaf.1.gz
+man/man1/yafMeta2Pcap.1.gz
+man/man1/yafdhcp.1.gz
man/man1/yafdpi.1.gz
man/man1/yafscii.1.gz
+@dirrm lib/yaf
@dirrm include/yaf
-@dirrm include/libltdl
@dirrm include/airframe