aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/zabbix22-frontend
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-12-19 17:20:01 +0800
committervanilla <vanilla@FreeBSD.org>2013-12-19 17:20:01 +0800
commit5cf5ce09af6a7225f1228d3b1704c90db02b791f (patch)
treef89b521ba6221f79ce04368ff21c5dbeea1fddb5 /net-mgmt/zabbix22-frontend
parentdefc3fda4129c6bc89b3e052e43639c531be8724 (diff)
downloadfreebsd-ports-gnome-5cf5ce09af6a7225f1228d3b1704c90db02b791f.tar.gz
freebsd-ports-gnome-5cf5ce09af6a7225f1228d3b1704c90db02b791f.tar.zst
freebsd-ports-gnome-5cf5ce09af6a7225f1228d3b1704c90db02b791f.zip
Add zabbix22-*
PR: ports/183958 Submitted by: Pakhom Golynga (origin zabbix2-* maintainer)
Diffstat (limited to 'net-mgmt/zabbix22-frontend')
-rw-r--r--net-mgmt/zabbix22-frontend/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-mgmt/zabbix22-frontend/Makefile b/net-mgmt/zabbix22-frontend/Makefile
new file mode 100644
index 000000000000..34d4df4c3727
--- /dev/null
+++ b/net-mgmt/zabbix22-frontend/Makefile
@@ -0,0 +1,51 @@
+# Created by: Jim Riggs <ports@christianserving.org>
+# $FreeBSD$
+
+PORTNAME= zabbix22
+PKGNAMESUFFIX= -frontend
+CATEGORIES= net-mgmt
+
+MASTERDIR= ${.CURDIR}/../zabbix22-server
+
+NO_BUILD= yes
+PATCHDIR=
+PLIST= ${PKGDIR}/pkg-plist.frontend
+
+USE_PHP= bcmath ctype gd pcre snmp sockets mbstring session dom xml \
+ xmlreader xmlwriter simplexml gettext ldap
+WANT_PHP_WEB= yes
+
+OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
+OPTIONS_DEFINE= MYSQL MYSQLI PGSQL SQLITE ORACLE
+OPTIONS_DEFAULT= MYSQL MYSQLI
+MYSQLI_DESC= MySQLI backend
+
+NO_STAGE= yes
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMYSQL}
+USE_PHP+= mysql
+.endif
+
+.if ${PORT_OPTIONS:MMYSQLI}
+USE_PHP+= mysqli
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PHP+= pgsql
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE}
+USE_PHP+= sqlite3
+.endif
+
+.if ${PORT_OPTIONS:MORACLE}
+ZABBIX_REQUIRE=
+CONFIGURE_ARGS+= --with-oracle
+.endif
+
+do-install:
+ @${INSTALL} -d ${WWWDIR}
+ @cd ${WRKSRC}/frontends/php/ && ${COPYTREE_SHARE} . ${WWWDIR}
+
+.include "${MASTERDIR}/Makefile"