aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
committermat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
commit3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /net-mgmt
parentbd4297a179c7edf0fe5800bb82c677771f17923c (diff)
downloadfreebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.gz
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.zst
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/icingaweb2/Makefile2
-rw-r--r--net-mgmt/klg/Makefile12
-rw-r--r--net-mgmt/librenms/Makefile4
-rw-r--r--net-mgmt/nagiosql/Makefile2
-rw-r--r--net-mgmt/observium/Makefile4
-rw-r--r--net-mgmt/phpipam/Makefile2
-rw-r--r--net-mgmt/phpweathermap/Makefile2
7 files changed, 16 insertions, 12 deletions
diff --git a/net-mgmt/icingaweb2/Makefile b/net-mgmt/icingaweb2/Makefile
index 08b0fc6561f3..baf11d504b8c 100644
--- a/net-mgmt/icingaweb2/Makefile
+++ b/net-mgmt/icingaweb2/Makefile
@@ -40,7 +40,7 @@ NLS_USE= php=intl
PGSQL_USE= PHP=pdo_pgsql,pgsql
MYSQL_USE= PHP=pdo_mysql
LDAP_USE= PHP=ldap
-PDF_RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:graphics/pecl-imagick
+PDF_RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:graphics/pecl-imagick@${PHP_FLAVOR}
post-patch:
${REINPLACE_CMD} 's%\(/etc/icingaweb2\)%${PREFIX}\1%g' \
diff --git a/net-mgmt/klg/Makefile b/net-mgmt/klg/Makefile
index 70afd76c8ddf..fc29b0796e8e 100644
--- a/net-mgmt/klg/Makefile
+++ b/net-mgmt/klg/Makefile
@@ -11,7 +11,7 @@ COMMENT= PHP-based looking glass for Cisco, Juniper and Quagga/Zebra routers
LICENSE= BSD3CLAUSE
-USES= tar:txz
+USES= tar:txz php
USE_MYSQL= yes
USE_PHP= mysql pcre sockets xml
WANT_PHP_WEB= yes
@@ -33,10 +33,14 @@ OPTIONS_DEFAULT= SSH2
SSH2_DESC= SSH2 support for router access
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSSH2}
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/ssh2.so:security/pecl-ssh2
+. if ${PHP_VER} < 70
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/ssh2.so:security/pecl-ssh2-0@${PHP_FLAVOR}
+. else
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/ssh2.so:security/pecl-ssh2@${PHP_FLAVOR}
+. endif
.endif
do-install:
@@ -47,4 +51,4 @@ do-install:
${CP} ${WRKSRC}/klg_config.php ${STAGEDIR}/${WWWDIR}/klg_config.php.sample
${CP} ${WRKSRC}/klg_template.html ${STAGEDIR}/${WWWDIR}/klg_template.html.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/librenms/Makefile b/net-mgmt/librenms/Makefile
index f55c9b14d68d..aac727459d8b 100644
--- a/net-mgmt/librenms/Makefile
+++ b/net-mgmt/librenms/Makefile
@@ -49,8 +49,8 @@ NO_BUILD= yes
RUN_DEPENDS+= rrdtool:databases/rrdtool \
dot:graphics/graphviz \
- ${LOCALBASE}/share/pear/Net/IPv4.php:net/pear-Net_IPv4 \
- ${LOCALBASE}/share/pear/Net/IPv6.php:net/pear-Net_IPv6 \
+ ${LOCALBASE}/share/pear/Net/IPv4.php:net/pear-Net_IPv4@${PHP_FLAVOR} \
+ ${LOCALBASE}/share/pear/Net/IPv6.php:net/pear-Net_IPv6@${PHP_FLAVOR} \
snmpget:net-mgmt/net-snmp \
bash:shells/bash \
sudo:security/sudo
diff --git a/net-mgmt/nagiosql/Makefile b/net-mgmt/nagiosql/Makefile
index dcbe666adf80..cc8a7c0e5f40 100644
--- a/net-mgmt/nagiosql/Makefile
+++ b/net-mgmt/nagiosql/Makefile
@@ -15,7 +15,7 @@ COMMENT= Web based administration tool for Nagios
LICENSE= GPLv2
RUN_DEPENDS= nagios:net-mgmt/nagios \
- ${PEARDIR}/HTML/Template/IT.php:devel/pear-HTML_Template_IT
+ ${PEARDIR}/HTML/Template/IT.php:devel/pear-HTML_Template_IT@${PHP_FLAVOR}
USE_MYSQL= yes
USES= cpe gettext tar:bzip2
diff --git a/net-mgmt/observium/Makefile b/net-mgmt/observium/Makefile
index 4d2f47db23b2..2b01f60c55f5 100644
--- a/net-mgmt/observium/Makefile
+++ b/net-mgmt/observium/Makefile
@@ -35,8 +35,8 @@ NO_BUILD= yes
RUN_DEPENDS+= rrdtool:databases/rrdtool \
dot:graphics/graphviz \
mtr:net/mtr-nox11 \
- ${LOCALBASE}/share/pear/Net/IPv4.php:net/pear-Net_IPv4 \
- ${LOCALBASE}/share/pear/Net/IPv6.php:net/pear-Net_IPv6 \
+ ${LOCALBASE}/share/pear/Net/IPv4.php:net/pear-Net_IPv4@${PHP_FLAVOR} \
+ ${LOCALBASE}/share/pear/Net/IPv6.php:net/pear-Net_IPv6@${PHP_FLAVOR} \
snmpget:net-mgmt/net-snmp \
sudo:security/sudo
LIB_DEPENDS+= libpng.so:graphics/png
diff --git a/net-mgmt/phpipam/Makefile b/net-mgmt/phpipam/Makefile
index cfa0b983a353..06c782912fc1 100644
--- a/net-mgmt/phpipam/Makefile
+++ b/net-mgmt/phpipam/Makefile
@@ -11,7 +11,7 @@ COMMENT= PHP IP Address Management IPv4/IPv6
LICENSE= GPLv3
-RUN_DEPENDS= ${LOCALBASE}/share/pear/System.php:devel/pear
+RUN_DEPENDS= ${LOCALBASE}/share/pear/System.php:devel/pear@${PHP_FLAVOR}
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/net-mgmt/phpweathermap/Makefile b/net-mgmt/phpweathermap/Makefile
index 47a86d157ce7..e2bc5c26bda7 100644
--- a/net-mgmt/phpweathermap/Makefile
+++ b/net-mgmt/phpweathermap/Makefile
@@ -14,7 +14,7 @@ COMMENT= Network visualisation tool with web editor
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= ${LOCALBASE}/share/pear/Console/Getopt.php:devel/pear \
+RUN_DEPENDS= ${LOCALBASE}/share/pear/Console/Getopt.php:devel/pear@${PHP_FLAVOR} \
rrdtool:databases/rrdtool
NO_BUILD= yes