aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorpkubaj <pkubaj@FreeBSD.org>2019-06-15 20:59:24 +0800
committerpkubaj <pkubaj@FreeBSD.org>2019-06-15 20:59:24 +0800
commit5bbea0f361d7ef5ae8a1fb53959d37d69231fd07 (patch)
treec80eee0b1c44c8d1f79792ae7f94cdcfe905560a /net-mgmt
parent65de0320bc21640d11a84fa022505ec2bf3b486c (diff)
downloadfreebsd-ports-gnome-5bbea0f361d7ef5ae8a1fb53959d37d69231fd07.tar.gz
freebsd-ports-gnome-5bbea0f361d7ef5ae8a1fb53959d37d69231fd07.tar.zst
freebsd-ports-gnome-5bbea0f361d7ef5ae8a1fb53959d37d69231fd07.zip
net-mgmt/xymon-server: fix build with GCC-based architectures
Adding -L/usr/lib when using gcc8 (used on GCC architectures) makes gcc8 link to base libstdc++ which breaks build. Fix this by adding -L${OPENSSLBASE} only when using non-base SSL. PR: 237956 Approved by: feld (maintainer timeout), linimon (mentor, on IRC)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/xymon-server/Makefile2
-rw-r--r--net-mgmt/xymon-server/files/Makefile7
2 files changed, 8 insertions, 1 deletions
diff --git a/net-mgmt/xymon-server/Makefile b/net-mgmt/xymon-server/Makefile
index 2ac8e08ba64f..5032f0ccfd61 100644
--- a/net-mgmt/xymon-server/Makefile
+++ b/net-mgmt/xymon-server/Makefile
@@ -29,7 +29,7 @@ XYMONUSER?= xymon
XYMONHOSTNAME?= xymon.example.com
XYMONHOSTIP?= 127.0.0.1
-USES= cpe gmake shebangfix ssl
+USES= compiler:c11 cpe gmake shebangfix ssl
SHEBANG_FILES= ${WRKSRC}/xymond/xymonreports.sh.DIST ${WRKSRC}/build/upgrade430.sh
MAKE_JOBS_UNSAFE= yes
CONFIGURE_ENV= MAKE=gmake
diff --git a/net-mgmt/xymon-server/files/Makefile b/net-mgmt/xymon-server/files/Makefile
index 86c0428a3529..7de4abe9114b 100644
--- a/net-mgmt/xymon-server/files/Makefile
+++ b/net-mgmt/xymon-server/files/Makefile
@@ -60,9 +60,14 @@ DORRD = yes
#
# OpenSSL settings
SSLFLAGS = -DHAVE_OPENSSL
+
+ifneq (${OPENSSLLIB},/usr/lib)
SSLINCDIR = -I${OPENSSLINC}
SSLLIBS = -L${OPENSSLLIB} -lssl -lcrypto
RPATHVAL += ${OPENSSLLIB}
+else
+SSLLIBS = -lssl -lcrypto
+endif
DOSSL = yes
#
ifdef WITH_LDAP
@@ -70,7 +75,9 @@ ifdef WITH_LDAP
LDAPFLAGS = -DXYMON_LDAP -DXYMON_LDAP_USESTARTTLS -DHAVE_LDAP
LDAPINCDIR = -I${PREFIX}/include
LDAPLIBS = -L${PREFIX}/lib -lldap -llber
+ifneq (${OPENSSLLIB},/usr/lib)
RPATHVAL += ${PREFIX}/lib
+endif
RPATHVAL += /usr/local/lib
DOLDAP = yes
endif