aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-11 07:19:26 +0800
committerJohn Marino <marino@FreeBSD.org>2016-09-11 07:19:26 +0800
commit5ed02ebc5a026ae97d1b03b2d602cde7b2a429e4 (patch)
treef0b7352a27522132d7091098f36bd49b0223479f /net-mgmt
parent413583fcc11ac16530c81d52e83c88e806f826e1 (diff)
downloadfreebsd-ports-gnome-5ed02ebc5a026ae97d1b03b2d602cde7b2a429e4.tar.gz
freebsd-ports-gnome-5ed02ebc5a026ae97d1b03b2d602cde7b2a429e4.tar.zst
freebsd-ports-gnome-5ed02ebc5a026ae97d1b03b2d602cde7b2a429e4.zip
net-mgmt/ndpmon: USES+=SSL and port options overhaul
The py4suite option probably didn't work even before the py4suite dependency was removed from the tree 2 years ago. The MACRESOLV option fetches during the build which is illegal and maybe is hitting a bad URL because it freezes as well. The py4suite has been removed completed and the MACRESOL option has been marked broken. This is after I rearranged the port to make them even work as intended. I cleaned up the port a lot after documenting the SSL requirement with USES=ssl. Approved by: just-fit-it and SSL blankets
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ndpmon/Makefile55
-rw-r--r--net-mgmt/ndpmon/pkg-plist1
2 files changed, 20 insertions, 36 deletions
diff --git a/net-mgmt/ndpmon/Makefile b/net-mgmt/ndpmon/Makefile
index b1b489072c18..0335ce8da3cd 100644
--- a/net-mgmt/ndpmon/Makefile
+++ b/net-mgmt/ndpmon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ndpmon
PORTVERSION= 1.4.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-1.4/
@@ -13,23 +13,7 @@ COMMENT= On-link icmpv6 message monitoring and reporting daemon
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= PY4SUITE MACRESOLV
-OPTIONS_DEFAULT=
-
-PY4SUITE_DESC= Depend on py-4suite-xml (for generating HTML)
-MACRESOLV_DESC= Enable MAC Manufacturer Resolution (use p5-libwww)
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPY4SUITE}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Ft/Xml/Domlette.py:textproc/py-4suite-xml
-USES+= python
-PLIST_SUB+= PY=""
-.else
-PLIST_SUB+= PY="@comment "
-.endif
-
-USES= perl5 shebangfix tar:tgz
+USES= perl5 shebangfix ssl tar:tgz
SHEBANG_FILES= demopipeprogram.pl.sample
USE_PERL5= run
USE_GNOME= libxml2
@@ -41,15 +25,20 @@ CONFIGURE_ARGS= --with-var-datadir=${PREFIX}/var --with-confdir=${ETCDIR} \
--with-libxml2=${LOCALBASE} --cache-file=/dev/null
PORTDOCS= INSTALL README
+CUSTOMMSG= ${WRKDIR}/custom-message
+PKGMESSAGE= ${CUSTOMMSG}
-.if ${PORT_OPTIONS:MMACRESOLV}
-CONFIGURE_ARGS+=--enable-mac-resolv
-BUILD_DEPENDS+= p5-libwww>=6.05:www/p5-libwww
-RUN_DEPENDS+= p5-libwww>=6.05:www/p5-libwww
-PLIST_SUB+= MACRESOLV=""
-.else
-PLIST_SUB+= MACRESOLV="@comment "
-.endif
+OPTIONS_DEFINE= DOCS MACRESOLV
+OPTIONS_DEFAULT=
+OPTIONS_SUB= yes
+
+MACRESOLV_DESC= Enable MAC Manufacturer Resolution
+MACRESOLV_CONFIGURE_ENABLE= mac-resolv
+MACRESOLV_BUILD_DEPENDS= p5-libwww>=6.05:www/p5-libwww
+MACRESOLV_RUN_DEPENDS= p5-libwww>=6.05:www/p5-libwww
+MACRESOLV_BROKEN= MACRESOLV option tries to fetch during build
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
@@ -60,6 +49,10 @@ post-patch:
${WRKSRC}/config_ndpmon.xml.in \
${WRKSRC}/config_ndpmon.xml
(cd ${WRKSRC}; ${MAKE} clean)
+ ${TOUCH} ${CUSTOMMSG}
+.if ${PORT_OPTIONS:MMACRESOLV}
+ ${CAT} ${.CURDIR}/pkg-message.MACRESOLV > ${CUSTOMMSG}
+.endif
do-install:
${INSTALL_MAN} ${WRKSRC}/ndpmon.8 ${STAGEDIR}${PREFIX}/man/man8
@@ -68,28 +61,20 @@ do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.dtd ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/demopipeprogram.pl.sample ${STAGEDIR}${DATADIR}
-.if ${PORT_OPTIONS:MPY4SUITE}
- ${INSTALL_SCRIPT} ${WRKSRC}/create_html_table.py ${STAGEDIR}${DATADIR}
-.endif
.if ${PORT_OPTIONS:MMACRESOLV}
${MKDIR} ${STAGEDIR}${DATADIR}/plugins/mac_resolv
${INSTALL_SCRIPT} ${WRKSRC}/plugins/mac_resolv/make-manuf ${STAGEDIR}${DATADIR}/plugins/mac_resolv
${INSTALL_DATA} ${WRKSRC}/plugins/mac_resolv/*.tmpl ${STAGEDIR}${DATADIR}/plugins/mac_resolv
${INSTALL_DATA} ${WRKSRC}/plugins/mac_resolv/manuf ${STAGEDIR}${DATADIR}/plugins/mac_resolv
.endif
-
${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/config_ndpmon.xml ${STAGEDIR}${ETCDIR}/config_ndpmon.xml-dist
${MKDIR} ${STAGEDIR}${PREFIX}/var/ndpmon
${INSTALL_DATA} ${WRKSRC}/neighbor_list.xml ${STAGEDIR}${PREFIX}/var/ndpmon/neighbor_list.xml
-.if ${PORT_OPTIONS:MDOCS}
+do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MMACRESOLV}
- @${CAT} ${PKGMESSAGE}.MACRESOLV
-.endif
.include <bsd.port.mk>
diff --git a/net-mgmt/ndpmon/pkg-plist b/net-mgmt/ndpmon/pkg-plist
index 1aab6c85ea54..7ff37514843e 100644
--- a/net-mgmt/ndpmon/pkg-plist
+++ b/net-mgmt/ndpmon/pkg-plist
@@ -4,7 +4,6 @@ man/man8/ndpmon.8.gz
%%DATADIR%%/config_ndpmon.dtd
%%DATADIR%%/demopipeprogram.pl.sample
%%DATADIR%%/neighbor_list.dtd
-%%PY%%%%DATADIR%%/create_html_table.py
%%MACRESOLV%%%%DATADIR%%/plugins/mac_resolv/make-manuf
%%MACRESOLV%%%%DATADIR%%/plugins/mac_resolv/manuf.tmpl
%%MACRESOLV%%%%DATADIR%%/plugins/mac_resolv/wka.tmpl