aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-02 06:51:08 +0800
committerpav <pav@FreeBSD.org>2006-04-02 06:51:08 +0800
commit66374bcf26270cd276cc959296ce33fbda3b1997 (patch)
treede67176b630e0f0ba9a75bc4e4e77d71d32ace7b /net-mgmt
parenta823ae7f5be239439f6c69be172a8c033a78531c (diff)
downloadfreebsd-ports-gnome-66374bcf26270cd276cc959296ce33fbda3b1997.tar.gz
freebsd-ports-gnome-66374bcf26270cd276cc959296ce33fbda3b1997.tar.zst
freebsd-ports-gnome-66374bcf26270cd276cc959296ce33fbda3b1997.zip
- Make ARPDIR configurable
PR: ports/92763 Submitted by: Eugene Grosbein <eugen@kuzbass.ru>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/arpwatch/Makefile4
-rw-r--r--net-mgmt/arpwatch/files/patch-ab19
2 files changed, 18 insertions, 5 deletions
diff --git a/net-mgmt/arpwatch/Makefile b/net-mgmt/arpwatch/Makefile
index 6af570b3fa77..29466e93de93 100644
--- a/net-mgmt/arpwatch/Makefile
+++ b/net-mgmt/arpwatch/Makefile
@@ -24,6 +24,10 @@ MAN8= arpwatch.8 arpsnmp.8
USE_RC_SUBR= arpwatch.sh
+.ifdef ARPDIR
+MAKE_ARGS= ARPDIR=${ARPDIR}
+.endif
+
post-install:
if [ ! -d ${PREFIX}/arpwatch ]; then \
${MKDIR} ${PREFIX}/arpwatch; \
diff --git a/net-mgmt/arpwatch/files/patch-ab b/net-mgmt/arpwatch/files/patch-ab
index 76cbc814dfaf..4928d0c9586f 100644
--- a/net-mgmt/arpwatch/files/patch-ab
+++ b/net-mgmt/arpwatch/files/patch-ab
@@ -1,7 +1,16 @@
---- Makefile.in.orig Wed Jul 29 06:16:45 1998
-+++ Makefile.in Fri Aug 21 10:57:51 1998
-@@ -44,7 +44,7 @@
- CC = @CC@
+--- Makefile.in.orig Thu Jun 15 08:39:55 2000
++++ Makefile.in Fri Feb 3 17:12:51 2006
+@@ -31,7 +31,7 @@
+ # Pathname of directory to install the man page
+ MANDEST = @mandir@
+ # Pathname of directory to install database file
+-ARPDIR = $(prefix)/arpwatch
++ARPDIR ?= $(prefix)/arpwatch
+
+ # VPATH
+ srcdir = @srcdir@
+@@ -45,7 +45,7 @@
+ PROG = arpwatch
CCOPT = @V_CCOPT@
INCLS = -I. @V_INCLS@
-DEFS = -DDEBUG @DEFS@ -DARPDIR=\"$(ARPDIR)\" -DPATH_SENDMAIL=\"$(SENDMAIL)\"
@@ -9,7 +18,7 @@
# Standard CFLAGS
CFLAGS = $(CCOPT) $(DEFS) $(INCLS)
-@@ -109,8 +109,8 @@
+@@ -110,8 +110,8 @@
$(CC) $(CFLAGS) -o $@ zap.o intoa.o -lutil
install: force