aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2013-05-30 19:55:31 +0800
committerzi <zi@FreeBSD.org>2013-05-30 19:55:31 +0800
commit6ce5ea4d4e3f23fefebf2e9568c7b2816402a620 (patch)
tree1684ecb01dd4248fc400e3c37266354cbc6a8e39 /net-mgmt
parent24aac707b172ae1516efec698e0149b659f58f10 (diff)
downloadfreebsd-ports-gnome-6ce5ea4d4e3f23fefebf2e9568c7b2816402a620.tar.gz
freebsd-ports-gnome-6ce5ea4d4e3f23fefebf2e9568c7b2816402a620.tar.zst
freebsd-ports-gnome-6ce5ea4d4e3f23fefebf2e9568c7b2816402a620.zip
- Fix kvm_read() issue
- Bump PORTREVISION PR: ports/177761 Submitted by: sbruno@
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/net-snmp/files/patch-agent__auto_nlist.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index a929d730090a..f50671d7bcb1 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= snmp
PORTVERSION= 5.7.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
diff --git a/net-mgmt/net-snmp/files/patch-agent__auto_nlist.c b/net-mgmt/net-snmp/files/patch-agent__auto_nlist.c
new file mode 100644
index 000000000000..5712336b3602
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent__auto_nlist.c
@@ -0,0 +1,10 @@
+--- ./agent/auto_nlist.c.orig 2012-10-09 18:28:58.000000000 -0400
++++ ./agent/auto_nlist.c 2013-04-10 14:26:21.000000000 -0400
+@@ -56,6 +56,7 @@
+ static char *n_name = NULL;
+ #endif
+ *ptr = (struct autonlist *) malloc(sizeof(struct autonlist));
++ bzero(*ptr, sizeof(struct autonlist));
+ it = *ptr;
+ it->left = 0;
+ it->right = 0;