aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-12-02 00:02:07 +0800
committerpav <pav@FreeBSD.org>2006-12-02 00:02:07 +0800
commit73b010a5e77251de842273fc5529da75d02b9231 (patch)
tree658e1b72a37ba0e24f2968dbc1eed5b26c19c81f /net-mgmt
parent34c0f6cb3e66ac7ce27c163ac2a9f1460561183d (diff)
downloadfreebsd-ports-gnome-73b010a5e77251de842273fc5529da75d02b9231.tar.gz
freebsd-ports-gnome-73b010a5e77251de842273fc5529da75d02b9231.tar.zst
freebsd-ports-gnome-73b010a5e77251de842273fc5529da75d02b9231.zip
* Argus is a system and network monitoring application.
* It will monitor nearly anything you ask it to monitor (TCP + UDP applications, IP connectivity, SNMP OIDS, Programs, Databases, etc). * It presents a nice clean, easy to view web interface that will keep both the managers happy (Red Bad. Green Good.) and the techs happy ("Ah! that's what the problem is"). * It can send alerts numerous ways (such as via pager) and can automatically escalate if someone falls asleep. WWW: http://argus.tcp4me.com/ PR: ports/105837 Submitted by: Brock Williams <brock@gringo.cotcomsol.com>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/argus-monitor/Makefile47
-rw-r--r--net-mgmt/argus-monitor/distinfo3
-rw-r--r--net-mgmt/argus-monitor/files/argusd.in24
-rw-r--r--net-mgmt/argus-monitor/pkg-descr11
-rw-r--r--net-mgmt/argus-monitor/pkg-plist99
6 files changed, 185 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index b6df22fd2d02..87affc718382 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -16,6 +16,7 @@
SUBDIR += apan
SUBDIR += argus
SUBDIR += argus-clients
+ SUBDIR += argus-monitor
SUBDIR += arpalert
SUBDIR += arpscan
SUBDIR += arpwatch
diff --git a/net-mgmt/argus-monitor/Makefile b/net-mgmt/argus-monitor/Makefile
new file mode 100644
index 000000000000..9cc3257d6489
--- /dev/null
+++ b/net-mgmt/argus-monitor/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: argus-monitor
+# Date created: 18 November 2006
+# Whom: brock@cotcomsol.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= argus-monitor
+PORTVERSION= 20060722
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.tcp4me.com/code/argus-archive/
+DISTNAME= argus-dev-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= brock@cotcomsol.com
+COMMENT= Argus - The All Seeing System and Network Monitoring Software
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_PERL5= yes
+USE_RC_SUBR= argusd
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= Configure
+CONFIGURE_ARGS= --bin_dir=${PREFIX}/bin --sbin_dir=${PREFIX}/sbin \
+ --lib_dir=${PREFIX}/lib/argus-monitor --data_dir=${PREFIX}/etc/argus-monitor
+
+OPTIONS= QPAGE "qpage support" Off \
+ FPING "fping support" Off \
+ GD "GD graphics support" On
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_QPAGE)
+RUN_DEPENDS+= qpage:${PORTSDIR}/comms/qpage
+BUILD_DEPENDS+= qpage:${PORTSDIR}/comms/qpage
+.endif
+
+.if defined(WITH_FPING)
+RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
+BUILD_DEPENDS+= fping:${PORTSDIR}/net/fping
+.endif
+
+.if !defined(WITHOUT_GD)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/argus-monitor/distinfo b/net-mgmt/argus-monitor/distinfo
new file mode 100644
index 000000000000..9be8c754f194
--- /dev/null
+++ b/net-mgmt/argus-monitor/distinfo
@@ -0,0 +1,3 @@
+MD5 (argus-dev-20060722.tgz) = 8118f8faebb5e54b7e76a842a0716a65
+SHA256 (argus-dev-20060722.tgz) = 9e380e1caa28da06489258952fefee74e92afa896c675013beea5510187c2ba1
+SIZE (argus-dev-20060722.tgz) = 306604
diff --git a/net-mgmt/argus-monitor/files/argusd.in b/net-mgmt/argus-monitor/files/argusd.in
new file mode 100644
index 000000000000..df9342cdc954
--- /dev/null
+++ b/net-mgmt/argus-monitor/files/argusd.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+# PROVIDE: argusd
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# argusd_enable (bool): Set to NO by default.
+# Set it to YES to enable argusd
+#
+
+. %%RC_SUBR%%
+
+name="argusd"
+rcvar=${name}_enable
+
+command=%%PREFIX%%/sbin/${name}
+pidfile=/var/run/${name}.pid
+
+load_rc_config $name
+
+: ${argusd_enable="NO"}
+
+run_rc_command "$1"
diff --git a/net-mgmt/argus-monitor/pkg-descr b/net-mgmt/argus-monitor/pkg-descr
new file mode 100644
index 000000000000..767f4f2054e4
--- /dev/null
+++ b/net-mgmt/argus-monitor/pkg-descr
@@ -0,0 +1,11 @@
+* Argus is a system and network monitoring application.
+* It will monitor nearly anything you ask it to monitor (TCP + UDP
+ applications, IP connectivity, SNMP OIDS, Programs, Databases,
+ etc).
+* It presents a nice clean, easy to view web interface that will keep both the
+ managers happy (Red Bad. Green Good.) and the techs happy ("Ah! that's what
+ the problem is").
+* It can send alerts numerous ways (such as via pager) and can automatically
+ escalate if someone falls asleep.
+
+WWW: http://argus.tcp4me.com/
diff --git a/net-mgmt/argus-monitor/pkg-plist b/net-mgmt/argus-monitor/pkg-plist
new file mode 100644
index 000000000000..b1b678b817a0
--- /dev/null
+++ b/net-mgmt/argus-monitor/pkg-plist
@@ -0,0 +1,99 @@
+bin/argus-config
+etc/argus-monitor/config.example
+etc/argus-monitor/locale/de_DE
+etc/argus-monitor/locale/el_gr
+etc/argus-monitor/locale/eubonics
+etc/argus-monitor/locale/fr_fr
+etc/argus-monitor/locale/piglatin
+etc/argus-monitor/locale/sp_ar
+etc/argus-monitor/locale/template
+etc/argus-monitor/log
+etc/argus-monitor/notno
+etc/argus-monitor/users.example
+lib/argus-monitor/Alias.pm
+lib/argus-monitor/Argus/Agent.pm
+lib/argus-monitor/Argus/Asterisk.pm
+lib/argus-monitor/Argus/BER.pm
+lib/argus-monitor/Argus/Ctl.pm
+lib/argus-monitor/Argus/Encode.pm
+lib/argus-monitor/Argus/IP.pm
+lib/argus-monitor/Argus/RPC.pm
+lib/argus-monitor/Argus/RPC/TCP.pm
+lib/argus-monitor/Argus/RPC/UDP.pm
+lib/argus-monitor/Argus/SIP.pm
+lib/argus-monitor/Argus/SIP/TCP.pm
+lib/argus-monitor/Argus/SIP/UDP.pm
+lib/argus-monitor/Artistic
+lib/argus-monitor/BaseIO.pm
+lib/argus-monitor/Chart/Strip.pm
+lib/argus-monitor/Commands.pm
+lib/argus-monitor/Conf.pm
+lib/argus-monitor/Configable.pm
+lib/argus-monitor/Control.pm
+lib/argus-monitor/Cron.pm
+lib/argus-monitor/DNS.pm
+lib/argus-monitor/DNS/TCP.pm
+lib/argus-monitor/DNS/UDP.pm
+lib/argus-monitor/DataBase.pm
+lib/argus-monitor/Doc.pm
+lib/argus-monitor/Error.pm
+lib/argus-monitor/Graph.pm
+lib/argus-monitor/GraphData.pm
+lib/argus-monitor/Group.pm
+lib/argus-monitor/LICENSE
+lib/argus-monitor/LOCATION
+lib/argus-monitor/MonEl.pm
+lib/argus-monitor/NotMe.pm
+lib/argus-monitor/Notify.pm
+lib/argus-monitor/NullConf.pm
+lib/argus-monitor/NullCtl.pm
+lib/argus-monitor/Override.pm
+lib/argus-monitor/Ping.pm
+lib/argus-monitor/Prog.pm
+lib/argus-monitor/README
+lib/argus-monitor/Resolv.pm
+lib/argus-monitor/SNMP.pm
+lib/argus-monitor/SSL.pm
+lib/argus-monitor/Self.pm
+lib/argus-monitor/Server.pm
+lib/argus-monitor/Service.pm
+lib/argus-monitor/Stats.pm
+lib/argus-monitor/TCP.pm
+lib/argus-monitor/TestPort.pm
+lib/argus-monitor/UDP.pm
+lib/argus-monitor/UserCron.pm
+lib/argus-monitor/Web.pm
+lib/argus-monitor/conf.pl
+lib/argus-monitor/graphd
+lib/argus-monitor/localization.pl
+lib/argus-monitor/misc.pl
+lib/argus-monitor/picasso
+lib/argus-monitor/web_about.pl
+lib/argus-monitor/web_acl.pl
+lib/argus-monitor/web_auth_file.pl
+lib/argus-monitor/web_graph.pl
+lib/argus-monitor/web_login.pl
+lib/argus-monitor/web_misc.pl
+lib/argus-monitor/web_notify.pl
+lib/argus-monitor/web_override.pl
+lib/argus-monitor/web_page.pl
+lib/argus-monitor/web_utils.pl
+sbin/argus-agent
+sbin/arguscgi
+sbin/argusctl
+sbin/argusd
+sbin/argusvxml
+@dirrm lib/argus-monitor/DNS
+@dirrm lib/argus-monitor/Chart
+@dirrm lib/argus-monitor/Argus/SIP
+@dirrm lib/argus-monitor/Argus/RPC
+@dirrm lib/argus-monitor/Argus
+@dirrm lib/argus-monitor
+@dirrm etc/argus-monitor/stats
+@dirrm etc/argus-monitor/perl
+@dirrm etc/argus-monitor/notify
+@dirrm etc/argus-monitor/locale
+@dirrm etc/argus-monitor/html
+@dirrm etc/argus-monitor/gdata
+@dirrm etc/argus-monitor/gcache
+@dirrm etc/argus-monitor