aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormmokhi <mmokhi@FreeBSD.org>2017-11-08 20:18:34 +0800
committermmokhi <mmokhi@FreeBSD.org>2017-11-08 20:18:34 +0800
commit82df0b1fb5024ddf23b2b2e957ca4c4883b08187 (patch)
tree332fbc3c113ff95450fa1f526be2d0bf03e6295c /net-mgmt
parentc478516492d2c9d8fcd25d07083dc75107b308b6 (diff)
downloadfreebsd-ports-gnome-82df0b1fb5024ddf23b2b2e957ca4c4883b08187.tar.gz
freebsd-ports-gnome-82df0b1fb5024ddf23b2b2e957ca4c4883b08187.tar.zst
freebsd-ports-gnome-82df0b1fb5024ddf23b2b2e957ca4c4883b08187.zip
net-mgmt/netdata: Add option for freeipmi support
PR: 223460 Reported by: Bryce Edwards <bryce@bryce.net> Reviewed by: mat (mentor) Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D12975
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/netdata/Makefile11
-rw-r--r--net-mgmt/netdata/pkg-plist1
2 files changed, 10 insertions, 2 deletions
diff --git a/net-mgmt/netdata/Makefile b/net-mgmt/netdata/Makefile
index ddc4b2482cff..a49fab61f534 100644
--- a/net-mgmt/netdata/Makefile
+++ b/net-mgmt/netdata/Makefile
@@ -4,6 +4,7 @@
PORTNAME= netdata
PORTVERSION= 1.8.0
DISTVERSIONPREFIX=v
+PORTREVISION= 1
CATEGORIES= net-mgmt
MAINTAINER= mmokhi@FreeBSD.org
@@ -14,6 +15,8 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/include/uuid/uuid.h:misc/e2fsprogs-libuuid
LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid
+USES= autoreconf pathfix pkgconfig:both python shebangfix
+
USE_GITHUB= yes
GH_ACCOUNT= firehol
@@ -21,9 +24,7 @@ NETDATA_CACHE= /var/cache/${PORTNAME}
NETDATA_LOG= /var/log/${PORTNAME}
NETDATA_PERST= /var/db/${PORTNAME}
-USES= autoreconf pathfix pkgconfig:both python shebangfix
USE_LDCONFIG= yes
-
GNU_CONFIGURE= yes
CPPFLAGS+= -D_WANT_VMMETER -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
@@ -43,6 +44,12 @@ SUB_FILES= ${PORTNAME}.conf.sample
USERS= netdata
GROUPS= netdata
+OPTIONS_DEFINE= FREEIPMI
+OPTIONS_SUB= YES
+FREEIPMI_DESC= Enable support for freeipmi
+
+FREEIPMI_LIB_DEPENDS= libfreeipmi.so:sysutils/freeipmi
+
post-patch:
@${REINPLACE_CMD} -e 's|%%NETDATA_CACHE%%|${NETDATA_CACHE}|g' \
${PATCH_WRKSRC}/configure.ac
diff --git a/net-mgmt/netdata/pkg-plist b/net-mgmt/netdata/pkg-plist
index dd7f161bb892..f76c85ae6ceb 100644
--- a/net-mgmt/netdata/pkg-plist
+++ b/net-mgmt/netdata/pkg-plist
@@ -156,6 +156,7 @@ libexec/netdata/plugins.d/cgroup-name.sh
libexec/netdata/plugins.d/charts.d.dryrun-helper.sh
libexec/netdata/plugins.d/charts.d.plugin
libexec/netdata/plugins.d/fping.plugin
+%%FREEIPMI%%libexec/netdata/plugins.d/freeipmi.plugin
libexec/netdata/plugins.d/loopsleepms.sh.inc
libexec/netdata/plugins.d/node.d.plugin
libexec/netdata/plugins.d/python.d.plugin