aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-04-16 18:29:26 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-04-16 18:29:50 +0800
commit8537097a722fe9e360bfefce98c8d26c7c07f0ee (patch)
tree5f06ac6358343708269f12bef97ef49d00184b36 /net-mgmt
parentf1ea4a0bfd36e9f39950b490c344362402ca83b9 (diff)
downloadfreebsd-ports-gnome-8537097a722fe9e360bfefce98c8d26c7c07f0ee.tar.gz
freebsd-ports-gnome-8537097a722fe9e360bfefce98c8d26c7c07f0ee.tar.zst
freebsd-ports-gnome-8537097a722fe9e360bfefce98c8d26c7c07f0ee.zip
- Convert VictoriaMetrics ports to master-slave relationship which
allows to remove lots of duplicated lines between the Makefiles - Remove not actually needed, albeit harmless patch while I'm here
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/victoria-metrics/Makefile20
-rw-r--r--net-mgmt/victoria-metrics/files/patch-Makefile17
-rw-r--r--net-mgmt/victoria-metrics/files/vmagent.in (renamed from net-mgmt/vmutils/files/vmagent.in)0
-rw-r--r--net-mgmt/vmutils/Makefile37
4 files changed, 17 insertions, 57 deletions
diff --git a/net-mgmt/victoria-metrics/Makefile b/net-mgmt/victoria-metrics/Makefile
index c954360b5ef4..86846536a124 100644
--- a/net-mgmt/victoria-metrics/Makefile
+++ b/net-mgmt/victoria-metrics/Makefile
@@ -1,18 +1,18 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
-PORTNAME= victoria-metrics
+PORTNAME?= victoria-metrics
DISTVERSIONPREFIX= v
DISTVERSION= 1.58.0
CATEGORIES= net-mgmt
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Fast, cost-effective, and scalable time series database
+COMMENT?= Fast, cost-effective, and scalable time series database
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= gmake go:modules,no_targets
-USE_RC_SUBR= ${PORTNAME}
+USE_RC_SUBR?= ${PORTNAME}
MAKE_ENV= PKG_TAG=${DISTVERSIONPREFIX}${DISTVERSION} \
BUILDINFO_TAG=edd1590 GOOS=${OPSYS:tl}
ALL_TARGET= ${PORTNAME}-pure
@@ -21,11 +21,9 @@ USE_GITHUB= yes
GH_ACCOUNT= VictoriaMetrics
GH_PROJECT= VictoriaMetrics
-.include "${.CURDIR}/Makefile.deps"
-
-USERS= ${PORTNAME}
-GROUPS= ${PORTNAME}
-VICTORIA_DATA?= /var/db/${PORTNAME}
+USERS= victoria-metrics
+GROUPS= victoria-metrics
+VICTORIA_DATA?= /var/db/victoria-metrics
SUB_LIST+= VICTORIA_DATA=${VICTORIA_DATA} \
VICTORIA_USER=${USERS}
@@ -36,14 +34,20 @@ PLIST_SUB+= VICTORIA_DATA=${VICTORIA_DATA} \
OPTIONS_DEFINE= DOCS
+.if !target(do-install)
do-install:
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/bin/${PORTNAME}-pure \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}
@${MKDIR} ${STAGEDIR}${VICTORIA_DATA}
+.endif
+.if !target(do-install-DOCS-on)
do-install-DOCS-on:
@cd ${INSTALL_WRKSRC}/docs && ${RM} robots.txt vm*
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${INSTALL_WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
+.endif
.include <bsd.port.mk>
+
+.include "${MASTERDIR}/Makefile.deps"
diff --git a/net-mgmt/victoria-metrics/files/patch-Makefile b/net-mgmt/victoria-metrics/files/patch-Makefile
deleted file mode 100644
index 901e7a11c695..000000000000
--- a/net-mgmt/victoria-metrics/files/patch-Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile.orig 2021-04-08 06:35:50 UTC
-+++ Makefile
-@@ -1,5 +1,6 @@
- PKG_PREFIX := github.com/VictoriaMetrics/VictoriaMetrics
-
-+ifneq (,$(wildcard .git))
- BUILDINFO_TAG ?= $(shell echo $$(git describe --long --all | tr '/' '-')$$( \
- git diff-index --quiet HEAD -- || echo '-dirty-'$$(git diff-index -u HEAD | openssl sha1 | cut -c 10-17)))
-
-@@ -7,6 +8,7 @@ PKG_TAG ?= $(shell git tag -l --points-at HEAD)
- ifeq ($(PKG_TAG),)
- PKG_TAG := $(BUILDINFO_TAG)
- endif
-+endif
-
- GO_BUILDINFO = -X '$(PKG_PREFIX)/lib/buildinfo.Version=$(APP_NAME)-$(shell date -u +'%Y%m%d-%H%M%S')-$(BUILDINFO_TAG)'
-
diff --git a/net-mgmt/vmutils/files/vmagent.in b/net-mgmt/victoria-metrics/files/vmagent.in
index b07a662486a9..b07a662486a9 100644
--- a/net-mgmt/vmutils/files/vmagent.in
+++ b/net-mgmt/victoria-metrics/files/vmagent.in
diff --git a/net-mgmt/vmutils/Makefile b/net-mgmt/vmutils/Makefile
index 754534b5f087..ee41121132de 100644
--- a/net-mgmt/vmutils/Makefile
+++ b/net-mgmt/vmutils/Makefile
@@ -1,41 +1,12 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= vmutils
-DISTVERSIONPREFIX= v
-DISTVERSION= 1.58.0
-CATEGORIES= net-mgmt
-DISTINFO_FILE= ${.CURDIR}/../victoria-metrics/distinfo
-
-MAINTAINER= danfe@FreeBSD.org
COMMENT= Ancillary utilities and agent for VictoriaMetrics
-LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-USES= gmake go:modules,no_targets
USE_RC_SUBR= vmagent
-MAKE_ENV= PKG_TAG=${DISTVERSIONPREFIX}${DISTVERSION} \
- BUILDINFO_TAG=edd1590 GOOS=${OPSYS:tl}
-ALL_TARGET= ${PORTNAME}-pure
-
-USE_GITHUB= yes
-GH_ACCOUNT= VictoriaMetrics
-GH_PROJECT= VictoriaMetrics
-
-.include "${.CURDIR}/../victoria-metrics/Makefile.deps"
-USERS= victoria-metrics
-GROUPS= victoria-metrics
-VICTORIA_DATA?= /var/db/victoria-metrics
-
-SUB_LIST+= VICTORIA_DATA=${VICTORIA_DATA} \
- VICTORIA_USER=${USERS}
-
-PLIST_SUB+= VICTORIA_DATA=${VICTORIA_DATA} \
- VICTORIA_GROUP=${GROUPS} \
- VICTORIA_USER=${USERS}
-
-OPTIONS_DEFINE= DOCS
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
do-install:
.for p in agent alert auth backup ctl restore
@@ -47,4 +18,6 @@ do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${INSTALL_WRKSRC}/docs/vm* ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+MASTERDIR= ${.CURDIR}/../victoria-metrics
+
+.include "${MASTERDIR}/Makefile"