aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-02-19 17:01:38 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-02-19 17:01:38 +0800
commit8879ec105cc381d9cced50121520474882d1360c (patch)
tree71ceee7c571f3dd2f7b4f45d5ef9b65151badf54 /net-mgmt
parentb94d288194343ceeeb617aff65e1a8f54ea00521 (diff)
downloadfreebsd-ports-gnome-8879ec105cc381d9cced50121520474882d1360c.tar.gz
freebsd-ports-gnome-8879ec105cc381d9cced50121520474882d1360c.tar.zst
freebsd-ports-gnome-8879ec105cc381d9cced50121520474882d1360c.zip
- Switch to options helpers
- Remove redundant SUB_LIST and unneeded <bsd.port.options.mk> inclusion
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/mk-livestatus/Makefile24
-rw-r--r--net-mgmt/mk-livestatus/pkg-descr1
2 files changed, 11 insertions, 14 deletions
diff --git a/net-mgmt/mk-livestatus/Makefile b/net-mgmt/mk-livestatus/Makefile
index d34eb1a2e35a..a207313250fa 100644
--- a/net-mgmt/mk-livestatus/Makefile
+++ b/net-mgmt/mk-livestatus/Makefile
@@ -15,21 +15,9 @@ LICENSE= GPLv2
USES= compiler:c++11-lib gmake
GNU_CONFIGURE= yes
-OPTIONS_SINGLE= NAGIOS
-OPTIONS_SINGLE_NAGIOS= NAGIOS3 NAGIOS4
-OPTIONS_DEFAULT= NAGIOS3
-
-NAGIOS3_DESC= build for nagios-3.x
-NAGIOS4_DESC= build for nagios-4.x
-
-NAGIOS4_CONFIGURE_ON= --with-nagios4
-
-.include <bsd.port.options.mk>
-
PLIST_FILES= lib/mk-livestatus/unixcat \
lib/mk-livestatus/livestatus.o
SUB_FILES= pkg-message
-SUB_LIST= PREFIX=${PREFIX}
PORTEXAMPLES= *
EXAMPLE_FILES= api/python/example_multisite.py \
@@ -41,6 +29,16 @@ EXAMPLE_FILES= api/python/example_multisite.py \
# parameter "command_file" from nagios.cfg
COMMAND_FILE?= /var/spool/nagios/rw/live
+OPTIONS_DEFINE= EXAMPLES
+OPTIONS_SINGLE= NAGIOS
+OPTIONS_SINGLE_NAGIOS= NAGIOS3 NAGIOS4
+OPTIONS_DEFAULT= NAGIOS3
+
+NAGIOS3_DESC= build for nagios-3.x
+NAGIOS4_DESC= build for nagios-4.x
+
+NAGIOS4_CONFIGURE_ON= --with-nagios4
+
# perl api is really outdated, do not install!
# Actual version can be found on CPAN
# http://search.cpan.org/~nierlein/Monitoring-Livestatus/
@@ -55,7 +53,7 @@ post-patch:
@${SED} -i '' -e 's|/usr/local/nagios/var/rw/live|${COMMAND_FILE}|' \
${WRKSRC}/src/livestatus.h
-post-install:
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
( cd ${WRKSRC} && ${COPYTREE_SHARE} api\* ${STAGEDIR}${EXAMPLESDIR}/ )
diff --git a/net-mgmt/mk-livestatus/pkg-descr b/net-mgmt/mk-livestatus/pkg-descr
index eb098f8a7f12..a895f1ad7347 100644
--- a/net-mgmt/mk-livestatus/pkg-descr
+++ b/net-mgmt/mk-livestatus/pkg-descr
@@ -9,5 +9,4 @@ actively write out data e.g. to the disk. Instead, it opens a socket for
external applications to connect to and fetch the current status
information from Nagios.
-
WWW: http://mathias-kettner.de/checkmk_livestatus.html