aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1996-12-01 09:23:27 +0800
committerobrien <obrien@FreeBSD.org>1996-12-01 09:23:27 +0800
commit8efcf00b2e5836ef32baf7637535242a296a8c38 (patch)
tree6d6249f3f223daa0ca98c880b13d349c86a0942c /net-mgmt
parent238c02c9d9fee5aee4bb8357a9efa521b3d1364e (diff)
downloadfreebsd-ports-gnome-8efcf00b2e5836ef32baf7637535242a296a8c38.tar.gz
freebsd-ports-gnome-8efcf00b2e5836ef32baf7637535242a296a8c38.tar.zst
freebsd-ports-gnome-8efcf00b2e5836ef32baf7637535242a296a8c38.zip
General Makefile cleanup
Add MAINATERS mkdir -p ==> ${MKDIR} cp ==> ${CP} install ==> ${INSTALL}/${INSTALL_*} etc...
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/scotty3/Makefile10
-rw-r--r--net-mgmt/wide-dhcp/Makefile18
2 files changed, 15 insertions, 13 deletions
diff --git a/net-mgmt/scotty3/Makefile b/net-mgmt/scotty3/Makefile
index 3496328fd9d0..4a6c120eaa93 100644
--- a/net-mgmt/scotty3/Makefile
+++ b/net-mgmt/scotty3/Makefile
@@ -3,13 +3,15 @@
# Date created: 18 Februar 1995
# Whom: Gennady Sorokopud <gena@netvision.net.il>
#
-# $Id: Makefile,v 1.12 1996/10/10 14:54:36 erich Exp $
+# $Id: Makefile,v 1.13 1996/11/18 11:36:20 asami Exp $
#
DISTNAME= scotty-2.1.3
CATEGORIES= net
MASTER_SITES= ftp://ftp.ibr.cs.tu-bs.de/pub/local/tkined/
+MAINTAINER= gena@netvision.net.il
+
LIB_DEPENDS= tk41\\.1\\.:${PORTSDIR}/x11/tk41
GNU_CONFIGURE= yes
@@ -25,16 +27,16 @@ MANN= Tnm.n cmip.n dns.n gdmo.n http.n icmp.n ined.n job.n \
pre-install:
@cd ${WRKSRC};make sinstall
- @cp ${WRKSRC}/../tnm/ntping/ntping.8 ${WRKSRC}/../doc
+ @${CP} ${WRKSRC}/../tnm/ntping/ntping.8 ${WRKSRC}/../doc
@sed "s,@FREEBSD_VERSION@,$$(uname -m)-$$(uname)-$$(uname -r)," pkg/PLIST.in >/tmp/PLIST
.if defined(NOMANCOMPRESS)
@sed "s,@GZIP@,," /tmp/PLIST >pkg/PLIST
.else
@sed "s,@GZIP@,.gz," /tmp/PLIST >pkg/PLIST
.endif
- @rm /tmp/PLIST
+ @{RM} /tmp/PLIST
pre-clean:
- @rm -f pkg/PLIST
+ @{RM} -f pkg/PLIST
.include <bsd.port.mk>
diff --git a/net-mgmt/wide-dhcp/Makefile b/net-mgmt/wide-dhcp/Makefile
index 88225bbdfdca..9e5d627b66b0 100644
--- a/net-mgmt/wide-dhcp/Makefile
+++ b/net-mgmt/wide-dhcp/Makefile
@@ -3,7 +3,7 @@
# Date created: 21 November 1995
# Whom: Yoshiro MIHIRA <sanpei@yy.cs.keio.ac.jp>
#
-# $Id: Makefile,v 1.3 1996/05/30 08:54:17 asami Exp $
+# $Id: Makefile,v 1.4 1996/11/18 11:37:02 asami Exp $
#
DISTNAME= dhcp-1.3beta
@@ -20,19 +20,19 @@ MAKE_ENV= OSTYPE=`uname`
post-patch:
if [ ! -f ${WRKSRC}/server/tzfile.h ]; then \
- cp ${DISTDIR}/tzfile.h ${WRKSRC}/server/; \
+ ${CP} ${DISTDIR}/tzfile.h ${WRKSRC}/server/; \
fi
post-install:
@if [ ! -d ${PREFIX}/share/dhcp ]; then \
- mkdir -p ${PREFIX}/share/dhcp; \
+ ${MKDIR} ${PREFIX}/share/dhcp; \
fi
- @cp ${WRKSRC}/README ${PREFIX}/share/dhcp/
- @cp ${WRKSRC}/README.jis ${PREFIX}/share/dhcp/
- @cp ${WRKSRC}/db_sample/dhcpdb.pool ${PREFIX}/share/dhcp/dhcpdb.pool.sample
- @cp ${WRKSRC}/db_sample/dhcpdb.relay ${PREFIX}/share/dhcp/dhcpdb.relay.sample
- @cp ${WRKSRC}/db_sample/dhcpdb.server ${PREFIX}/share/dhcp/dhcpdb.server.sample
- @cp ${WRKSRC}/db_sample/intro.dhcp ${PREFIX}/share/dhcp/
+ @{CP} ${WRKSRC}/README ${PREFIX}/share/dhcp/
+ @{CP} ${WRKSRC}/README.jis ${PREFIX}/share/dhcp/
+ @{CP} ${WRKSRC}/db_sample/dhcpdb.pool ${PREFIX}/share/dhcp/dhcpdb.pool.sample
+ @{CP} ${WRKSRC}/db_sample/dhcpdb.relay ${PREFIX}/share/dhcp/dhcpdb.relay.sample
+ @{CP} ${WRKSRC}/db_sample/dhcpdb.server ${PREFIX}/share/dhcp/dhcpdb.server.sample
+ @{CP} ${WRKSRC}/db_sample/intro.dhcp ${PREFIX}/share/dhcp/
@if [ ! -c /dev/bpf1 ]; then \
echo "**********************************************************";\
echo "* W a r n i n g *";\