aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-07-30 22:22:00 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-07-30 22:22:00 +0800
commit9d57a35fecdf341899f2e54cbc2ef822eeeeec45 (patch)
tree5c83655b85d28a26adc898aa19acb89be392a506 /net-mgmt
parent9d2bd9834f568cbf35365025875eb5850ebd155b (diff)
downloadfreebsd-ports-gnome-9d57a35fecdf341899f2e54cbc2ef822eeeeec45.tar.gz
freebsd-ports-gnome-9d57a35fecdf341899f2e54cbc2ef822eeeeec45.tar.zst
freebsd-ports-gnome-9d57a35fecdf341899f2e54cbc2ef822eeeeec45.zip
- Fix shebangs
Approved by: portmgr blanket MFH: 2015Q3 (blanket)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/pandorafms_agent/Makefile3
-rw-r--r--net-mgmt/pandorafms_console/Makefile10
-rw-r--r--net-mgmt/pandorafms_server/Makefile23
-rw-r--r--net-mgmt/pandorafms_server/bsd.pandora.mk1
4 files changed, 35 insertions, 2 deletions
diff --git a/net-mgmt/pandorafms_agent/Makefile b/net-mgmt/pandorafms_agent/Makefile
index 2b3bf5e4bb31..09eb2965cd00 100644
--- a/net-mgmt/pandorafms_agent/Makefile
+++ b/net-mgmt/pandorafms_agent/Makefile
@@ -14,7 +14,8 @@ OPTIONS_DEFINE= DOCS TENTACLE_SERVER
OPTIONS_DEFAULT= DOCS TENTACLE_SERVER
TENTACLE_SERVER_DESC= Install tentalce_server
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= plugins/pandora_netusage
SUB_FILES= pkg-message
diff --git a/net-mgmt/pandorafms_console/Makefile b/net-mgmt/pandorafms_console/Makefile
index 2a4cbe89c797..25fbbe473c88 100644
--- a/net-mgmt/pandorafms_console/Makefile
+++ b/net-mgmt/pandorafms_console/Makefile
@@ -12,6 +12,16 @@ LICENSE_FILE= ${PANDORA_LICENSE_FILE}
RUN_DEPENDS= ${LOCALBASE}/bin/twopi:${PORTSDIR}/graphics/graphviz
+USES= shebangfix
+SHEBANG_FILES= include/languages/util-all \
+ include/languages/util-bzr-update \
+ include/languages/util-compile-mo \
+ include/languages/util-create-po \
+ include/languages/util-create-template \
+ include/languages/util-generate-tarball \
+ include/languages/util-update-po \
+ pandora_console_upgrade
+
OPTIONS_DEFINE= DOCS PGSQL
DOCS_DESC= Install AUTHORS and ChangeLog
PGSQL_DESC= Use PostgreSQL backend (experimental)
diff --git a/net-mgmt/pandorafms_server/Makefile b/net-mgmt/pandorafms_server/Makefile
index d11faee0c623..9751fcf4f0bc 100644
--- a/net-mgmt/pandorafms_server/Makefile
+++ b/net-mgmt/pandorafms_server/Makefile
@@ -37,7 +37,28 @@ PGSQL_DESC= Use PostgreSQL backend (experimental)
ORACLE_DESC= Use Oracle backend (experimental)
EXTRAS_DESC= Extra dependencies for util scripts
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= FreeBSD/pandora_server \
+ bin/pandora_server \
+ util/integrity_check \
+ util/pandora_backup.sh \
+ util/pandora_count.sh \
+ util/pandora_diagnostic.sh \
+ util/pandora_remote_agent.sh \
+ util/pandora_server \
+ util/pandora_watchdog.sh \
+ util/plugin/babel_plugin/babel_plugin.sh \
+ util/plugin/create_integria_incident.sh \
+ util/plugin/dns_plugin.sh \
+ util/plugin/integria_plugin/integria_plugin.sh \
+ util/plugin/mysql_plugin.sh \
+ util/plugin/packet_loss.sh \
+ util/plugin/ssh_pandoraplugin.sh \
+ util/plugin/udp_nmap_plugin.sh \
+ util/plugin/webcheck_plugin.sh \
+ util/snmptrap_gen.sh \
+ util/tentacle_serverd \
+ util/trap_rate.sh
USE_PERL5= build run
SUB_LIST+= PERL="${PERL}" DATADIR="${DATADIR}"
SUB_FILES= pkg-message
diff --git a/net-mgmt/pandorafms_server/bsd.pandora.mk b/net-mgmt/pandorafms_server/bsd.pandora.mk
index 1262cdda7013..ee34d43f46d2 100644
--- a/net-mgmt/pandorafms_server/bsd.pandora.mk
+++ b/net-mgmt/pandorafms_server/bsd.pandora.mk
@@ -13,6 +13,7 @@ PANDORA_INSTALLER= ${PORTNAME}_installer
PANDORA_INSTALLER_ARGS= --install
PORTVERSION= ${PANDORA_VERSION:C/SP/./}
+PORTREVISION= 1
MASTER_SITES?= SF/pandora/Pandora%20FMS%20${PANDORA_VERSION:C/(SP[0-9]*)/\/\1/}Final/Tarball
.if ${PORTNAME} == "pandora_agent"