aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-07-29 22:43:17 +0800
committermat <mat@FreeBSD.org>2014-07-29 22:43:17 +0800
commita283b36e6a7177866d718dfa2b40a5e33427d22a (patch)
treebfa26b5fa740e03cda735ba1f4022c69200fc143 /net-mgmt
parent32905e1a923e0b9a6979fe2e78bc1bbec0fc748d (diff)
downloadfreebsd-ports-gnome-a283b36e6a7177866d718dfa2b40a5e33427d22a.tar.gz
freebsd-ports-gnome-a283b36e6a7177866d718dfa2b40a5e33427d22a.tar.zst
freebsd-ports-gnome-a283b36e6a7177866d718dfa2b40a5e33427d22a.zip
Update to 2.0.
Changes: https://www.monitoring-plugins.org/news/release-2-0.html Sponsored by: Absolight
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/monitoring-plugins/Makefile19
-rw-r--r--net-mgmt/monitoring-plugins/distinfo4
-rw-r--r--net-mgmt/monitoring-plugins/files/patch-plugins-scripts__check_ircd.pl8
-rw-r--r--net-mgmt/monitoring-plugins/files/patch-plugins-scripts__check_ntp.pl19
-rw-r--r--net-mgmt/monitoring-plugins/files/patch-plugins__check_ssh.c8
5 files changed, 14 insertions, 44 deletions
diff --git a/net-mgmt/monitoring-plugins/Makefile b/net-mgmt/monitoring-plugins/Makefile
index 4cff99f915d4..e12011b1b350 100644
--- a/net-mgmt/monitoring-plugins/Makefile
+++ b/net-mgmt/monitoring-plugins/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= monitoring-plugins
-PORTVERSION= 1.5.99.20140721
-PORTREVISION= 1
+PORTVERSION= 2.0
CATEGORIES= net-mgmt
-MASTER_SITES= LOCAL/mat/${PORTNAME} GH GHC
-
+MASTER_SITES= https://www.monitoring-plugins.org/download/ LOCAL/mat/${PORTNAME}
MAINTAINER= mat@FreeBSD.org
COMMENT= Monitoring Plugins for Nagios
@@ -14,11 +12,6 @@ COMMENT= Monitoring Plugins for Nagios
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GITHUB= yes
-GH_ACCOUNT= monitoring-plugins
-GH_COMMIT= b5611ea
-GH_TAGNAME= ${GH_COMMIT}
-
CONFLICTS_INSTALL= nagios-plugins-*
USES= charsetfix gmake perl5 libtool
@@ -57,8 +50,6 @@ EXTRAOPTS_CONFIGURE_ENABLE= extra-opts
GNU_CONFIGURE= yes
-NAGIOSUSER?= nagios
-NAGIOSGROUP?= nagios
NAGIOSDIR?= /var/spool/nagios
NAGIOSWWWDIR?= www/nagios
@@ -68,21 +59,19 @@ NAGIOSCGIURL?= ${NAGIOSHTMURL}/cgi-bin
NAGIOSPOLLIP?= 127.0.0.1
NAGIOSPOLLIP6?= ::1
-CONFIGURE_ARGS+=--with-nagios-user=${NAGIOSUSER} \
- --with-nagios-group=${NAGIOSGROUP} \
- --with-cgiurl=${NAGIOSCGIURL} \
+CONFIGURE_ARGS+=--with-cgiurl=${NAGIOSCGIURL} \
--sbindir=${PREFIX}/${NAGIOSWWWDIR}/cgi-bin \
--libexecdir=${PREFIX}/libexec/nagios \
--datadir=${PREFIX}/share \
--sysconfdir=${PREFIX}/etc/nagios \
--localstatedir=${NAGIOSDIR} \
+ --with-perl=${PERL} \
--prefix=${PREFIX}
# Also, force some commands with their expected paths so that they don't get
# disabled.
CONFIGURE_ARGS+=--with-qmail-qstat-command=/var/qmail/bin/qmail-qstat
-CONFIGURE_ENV= PERL=${PERL}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
diff --git a/net-mgmt/monitoring-plugins/distinfo b/net-mgmt/monitoring-plugins/distinfo
index d03369c812e4..7c1b9da3ac5b 100644
--- a/net-mgmt/monitoring-plugins/distinfo
+++ b/net-mgmt/monitoring-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (monitoring-plugins-1.5.99.20140721.tar.gz) = bc82a96d8384ec006d3a8f961e60582af87cc2d0a385d02769e73994af31ea50
-SIZE (monitoring-plugins-1.5.99.20140721.tar.gz) = 2051048
+SHA256 (monitoring-plugins-2.0.tar.gz) = a91b0f68ff00661e0d69f28e3cf577541af98e0f6d09dd014328f132bde6c3fc
+SIZE (monitoring-plugins-2.0.tar.gz) = 2610000
diff --git a/net-mgmt/monitoring-plugins/files/patch-plugins-scripts__check_ircd.pl b/net-mgmt/monitoring-plugins/files/patch-plugins-scripts__check_ircd.pl
index 891fb90b2cbd..fe29c20fd4a8 100644
--- a/net-mgmt/monitoring-plugins/files/patch-plugins-scripts__check_ircd.pl
+++ b/net-mgmt/monitoring-plugins/files/patch-plugins-scripts__check_ircd.pl
@@ -1,6 +1,6 @@
---- ./plugins-scripts/check_ircd.pl.orig 2014-04-27 19:59:06.000000000 +0200
-+++ ./plugins-scripts/check_ircd.pl 2014-05-09 18:45:31.000000000 +0200
-@@ -65,6 +65,7 @@
+--- ./plugins-scripts/check_ircd.pl.orig 2014-07-06 19:55:03.000000000 +0200
++++ ./plugins-scripts/check_ircd.pl 2014-07-29 15:15:32.000000000 +0200
+@@ -66,6 +66,7 @@
$ENV{'PATH'}='@TRUSTED_PATH@';
$ENV{'BASH_ENV'}='';
$ENV{'ENV'}='';
@@ -8,7 +8,7 @@
# -----------------------------------------------------------------[ Global ]--
-@@ -152,7 +153,7 @@
+@@ -153,7 +154,7 @@
print "IRCD UNKNOWN: Could not start socket ($!)\n";
exit $ERRORS{"UNKNOWN"};
}
diff --git a/net-mgmt/monitoring-plugins/files/patch-plugins-scripts__check_ntp.pl b/net-mgmt/monitoring-plugins/files/patch-plugins-scripts__check_ntp.pl
deleted file mode 100644
index f3d08657ca5f..000000000000
--- a/net-mgmt/monitoring-plugins/files/patch-plugins-scripts__check_ntp.pl
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./plugins-scripts/check_ntp.pl.orig 2014-03-04 20:21:36.000000000 +0100
-+++ ./plugins-scripts/check_ntp.pl 2014-04-14 10:22:50.000000000 +0200
-@@ -313,7 +313,6 @@
- }
- } else {
- print "No match!\n" if $verbose;
-- $jitter = '(not parsed)';
- }
-
- }
-@@ -427,7 +426,7 @@
- foreach my $key (keys %ERRORS) {
- if ($state==$ERRORS{$key}) {
- # print ("NTP $key: $answer");
-- print ("NTP $key: $answer|offset=$offset, jitter=" . $jitter/1000 . ",peer_stratum=$stratum\n");
-+ print ("NTP $key: $answer|offset=$offset, jitter=" . ($jitter || 0)/1000 . ",peer_stratum=$stratum\n");
- last;
- }
- }
diff --git a/net-mgmt/monitoring-plugins/files/patch-plugins__check_ssh.c b/net-mgmt/monitoring-plugins/files/patch-plugins__check_ssh.c
index 780f14984e83..041b7bd3fe14 100644
--- a/net-mgmt/monitoring-plugins/files/patch-plugins__check_ssh.c
+++ b/net-mgmt/monitoring-plugins/files/patch-plugins__check_ssh.c
@@ -1,6 +1,6 @@
---- ./plugins/check_ssh.c.orig 2014-04-27 19:59:06.000000000 +0200
-+++ ./plugins/check_ssh.c 2014-05-09 18:45:31.000000000 +0200
-@@ -250,6 +250,7 @@
+--- ./plugins/check_ssh.c.orig 2014-07-06 12:26:39.000000000 +0200
++++ ./plugins/check_ssh.c 2014-07-29 15:15:33.000000000 +0200
+@@ -255,6 +255,7 @@
printf
(_("SSH WARNING - %s (protocol %s) version mismatch, expected '%s'\n"),
ssh_server, ssh_proto, remote_version);
@@ -8,7 +8,7 @@
close(sd);
exit (STATE_WARNING);
}
-@@ -260,6 +261,7 @@
+@@ -273,6 +274,7 @@
(_("SSH OK - %s (protocol %s) | %s\n"),
ssh_server, ssh_proto, fperfdata("time", elapsed_time, "s",
FALSE, 0, FALSE, 0, TRUE, 0, TRUE, (int)socket_timeout));