aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorfarrokhi <farrokhi@FreeBSD.org>2006-11-09 02:08:47 +0800
committerfarrokhi <farrokhi@FreeBSD.org>2006-11-09 02:08:47 +0800
commita708e4c33ab63e2389c88c99e16a98a3e5fd8144 (patch)
tree85d02d4814f9beb9f56d8ee8a1c40ab0ef07acf6 /net-mgmt
parent26308adc4fa8bd4832a44df39eb792df241e7d02 (diff)
downloadfreebsd-ports-gnome-a708e4c33ab63e2389c88c99e16a98a3e5fd8144.tar.gz
freebsd-ports-gnome-a708e4c33ab63e2389c88c99e16a98a3e5fd8144.tar.zst
freebsd-ports-gnome-a708e4c33ab63e2389c88c99e16a98a3e5fd8144.zip
ipsectrace is a simple utility designed to profile the
ipsec traffic (esp and ah) in a pcap capture file. It is somewhat inspired by tcptrace. PR: ports/105137 Submitted by: self Approved by: miwi (mentor)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/ipsectrace/Makefile35
-rw-r--r--net-mgmt/ipsectrace/distinfo3
-rw-r--r--net-mgmt/ipsectrace/pkg-descr5
4 files changed, 44 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 5e2db0a58bc5..64e170004b12 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -73,6 +73,7 @@
SUBDIR += ipcalc
SUBDIR += ipfm
SUBDIR += ipplan
+ SUBDIR += ipsectrace
SUBDIR += ipv6calc
SUBDIR += ipv6gen
SUBDIR += irrtoolset
diff --git a/net-mgmt/ipsectrace/Makefile b/net-mgmt/ipsectrace/Makefile
new file mode 100644
index 000000000000..20819245adbd
--- /dev/null
+++ b/net-mgmt/ipsectrace/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ipsectrace
+# Date created: 2006-11-04
+# Whom: Babak Farrokhi <babak@farrokhi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipsectrace
+PORTVERSION= 0.1.0
+CATEGORIES= net-mgmt security
+MASTER_SITES= http://chewies.net/ \
+ http://farrokhi.net/distfiles/
+
+MAINTAINER= farrokhi@FreeBSD.org
+COMMENT= IPSEC Traffic Profiler
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS} -Wno-deprecated" \
+ LDFLAGS="${LDFLAGS} -lpcap" INCLUDES="${INCLUDES}"
+PLIST_FILES= bin/ipsectrace
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-O2,,g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's,<hash_map>,<hash_map.h>,g' ${WRKSRC}/ipsectrace.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ipsectrace ${PREFIX}/bin/ipsectrace
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600032
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/ipsectrace/distinfo b/net-mgmt/ipsectrace/distinfo
new file mode 100644
index 000000000000..f07f6e22be30
--- /dev/null
+++ b/net-mgmt/ipsectrace/distinfo
@@ -0,0 +1,3 @@
+MD5 (ipsectrace-0.1.0.tar.gz) = d8aa7b8bd918f95386af8d57639de69f
+SHA256 (ipsectrace-0.1.0.tar.gz) = 90c9511c50bf57428d556b965c436d1e50ad71dc21ee635bd6f8fda9411642d1
+SIZE (ipsectrace-0.1.0.tar.gz) = 9635
diff --git a/net-mgmt/ipsectrace/pkg-descr b/net-mgmt/ipsectrace/pkg-descr
new file mode 100644
index 000000000000..08be0c91fdd6
--- /dev/null
+++ b/net-mgmt/ipsectrace/pkg-descr
@@ -0,0 +1,5 @@
+Ipsectrace is a simple utility designed to profile the
+ipsec traffic (esp and ah) in a pcap capture file.
+It is somewhat inspired by tcptrace.
+
+WWW: http://freshmeat.net/projects/ipsectrace/