aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-07-28 23:16:44 +0800
committervanilla <vanilla@FreeBSD.org>2014-07-28 23:16:44 +0800
commitcb1d26048d9aae085a9f6c5635b82bdf7c8a2e9f (patch)
treef506f14c16fa2301981f056aa0de8cb93c158bd4 /net-mgmt
parent7f0340d724eef289455cc597b8a927028087f529 (diff)
downloadfreebsd-ports-gnome-cb1d26048d9aae085a9f6c5635b82bdf7c8a2e9f.tar.gz
freebsd-ports-gnome-cb1d26048d9aae085a9f6c5635b82bdf7c8a2e9f.tar.zst
freebsd-ports-gnome-cb1d26048d9aae085a9f6c5635b82bdf7c8a2e9f.zip
Stagify.
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios-snmp-plugins-extras/Makefile15
-rw-r--r--net-mgmt/nagios-snmp-plugins-extras/pkg-plist1
2 files changed, 8 insertions, 8 deletions
diff --git a/net-mgmt/nagios-snmp-plugins-extras/Makefile b/net-mgmt/nagios-snmp-plugins-extras/Makefile
index b657a782e9d0..0d43161461ca 100644
--- a/net-mgmt/nagios-snmp-plugins-extras/Makefile
+++ b/net-mgmt/nagios-snmp-plugins-extras/Makefile
@@ -10,15 +10,17 @@ MASTER_SITES= ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
MAINTAINER= ports@FreeBSD.org
COMMENT= Set of Nagios plugins written in Perl to check devices with SNMP
+LICENSE= GPLv2
+
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
+SHEBANG_FILES= ${PLUGINS}
RUN_DEPENDS+= p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
${LOCALBASE}/libexec/nagios/utils.pm:${PORTSDIR}/net-mgmt/nagios-plugins
-PLUGINS= \
- check_snmp_boostedge.pl \
+PLUGINS= check_snmp_boostedge.pl \
check_snmp_cpfw.pl \
check_snmp_css.pl \
check_snmp_css_main.pl \
@@ -31,20 +33,19 @@ PLUGINS= \
check_snmp_process.pl \
check_snmp_storage.pl \
check_snmp_vrrp.pl \
- check_snmp_win.pl \
+ check_snmp_win.pl
PLIST_FILES= ${PLUGINS:S,^,libexec/nagios/,}
WRKSRC= ${WRKDIR}/plugins
-NO_STAGE= yes
post-extract:
${SED} -i "" -e "s#/tmp/#/var/tmp/#" \
-e "s#/usr/local/nagios/libexec#${LOCALBASE}/libexec/nagios#" \
${PLUGINS:S,^,${WRKSRC}/,}
do-install:
- ${MKDIR} ${PREFIX}/libexec/nagios
- ${INSTALL_SCRIPT} ${PLUGINS:S,^,${WRKSRC}/,} ${PREFIX}/libexec/nagios/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${PLUGINS:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/libexec/nagios/
.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-snmp-plugins-extras/pkg-plist b/net-mgmt/nagios-snmp-plugins-extras/pkg-plist
deleted file mode 100644
index 70333e5eb62f..000000000000
--- a/net-mgmt/nagios-snmp-plugins-extras/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-@dirrmtry libexec/nagios