aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-05-22 21:15:13 +0800
committermat <mat@FreeBSD.org>2018-05-22 21:15:13 +0800
commitcff6da1b7fcbd896785c044bbdfe462c9fb1a74c (patch)
treec832b87b776a5db072088687b910601d961726da /net-mgmt
parent9304895709a6f8eba3df00bc5410b6f5dbe8382f (diff)
downloadfreebsd-ports-gnome-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.tar.gz
freebsd-ports-gnome-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.tar.zst
freebsd-ports-gnome-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.zip
Add PY_FLAVOR to Python module dependencies.
Sponsored by: Absolight
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/librenms/Makefile2
-rw-r--r--net-mgmt/observium/Makefile2
-rw-r--r--net-mgmt/pdagent-integrations/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/net-mgmt/librenms/Makefile b/net-mgmt/librenms/Makefile
index aac727459d8b..d1771efbf2b8 100644
--- a/net-mgmt/librenms/Makefile
+++ b/net-mgmt/librenms/Makefile
@@ -69,7 +69,7 @@ IPMITOOL_RUN_DEPENDS= ipmitool:sysutils/ipmitool
LIBVIRT_RUN_DEPENDS= virsh:devel/libvirt
NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:net-mgmt/nagios-plugins
NMAP_RUN_DEPENDS= nmap:security/nmap
-PYPOLLER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.3:databases/py-MySQLdb
+PYPOLLER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.3:databases/py-MySQLdb@${PY_FLAVOR}
PYPOLLER_VARS= PY_MYSQL=:2.7
X11_RUN_DEPENDS= Magick-config:graphics/ImageMagick \
mtr:net/mtr
diff --git a/net-mgmt/observium/Makefile b/net-mgmt/observium/Makefile
index 47393e4d2bd0..5970a67cff86 100644
--- a/net-mgmt/observium/Makefile
+++ b/net-mgmt/observium/Makefile
@@ -55,7 +55,7 @@ IPMITOOL_RUN_DEPENDS= ipmitool:sysutils/ipmitool
LIBVIRT_RUN_DEPENDS= virsh:devel/libvirt
NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:net-mgmt/nagios-plugins
NMAP_RUN_DEPENDS= nmap:security/nmap
-PYPOLLER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>0:databases/py-MySQLdb
+PYPOLLER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>0:databases/py-MySQLdb@${PY_FLAVOR}
PYPOLLER_VARS= PY_MYSQL=:2.7
SVN_RUN_DEPENDS= svn:devel/subversion
WMIC_RUN_DEPENDS= wmic:net-mgmt/wmi-client
diff --git a/net-mgmt/pdagent-integrations/Makefile b/net-mgmt/pdagent-integrations/Makefile
index 2b0fd8ef3277..100fe3ebe0d4 100644
--- a/net-mgmt/pdagent-integrations/Makefile
+++ b/net-mgmt/pdagent-integrations/Makefile
@@ -11,7 +11,7 @@ COMMENT= PagerDuty integrations for monitoring monitoring tools
LICENSE= BSD3CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pdagent>0:net-mgmt/py-pdagent
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pdagent>0:net-mgmt/py-pdagent@${PY_FLAVOR}
USES= python:2.7 shebangfix