aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2006-08-15 15:30:59 +0800
committertobez <tobez@FreeBSD.org>2006-08-15 15:30:59 +0800
commitebd159dadfbf0db432182d647e9140c5bbbffd5d (patch)
tree1564e179e7aaba7a6c59628803897287f7ef157e /net-mgmt
parent60e8f65738f67570423ff9a3aaed82db30b824fd (diff)
downloadfreebsd-ports-gnome-ebd159dadfbf0db432182d647e9140c5bbbffd5d.tar.gz
freebsd-ports-gnome-ebd159dadfbf0db432182d647e9140c5bbbffd5d.tar.zst
freebsd-ports-gnome-ebd159dadfbf0db432182d647e9140c5bbbffd5d.zip
Add p5-Net-IP-Match-Regexp 0.94, efficiently match IP addresses against
IP ranges via regexp. PR: ports/102017 Submitted by: Timur I. Bakeyev <bat at cpan.org>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/p5-Net-IP-Match-Regexp/Makefile31
-rw-r--r--net-mgmt/p5-Net-IP-Match-Regexp/distinfo3
-rw-r--r--net-mgmt/p5-Net-IP-Match-Regexp/pkg-descr12
-rw-r--r--net-mgmt/p5-Net-IP-Match-Regexp/pkg-plist4
5 files changed, 51 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index edb28f4ee935..459285660b8e 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -132,6 +132,7 @@
SUBDIR += p5-NSNMP
SUBDIR += p5-Net-CIDR
SUBDIR += p5-Net-IP
+ SUBDIR += p5-Net-IP-Match-Regexp
SUBDIR += p5-Net-IP-Match-XS
SUBDIR += p5-Net-IP-Resolver
SUBDIR += p5-Net-IPv4Addr
diff --git a/net-mgmt/p5-Net-IP-Match-Regexp/Makefile b/net-mgmt/p5-Net-IP-Match-Regexp/Makefile
new file mode 100644
index 000000000000..91891f984bc2
--- /dev/null
+++ b/net-mgmt/p5-Net-IP-Match-Regexp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: net-mgmt/p5-Net-IP-Match-Regexp
+# Date created: 1 Aug 2006
+# Whom: Timur I. Bakeyev <bat@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-IP-Match-Regexp
+PORTVERSION= 0.94
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bat@cpan.org
+COMMENT= Efficiently match IP addresses against IP ranges via regexp
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_MODBUILD= yes
+
+MAN3= Net::IP::Match::Regexp.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/p5-Net-IP-Match-Regexp/distinfo b/net-mgmt/p5-Net-IP-Match-Regexp/distinfo
new file mode 100644
index 000000000000..5cde13b854d8
--- /dev/null
+++ b/net-mgmt/p5-Net-IP-Match-Regexp/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-IP-Match-Regexp-0.94.tgz) = be72946b8fc39c641b8b1842d4036b06
+SHA256 (Net-IP-Match-Regexp-0.94.tgz) = 3400e10d232d277b85ba6c0173896f21552a6eb43630c782c4dde908231a0939
+SIZE (Net-IP-Match-Regexp-0.94.tgz) = 20116
diff --git a/net-mgmt/p5-Net-IP-Match-Regexp/pkg-descr b/net-mgmt/p5-Net-IP-Match-Regexp/pkg-descr
new file mode 100644
index 000000000000..137ad191da04
--- /dev/null
+++ b/net-mgmt/p5-Net-IP-Match-Regexp/pkg-descr
@@ -0,0 +1,12 @@
+Net::IP::Match::Regexp allows you to check an IP address against one or
+more IP ranges. It employs Perl's highly optimized regular expression
+engine to do the hard work, so it is very fast. It is optimized for
+speed by doing the match against a regexp which implicitly checks the
+broadest IP ranges first. An advantage is that the regexp can be
+computed and stored in advance (in source code, in a database table,
+etc) and reused, saving much time if the IP ranges don't change too
+often. The match can optionally report a value (e.g. a network name)
+instead of just a boolean, which makes module useful for mapping IP
+ranges to names or codes or anything else.
+
+WWW: http://search.cpan.org/dist/Net-IP-Match-Regexp/
diff --git a/net-mgmt/p5-Net-IP-Match-Regexp/pkg-plist b/net-mgmt/p5-Net-IP-Match-Regexp/pkg-plist
new file mode 100644
index 000000000000..c24627d29455
--- /dev/null
+++ b/net-mgmt/p5-Net-IP-Match-Regexp/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Net/IP/Match/Regexp.pm
+@dirrmtry %%SITE_PERL%%/Net/IP/Match
+@dirrmtry %%SITE_PERL%%/Net/IP
+@dirrmtry %%SITE_PERL%%/Net